Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


Search the Community

Showing results for tags 'hc2'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • FIBARO Community
    • FIBARO Portal and Forum policy
    • FIBARO
    • Say hello!
    • Off-topics
  • FIBARO Update
    • FIBARO System Update
    • FIBARO Mobile Update
  • FIBARO Community Support
    • Scenes and Interface
    • FIBARO Products
    • FIBARO Mobile
    • FIBARO HomeKit
    • FIBARO Assistant Integrations
    • Other Devices / Third-party devices
    • Tutorials and Guides
    • Home Automation
    • Suggestions
  • FIBARO Społeczność
    • FIBARO
    • Przywitaj się!
    • Off-topic
  • FIBARO Aktualizacja
    • FIBARO System Aktualizacja
    • FIBARO Mobile Aktualizacja
  • FIBARO Wsparcie Społeczności
    • Sceny i Interfejs
    • FIBARO Urządzenia
    • FIBARO Mobilnie
    • FIBARO HomeKit
    • Integracja z Amazon Alexa i Google Home
    • Urządzenia Firm Trzecich
    • Poradniki
    • Automatyka Domowa
    • Sugestie

Categories

  • Scenes
  • Virtual Devices
  • Quick Apps
  • Icons

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Facebook


Google+


Skype


Website URL


WhatsApp


Country


Gateway/s


Interests

  1. Hi everyone, Can someone help me, I am trying to enter my HC2 without success; I need help. The HC2 is connected, the blue lights stop telling me on and connected to my network but the Fibaro Finder cannot find it. Just in case I have also used an "Advanced IP Scanner" program to find it but nothing. I have rebooted, forced to delete all content hoping that something would happen but nothing ... I don't know what else to do since it won't let me in. Anyone who has any idea what I can try ???
  2. Hi! The HeatIt Z-Smoke is a combined Smoke/Motion/Temperature detecor. I have just realised that the support for Z-Smoke in HC2 is faulty. Here is what happens: The Z-Smoke motion detector will NOT trigger the Motion Detector device in HC2, but will trigger the Smoke detector device (!): The motion detector device will stay "Unbreached". I have made contact with HeatIt customer support, who has confirmed that this is a known bug and states clearly that this is a Fibaro problem. My previous experience with Fibaro indicates that getting this fixed will be a walk in the desert. Customer support also states that the problem is fixed in HC3. But I am NOT buying a new hub to fix this stupid error. Therefore: Has anyone a LUA workaround for HC2 for this potentially very useful detector?
  3. Hi! I have a electric meter Aeotec but it shows incorrect data. I consume about 1500kWh a day, but the values that I see are much lower. I put these parameters (2picture) on what I think is a total clamp, but nothing has changed. I tried to make associations for all the clamps, but I can't understand what exactly needs to be noted (3picture).Or should I have set these parameters to all 4 clamps? I will be grateful for all the advice. Thank you!
  4. I have a in wall toggle switch that i connected to my HC2 (latest version). it has been working great until now. The device will be working and then becomes "dead" "communication problem". if i awake the dead node and press turn off/on it says "transfer OK" and turns on/off the light. it stays this way for a while then goes dead again. Distance should not be an issue as it is about 10 feet from HC2. all other devices and scenes are working. I do not understand why this device keeps going dead even though it can still receive a command. Can someone help me understand what is happening and/or have a solution?
  5. Hello All, I am looking for some help to create a virtual device for a epson projector that utilizes the PJLink protocol. that way it could be used for a lot of different projectors. I am a newbie and have little experience with coding, Any help would be gtreatly appreciated.
  6. Hi I have to understand the Quick app HC2 code to make the same app to HC3. This Quick App control Multiroom AMCP MR4.50-XT - 4 Zones with Itach RS232 Serial Interface. I do not understand where in the LUA Code call function like above: local ID_VD = fibaro:getSelfId() fibaro:call(ID_VD, "pressButton", "6") fibaro:sleep(600) fibaro:call(ID_VD, "pressButton", "16") fibaro:sleep(600) fibaro:call(ID_VD, "pressButton", "26") fibaro:sleep(600) fibaro:call(ID_VD, "pressButton", "36") fibaro:sleep(300) Where I need to looking for some information about this code? MULTIROOM.vfib
  7. I am looking to by a z-wave siren which is fully implemented in HC2, with templates for the parameters. Any suggestions? I was initially thinking of the Aeotec Siren 6, but other threads seem to indicate that it is not supported in HC2 (and only for some FW-versions in HC3). What about other sirens? Any good experience to be shared?
  8. Version 1.0.0

    25 downloads

    This VD is a interface to the ping_shelly.lua which can also be found here. The IP-address needs to be configured as shown in the image. The port value ("109") is used/misused to set the number of the lua script in your HC2 ("_lua"). As example here the code for the "on" button: local _self=fibaro:getSelfId() local _addr=fibaro:getValue(_self,"IPAddress") local _lua=fibaro:getValue(_self,\"TCPPort\") fibaro:startScene(_lua,{_addr,"on"}) fibaro:sleep(1000) fibaro:startScene(_lua,{_addr}) fibaro:sleep(1000) local _slider = tonumber(fibaro:getGlobalValue("S" .. string.gsub(_addr,"%.","_"))) if (_slider <= 0) then _slider=10 fibaro:startScene(_lua,{_addr,_slider}) end fibaro:call(_self,"setProperty","ui.brightness.value",_slider)
  9. Version 1.0.0

    8 downloads

    v 1.1 22/05/2021 This scene polls if a Shelly Vintage bulb is online and sets its state. The default state is "opposite" which is converted to legal values "on" or "off". When state is a numeric value it is interpreted as brightness setting. Also, this scene can be called from another scene as fibaro:startScene(number_of_this_scene,{ip_number,a_state_as_described_above}); Things are complicated by the asynchronous character of the http call. With many thanks to jgab for the solution to this challenge. There is now also a VD based on this lua.
  10. Some of my devices are randomly becoming dead nodes and will not communicate. I have tried reconfiguring the z-wave network for neighbors but no luck. Any suggestions? I am on HC2 running the latest software update (it happened before I updated to the latest update)
  11. Once the alarm is activated I need to wait for the delay (60 seconds in my case) until the system is armed and THEN run a Scene. I can easily run the Scene at the same time the alarm is activated but cannot find any event or trigger for when the alarm is actually armed. Any assistance greatly appreciated.
  12. I'm not sure how important it is, but I jump into this hole "lastWorkingRoute and neighborList shemas are changed from HC2 to HC3 HC2 /api/devices/id produces JSON wtih following: "lastWorkingRoute": "[1,422,59]" HC3 /api/devices/ID produces a bit changed JSON: "lastWorkingRoute": [1,422,59] What is difference - HC2 gives me string representation of array but HC3 gives me array. For developer perspective this is quite big difference (agree - important only for tech apps) Is there SOMEWHERE some kind of DOCUMENTATION of that kind things, changes, schemas Both HC2 /docs and and HC3 swagger lack several important interfaces like /api/energy and /api/temperature why they are hidden or where to find SOME kind of reference
  13. I have a Jasco in-wall dimmer (26932). When I go to add it (by selecting or deselecting every option) the device adds and it says configuration finished. But when I go to the devices they all say not configured. It turns off the switch and when motion is detected it turns the switch back on, but the motion does not indicate a breach. It also added two lights for some reason. Does anyone have advise on resolving this issue or should I try another brand of in wall dimmer? I am tired of Fibaro not being able to add all of my devices properly!! HC2 4.600 device is 2” away from antenna
  14. When I tried to include a new device (a Sensative Strip), the HC2 responded by displaying the message "Requesting neighbours, please wait" every 5 seconds. The device was not included. I have been through this twice now, once with "Network wide inclusion" checked, the other without. The only way to terminate the loop is to restart the HC2. What is going on? My software version is 4.600. I re-meshed the entire network between the first and second attempt, to make sure that the z-wave mesh is OK. What else can I do?
  15. While working from home for eight months now I had the need to toggle a light or run a scene from my Windows 10 laptop. After some Google I didn't find an app so I decided to learn basic C# and create a Windows tray application myself. The application loads your configured rooms, devices and scenes from your HC2/HC3 and puts them in a menu in the system tray. Now you can run a scene or toggle a light switch without reaching for a wall switch or your phone. ? The program looks like this: I Iearn and get a lot from the Fibaro community, therefore I made the code open source on GitHub. You can download the application from the releases page. You only need the .exe file. I don't own a HC3. If it also works on the HC3 please inform me. Than I add it to the documentation.
  16. I have installed a Sensative Strip Drip to alert me about water leaks. The device works as planned, and was recently triggered. On the HC2 it indicated "breached", and the icon turned red. But I received no push message to my phone! I know I have the push system set up, as I regularly receive messages from other units. Typically, thermostats and temperature measurements, where "possible fire" and "freezing" are indicated when temperatures exceed those limits. I must have missed something to make the Sensative Strip trigger a push message in a similar way. What do I need to do? I have not set up an alarm panel yet. Is that necessary to make such devices with alarm frames trigger push messages or e-mails? And what about third party smoke alarms - do they need to be included in an alarm panel to trigger push messages or other alerts?
  17. Evening all. I have been having some scene issues just recently where scenes that have worked for months just stopped working so took it on myself to reboot my HC2 Black. It is now stuck on starting services. I have used the power button on the back and killed the power via the mains and nothing will get it out of starting services. I have E-Mailed support and no response as of yet. I have tried a repair is recovery mode and this has not helped. As i have 100 physical devices, i do not want to wipe the box as it would take weeks to get t back u and running. The bios loads with no errors on screen and the hc2 rests on the normal screen when booted. I have no idea how to restore from the cloud as I can't find any documentation how to carry it out. Can anyone help on this issue of starting services and also answer this question. If i wipe the hc2 and it comes back to life, how do i perform a recovery of a previous backup to the hc2? Thanks, Hal
  18. I have used a LUA script which is triggered by pushing the switch 2 on a Fibaro switch. Depending on whether the key is pushed once, twice or held, I control another device (a light) according to set rules. How the key is pushed, is found by the variable pressSource = fibaro:getSourceTrigger().event.data. This solution has been used previously by several contributors on the forum. My current code looks like this (only first part shown): --[[ %% properties %% events 394 CentralSceneEvent %% globals --]] -- Uses first slave for "CentralSceneEvent" ID (not master, not switch itself). Here 394 local trigger = fibaro:getSourceTrigger() if (trigger.type == "other") then fibaro:debug("Scene started by clicking 'start' button") else local pressSource = fibaro:getSourceTrigger().event.data fibaro:debug("New: CentralSceneEvent received from key: " .. pressSource.keyId) if (pressSource.keyId == 2) then local ledId = "306" local ledValue = fibaro:getValue(ledId, "value") if pressSource.keyAttribute == "Pressed" then fibaro:debug("Pressed") if ledValue == "0" then fibaro:call(ledId, "turnOn") else fibaro:call(ledId, "turnOff") end elseif pressSource.keyAttribute == "Pressed2" then fibaro:debug("Pressed 2 times") fibaro:call(ledId, "setValue", "100") elseif pressSource.keyAttribute == "HeldDown" then -- etc. (complete code not shown) I now want to add a second trigger, i.e. another Fibaro switch being pushed. Depending on which switch is used, I want different lights to be adjusted. Below is my first edit (still incomplete). In line 5, the new trigger 494 is added. How do I know if the scene was triggered by 394 or 494? The answer is probably in fibaro:getSourceTrigger(), but I cannot find the complete specification for this function documented anywhere. Specifically: - How do I find whether 394 or 494 was the trigger? The syntax trigger.event.id in line 14 is my guest guess. What is correct? - Once I have the right triggerID, I can easily make the variable ledID dependent on triggerID, by having two related lists (arrays): {394, 494} for the triggers and {306, 406} for the corresponding LED lights. This needs to be implemented in line 18. Can anyone please provide a more complete specification for the data returned by fibaro:getSourceTrigger in HC2, and show me how I can use it to implement double triggers? Or are you all too busy converting to HC3? PS: I have simplified this to TWO triggers. In reality I want to have several more. But if I can do two, I can do any number. --[[ %% properties %% events 394 CentralSceneEvent 494 CentralSceneEvent -- <<--- NEW TRIGGER %% globals --]] -- Uses first slave for "CentralSceneEvent" ID (not master, not switch itself). Here 394 and 494 respectively. local trigger = fibaro:getSourceTrigger() if (trigger.type == "other") then fibaro:debug("Scene started by clicking 'start' button") else local triggerID = trigger.event.id -- <<--- WHAT IS CORRECT SYNTAX?? local pressSource = fibaro:getSourceTrigger().event.data fibaro:debug("New: CentralSceneEvent received from key: " .. pressSource.keyId) if (pressSource.keyId == 2) then local ledId = "306" -- <<<< NEEDS TO BE CHANGED TO CORRESPOND TO triggerID local ledValue = fibaro:getValue(ledId, "value") if pressSource.keyAttribute == "Pressed" then fibaro:debug("Pressed") if ledValue == "0" then fibaro:call(ledId, "turnOn") else fibaro:call(ledId, "turnOff") end elseif pressSource.keyAttribute == "Pressed2" then fibaro:debug("Pressed 2 times") fibaro:call(ledId, "setValue", "100") elseif pressSource.keyAttribute == "HeldDown" then fibaro:debug("HeldDown") -- etc. (complete code not shown)
  19. I have experienced this with several third-party devices, but I will use a HeatIt 32A relay as my example. I needed to soft reconfigure this device today, expecting device numbers etc. to remain unchanged. The result, however, was puzzling: The general structure of master + slave devices changed! This device has no template implemented, but I expected the end-points to remain where they were. The reconfiguration was reported as successful by the HC2, but the results were suprising. Here is a summary of what I experienced: Tree before re-configuration (685 is the master device number): 685 ----------- 685.0 On/off Device ID 686 685.0.1 Amperes Device ID 687 685.1 On/off 688 685.1.1 Amperes 689 685.2 multichannel 690 685.2.1 Temperature 1 691 685.3 multichannel 692 685.3.1 Temperature 2 693 685.4 Flooding 694 ... and here is the same device after a "successful" soft reconfiguration (scroll to see the whole list): Notice that The number of slave devices is the same, but the naming is different. I now have two devices called 685.2.1, and two called 685.3.1. The first one retained the name I had given it, rather than 685.0. Good! The device called 685.4, a flood sensor, has been moved to another location in the tree, but retained its name Some device ID numbers changed (not shown on this screenshot). The first four slaves retained the numbers 686 to 689. The flood sensor 685.4 also retained its ID number 694. But the four temperature related devices (id 690 - 693 originally) were given new id numbers (709 - 712). This is not what is supposed to happen with a SOFT reconfigure. Both structure and id numbers should remain unchanged. I have experienced the same thing with HeatIt thermostats. A soft reconfigure changes the structure, naming and some device id's, making a soft reconfigure a risky operation. What else can I do? A hard reconfigure, losing all device ID's? Keep trying a soft reconfig?
  20. Has anyone also experienced the disappearance of devices suddenly. It happened to me twice with a Fibaro motionsensor and it was not the same device. I came to notice it yesterday evening when suddenly the lights were not responding, at first I performed a restart of the HC2, but that did ofcourse not help. Looking deeper into the devices and remembering from a while ago, I saw one motionsensor was missing. After adding it again (I did not had remove it) everything was fine again, scenes running with no errors. What can be the cause for devices to be removed from the HC2?
  21. Hi, I have several problems to get my HUE lights working white my Fibaro HC2. I have made a scene for my bathroom just to turn on and off the light in combination white a motion sensor. This is working fine but the light is always changing back to the warm color after about 24 hours. So i like to set the color by a LUA command. I used the debug function for the settings (see below) --[[ %% properties %% events %% globals --]] fibaro:debug(fibaro:getValue(162, "ui.brightness.value")) fibaro:debug(fibaro:getValue(162, "ui.saturation.value")) fibaro:debug(fibaro:getValue(162, "ui.hue.value")) If i change the Brightness on the HUE app the value changed. But the saturation and HUE value doesn't change at all. Whats the problem? is it a error of the Hue bridge (square one) or anything else??? This Youtube example looks oke to me: All you input is welcome and of course i can provite more information if necessary. Thank you in advance. Michel
  22. Mogę się zalogować , obsługiwać włączniki itp , ale nie mogę zapisać sceny mam cały czas taki komunikat: acces forbidden 403 a co chodzi >??? HC2
  23. Witajcie forumowicze, Rozpoczynam wątek połączenia HC2 z rekuperatoremp polskiej firmy reQnet. Dostałem od działu progrmistuów REST API do tego rekuperatora. Na tą chwilę czekam na wszystkie zabawki jak dojadą. Jeśli ktoś z Was posiada rekuperator reqnet proszę o info. Razem raźniej. https://reqnet.pl *** Hello forum members, I am starting the topic of connecting HC2 with an air ventilation unit from the Polish company reQnet. I got a REST API for this unit from the programming department. At the moment I am waiting for all the toys when they arrive. If any of you have a reqnet air unit, please let me know. Better together. https://reqnet.pl
  24. Hi, Lately I suddenly have to restart my HC2 (4.590) often to get the push notifications working again. Anyone have any idea why this is? Thank you in advance!! Kevin
  25. Hello everybody, I was wondering is it possible to develop a plugin for HC2, I'd like to connect my Sonoff devices to my HC. But i have to use ewelink-API but i can't import it into the Lua code. I've successfully that API into Homey app on Homey pro. I was hoping to do the same with Fibaro Home center. anyone has an idea how this could be done. Thanks in advance
×
×
  • Create New...