Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Temperature sensor and relay as thermostat


Stealth
 Share

Question

I'm having an issue with getting the Heating Panel to work!

 

 

I have the following modules -

 

1) Fibaro Universal Module FGBS-001

 

2) Fibaro FGS-211 Relay Module

 

3) Dallas DS8b20 Temperature sensor

 

I want to use these parts as a thermostat to control my hot water boiler. (i.e. temperature sensor on the hot water tank, when temperature drops below a threshold (between certain times of the day) the relay will answer the call for heat at the boiler by switching it on)

 

I have added these modules to the HC2 but I am having problems trying to get them to be controlled by the heating panel.

 

This is what I have done -

 

a) I put the temperature sensor and the relay in a room named 'Water Tank'

 

b) I have linked the temperature sensor and relay in the linked devices panel and named it Linked Hot Water

c) I created a zone in the heating panel named 'Heat Control' then added the room 'Water Tank' to it

 

d) I then set the temperature required with the day and time in the 'Heat Control' zone panel.

 

But when the water temperature drops below the threshold set the relay won't switch on.

 

What have I missed?

 

Thanks

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello,

 

I have done the same, and mine is working, i cannot find what you missed?

Maybe the only thing i see is b. by linked devices, room "water tank"??

Maybe you forgot?

 

Peter

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Hi Peter,

     

    Thank you for your reply...  I seem to have got it working by going into the 'General' settings of both the relay switch and the temperature sensor and clicking on the name of the device listed under 'Slave'.  I did the same on the temperature sensor general settings i.e. clicked on the name of the device under the 'Slave' heading then saved,  It now appears to work ok.

     

    To further test this fix.  I deleted both the devices and then re added them.  The same fault came back i.e. the devices didn't work in tandem.  I then tried the same fix above and its working again ok.

     

    It looks like the 'Linking' of devices may not be propagating through the system completely?

     

    Just out of interest what version of firmware are you using and was it an order version you used when you added your devices?

     

    I'm using the current 4.033 which I'm learning has a few bugs, maybe this is another one?

     

    Steve 

    Link to comment
    Share on other sites

    • 0

    Hello Steve,

     

    Nice that its working now!

    I use 3.600 because i have a satel alarm system and its not working any more in 4.0xx.

    I added the devices temp sensor in the first 3.xxx and de switch at the same moment i make the link.

    I cannot remember that i had any problem?

     

    Peter

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...