Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

HCL Virtual Device & Domoticz


augerv
 Share

Question

Hi this is my first post!

 

For a long time now I have been trying to get my HCL to send a string to my Raspberry Pi running Domoticz, I have managed to get weather and other devices to feed into the HCL but cannot get the HCL to control lights when setting up a virtual device.

 

Can anyone help me, if I put the below into IE I can turn the light On:

 

Please login or register to see this link.

 

If I put the below string into HCL under a virtual device nothing happens:

 

GET /json.htm?type=command&param=switchlight&idx=25&switchcmd=On&level=00x0D0x0A

 

What I want to be able to do is control my LightwaveRF devices from my HCL.

 

All the LightwaveRF devices are working on Domoticz on the Raspberry Pi

 

Could anyone tell me what I am doing wrong?

 

Many thanks

Vince

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0
  • Inquirer
  • Hi I've tried it that way works fine if I paste into Internet Explore/chrome etc.

    Nothing happens when I put into HCL

    Please login or register to see this image.

    /emoticons/default_sad.png" alt=":(" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Still haven't managed to get this working

    Please login or register to see this image.

    /emoticons/default_icon_cry.gif" alt=":cry:" />

    Link to comment
    Share on other sites

    • 0

    hello

    so i think that the fibaro link under domoticz setting is only for data from Domoticz to Fibaro? i ask this because i found this post at the end of my search about info for controll philips hue light that i have correctly installed on domoticz, from a fibaro HCL.

    any chanche? thanks

    Link to comment
    Share on other sites

    • 0

    after test i see that my hcl every time that i put the correct json string, when i push save button, the system change it !

    this is the reason because not function.

    example:

    i put in the on button of the virtual device the correct json string:

    Please login or register to see this link.

    command&param=switchlight&idx=17&switchcmd=On&level=0

     

    after pushed save , the systen change it in:

    Please login or register to see this link.

    command¶m=switchlight&idx=17&switchcmd=On&level=0

     

     

    And now? how we can fix it?

    Link to comment
    Share on other sites

    • 0

    Hi this is my first post!

     

    For a long time now I have been trying to get my HCL to send a string to my Raspberry Pi running Domoticz, I have managed to get weather and other devices to feed into the HCL but cannot get the HCL to control lights when setting up a virtual device.

     

    Can anyone help me, if I put the below into IE I can turn the light On:

     

    Please login or register to see this link.

     

    If I put the below string into HCL under a virtual device nothing happens:

     

    GET /json.htm?type=command&param=switchlight&idx=25&switchcmd=On&level=00x0D0x0A

     

    What I want to be able to do is control my LightwaveRF devices from my HCL.

     

    All the LightwaveRF devices are working on Domoticz on the Raspberry Pi

     

    Could anyone tell me what I am doing wrong?

     

    Many thanks

    Vince

    don't use 

    GET /json.htm?type=command&param=switchlight&idx=25&switchcmd=On&level=00x0D0x0A

     

    but:

    GET /json.htm?type=command&dparam=switchlight&idx=25&switchcmd=On&level=HTTP/1.10x0D0x0A0x0D0x0A

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thanks for the reply I have tried the above and again works fine from Internet Explorer but when put in HCL nothing happens.

    Please login or register to see this image.

    /emoticons/default_sad.png" alt=":(" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    Link to comment
    Share on other sites

    • 0

    I am facing the same issue - i.e. the string works in Internet Explorer but not within a Virtual Device in an HCL.  Did anyone get an answer to this?

     

    IGNORE - I worked in out.....

     

    thanks

    Edited by sitaylor
    Link to comment
    Share on other sites

    • 0

    I have a virtual switch in fibaro and a normal switch in domoticz. (on/off)

    I use the virtual switch to set the switch in domoticz on or off

    And i use this for switch on.     GET /json.htm?type=command&param=switchlight&idx=133&switchcmd=On HTTP/1.10x0D0x0A0x0D0x0A

     

    And this for switch off . GET /json.htm?type=command&param=switchlight&idx=133&switchcmd=Off HTTP/1.10x0D0x0A0x0D0x0A
     

    And ik works for me.

     

    Rob

     

    Link to comment
    Share on other sites

    • 0

    Can someone please advise whether it is possible to manage multiple switches in the same String?

     

    For 1 switch, this works fine (as outlined by others above):

    GET /json.htm?type=command&param=switchlight&idx=13&switchcmd=Off HTTP/1.10x0D0x0A0x0D0x0A

     

    But how to do multiple switches at the same time?, ie:

    GET /json.htm?type=command&param=switchlight&idx=13&switchcmd=Off

    GET /json.htm?type=command&param=switchlight&idx=14&switchcmd=Off

    GET /json.htm?type=command&param=switchlight&idx=15&switchcmd=Off

    HTTP/1.10x0D0x0A0x0D0x0A

     

    or 

    GET /json.htm?type=command&param=switchlight&idx=13,14,15&switchcmd=Off

     

    thanks

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...