Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
  • 0
Svartbacken

Family Members Locations

Question

Hi

 

I have just hade my HC2 for a week or so. But can’t get user locations to work. I have enabled GPS tracking every 15 minutes on the members of my family. I have logged in the iOS app with separate users. But I can’t seem to get any location data in my HC2. I can see on of the family members in the “Your House” view but there are no location data. Am I doing something wrong or doesn’t this work on 4.035?

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Hi,

 

Can you check the results under your 

Please login or register to see this link.

and check if all users' hasGPS is set to true/false.

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • Tanks

     

    I looked under api/users and I see that all users except me “hasGPS":false”. All users including me have iPhone 5 or 6 with iOS 8. But I know I tested the app on an Android phone. That may be why I can see med under My House as a user but without any location data.

    I checked in the HC2 and all users have “How frequently GPS position from the user’s iPhone should be collected” set to 15 min.

    Share this post


    Link to post
    Share on other sites
    • 0

    I've seen some users posting on this forum stating that their family tracking is not available on their ios devices as well.

     

    Anyway have you contacted fibaro support yet?

    Share this post


    Link to post
    Share on other sites
    • 0

    Heh, I've never noticed the link to where family is .. you learn something new every day !

    .. mine just sends me random messages about where i am, so i guess something gps is working, but it usually occurs when i'm not actually where it tells me i am, but the family screen is blank anyways ..

    oh well... put it on the bugzilla list i suppose .. ..

     

    al.

    Share this post


    Link to post
    Share on other sites
    • 0

    I have the same problem

    I checked users and all have :

    Please login or register to see this code.

    Form where can change this.

     

    (I have iphone 6, login with other user , .... )

    Share this post


    Link to post
    Share on other sites
    • 0

    For the first time, I finally get to see the 'Family' panel/section popping up.

     

    I am still not certain what I did that make GPS (partially) work or make the 'Family' panel/section shows up. Here are the steps I took:

     

    1. Configure "How frequently GPS position from the user’s iPhone should be collected" for the user account in HC2;

    2. Create a scene which polls for GPS position of the user.
    (I started with a test scene that polls user appears in vicinity of home, radius 300m then sends an email notification).

    3. Launch Fibaro app for iPhone and ensure it is logon via remote access, not direct IP to HC2.

    4. Launch Settings (iPhone), go to privacy | locations menu and check if Fibaro app is set to 'Always'.
    (Mine always turn empty whenever Fibaro app closes or reconnects and had to manual set to 'Always' again at each launch or reconnect of Fibaro app)

    5. Go back to Fibaro app for iPhone and ensure it is the active app on iPhone screen.

    6. Go to HC2, run the scene several times with a short interval in between. If you receive the email notification, that means GPS tracking is finally working (temporarily).

    7. Check the value of "hasGPS":true. It may not show up immediately.

    (Mine took a few hours later to show up as true while during testing, it stayed as false).

     

    Good luck. By the way, GPS tracking is still not full functional for all iPhones in my household. The locations tracking setting always end up changing back to 'empty' so now have to manually change it to 'Always' and let Fibaro app run in foreground for some time before it mysterious track the position. As such, not useful to do scenes for it.

    Share this post


    Link to post
    Share on other sites
    • 0

    Geofancy indeed looks promising. Specially iBeaons to track close proximity.

     

    But that is not why I bought fibaro 2 years back.

    Fibaro itself should be able to track position according their sales team.

    They are for sure selling more than possible. Its crazy that half of the features they promote do not work.

    For the same money I could have taken domotics, and build the damm-thing myself on a $25,- pi

    Share this post


    Link to post
    Share on other sites
    • 0

    I am not sure what is going on here.. in my iphone, I do not see Fibaro in Location Services. I have uninstalled the app and re-installed it multiple times and am using the home.fibaro.com as my gateway..

    Share this post


    Link to post
    Share on other sites
    • 0

    When I first set up my HC2 location services were working, my family data was populated and I could use it at a trigger. Several updates later and it no longer works.

     

    Followed

    Please login or register to see this link.

     post and I get results.

     

    I also have the issue with location services being blank on my iPhone every time I go back and I think this is one of the major issues. I also noticed, not sure it is related but Lili used to say "Welcome Andrew. My name is..." now she just says "Welcome. My name is..." It's as if the app does not know who is logged into the app.

     

    I find it more annoying that I had this working really well on my Veralite, there was an app that plugged into "find my iPhone" worked perfectly

    Please login or register to see this image.

    /emoticons/default_icon_curve.gif" alt=":-/" />

    Share this post


    Link to post
    Share on other sites
    • 0

    Ya...Can be a pain that new app releases break functionalities. I guess it may be Fibaro is not in touch with Apple Developer program and constantly updating to new SDK to maintain the app and its functionality to suit newer iOS releases.

     

    In iOS 8, the location services now allows 3 options "Always, No or When App in Use". Yet, majority of the apps still stick to old method. For Fibaro, it broke totally in recent few app releases.

     

    Sigh...Few months and still waiting for this to be fixed.

    Share this post


    Link to post
    Share on other sites
    • 0

    This is still not working, but as the app has not been updated it's to be expected. However I have worked out a few more things.

     

    If you open the app and then go to location services and set to always everything works. However if go back to the app and it needs to be refreshed, location services setting will have been reset to blank.

     

    I've written this up here with pics:

     

    Please login or register to see this link.

     

    Hopefully Fibaro can fix this soon as I'm missing location services

    Please login or register to see this image.

    /emoticons/default_icon_curve.gif" alt=":-/" />

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×