Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Sonos v1.0.1 beta VD - limit to # words spoken by TTS engine ???


AutoFrank
 Share

Question

Hi,

I have come across what I think is a limit to the number of words that the TTS engine can speak.

The following scene lua will work

Please login or register to see this code.

but if I replace the message line with a longer message it doesn't work. (no error is given)

Please login or register to see this code.

I think the limit seems to be around 46 characters (or perhaps its a time limit, ~2 seconds of speaking??)

 

'Guest' in the following post indicated that they had announcements that were much longer that 50 chars that were working fine with the 1.0.0 beta

 

Please login or register to see this link.

 

Is this a known issue or is there a fix out there...

 

 

Thanks

-F 

 

 

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
  • Inquirer
  • Could it be that you have reached your max for the API?

     

    interesting angle,

    Do you mean because of the number of sonos zones I have or the number of API calls to the HC2 (from all interfacing systems)

     

    ....any idea how I could check your 'API' theory ?

     

    I also noticed this morning that the remote buttons in the VD dont work for me. The status (radio playing, etc) seem to be working but not the stop, play, presets, etc seem to be working. I was on sonos 6.0 and upgraded to 6.2 this morning and not any better. I wonder if this is linked to the TTS issue. I checked resources (CPU, mem, etc) and all seems okay.....

     

    Found this from Ronald

    ----------

    If you change the slider, the VD is going to send the request to the controller.

     

    My testing show that it can really take more than 2 seconds for some actions to finish. The default timeout in the VD is set to 2 seconds, which is why some radio stations may not work, especially if you have multiple rooms, sonos players etc. (Starting up the radio takes sometimes too long, which results in the http request to be timed out, causing the action to be cancelled as well.)

     

    Enclosed is a new version of my code.

    -----------------

     

    I'll try his version and see if it solves the issue

    other than that I'll try the original VD and see if that solves the issue.....

     

    .... will report back...

     

     

     

    Thanks -

    Link to comment
    Share on other sites

    • 0

    You can log into

    Please login or register to see this link.

    and check the number of API calls you have made assuming this relates to the new voicerss setup.

     

    Cheers,

    al.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • You can log into

    Please login or register to see this link.

    and check the number of API calls you have made assuming this relates to the new voicerss setup.

     

    Cheers,

    al.

     

    Thanks for this ....

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • interesting angle,

    Do you mean because of the number of sonos zones I have or the number of API calls to the HC2 (from all interfacing systems)

     

    ....any idea how I could check your 'API' theory ?

     

    I also noticed this morning that the remote buttons in the VD dont work for me. The status (radio playing, etc) seem to be working but not the stop, play, presets, etc seem to be working. I was on sonos 6.0 and upgraded to 6.2 this morning and not any better. I wonder if this is linked to the TTS issue. I checked resources (CPU, mem, etc) and all seems okay.....

     

    Found this from Ronald

    ----------

    If you change the slider, the VD is going to send the request to the controller.

     

    My testing show that it can really take more than 2 seconds for some actions to finish. The default timeout in the VD is set to 2 seconds, which is why some radio stations may not work, especially if you have multiple rooms, sonos players etc. (Starting up the radio takes sometimes too long, which results in the http request to be timed out, causing the action to be cancelled as well.)

     

    Enclosed is a new version of my code.

    -----------------

     

    I'll try his version and see if it solves the issue

    other than that I'll try the original VD and see if that solves the issue.....

     

    .... will report back...

     

     

     

    Thanks -

     

    All 14 zones installed and TTS seems good on the 4 or 5 I tested.

    It also looks like a 500ms delay (between requests) is enough if you want to send an announcement to 2 or more zones

     

    thanks to all who helped resolve and in particular to Ronald for his modified VD code...

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...