Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Auto lock door scene


karlt
 Share

Question

I have a Yale lock and a Fibaro door sensor which i need help to make a auto lock scene with.

 

The yale lock has a auto lock after 30 seconds which is good, but it will lock even if the door is open. So I have disabled this and made a scene on my HC2 instead.

 

This is what I want to achieve.

 

1.       IF lock is open for 30 seconds or more

2.       AND the door is closed for 3 minutes or more

3.       THEN lock

 

It must also lock in the instance that the lock was opened but the door wasn't, i.e. the door has not open/closed to trigger the three minute count down.

 

​I built a scene as below but it doesn't work, can anyone suggest where I am going wrong?

 

Please login or register to see this attachment.

 

I made a simple scene as below that says if front door is safe for 0 seconds then lock after 180 seconds, this works fine however if the door doesn't open/close then it never triggers.

 

Please login or register to see this attachment.

 

Any help or suggestions much appreciated.

 

Thanks,

Karl

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I doubt the Yale Z-wave door lock actually feed status info back to HC on regular time interval. I don't think HC even polls it at regular interval too. But I may be wrong.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • I doubt the Yale Z-wave door lock actually feed status info back to HC on regular interval. I don't think HC even polls it at regular interval too.

     

    Interesting OK so perhaps that's why its not working?

     

    The HC2 always shows the correct status of it, so it knows when its locked or unlocked.

     

    I tried this one too which should trigger but no luck either

     

    1. IF lock is open (0 seconds)

    2. AND the door is safe (0 seconds)

    3. THEN lock after 180 seconds

    Link to comment
    Share on other sites

    • 0

    Interesting OK so perhaps that's why its not working?

     

    The HC2 always shows the correct status of it, so it knows when its locked or unlocked.

     

    I tried this one too which should trigger but no luck either

     

    1. IF lock is open (0 seconds)

    2. AND the door is safe (0 seconds)

    3. THEN lock after 180 seconds

     

    I have not look deeper into how the Yale lock's z-wave works since little is mentioned or documented.

     

    Based on my limited understanding, battery-operated devices normally do not support polling or reporting status back to controller. It may only support base-command-set which means when the lock is physically unlock, it sends a base-set signal to controller its status and that's it.

     

    Try to see if all the timing perimeters are set to zero and see if it works. If it does, that means the scene logic is ok but something else is preventing it from making the right assessment when timing is added to the logic.

     

    Add-On:

    You may want to create separate LUA script to query device info, last breached/status change, etc info to see what gets returned.

    Link to comment
    Share on other sites

    • 0

    I wish I can help more but the Yale lock I have access to is connected to a HCL which cannot run LUA script.

     

    Hmmm...Do you see any entry in the event logs about the Yale lock open or close? I checked the site with Yale lock I have access to/manage, there is no entry in event log at all. Something does not quite add up.

    Link to comment
    Share on other sites

    • 0

    I've had a strange problem. I can connect my Yale lock to the HC2 but I can't tell the Yale lock to lock and unlock. On the HC2 it says transfer ok but nothing happens.

    My firmware is 4.080.

    Any help guys

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I've had a strange problem. I can connect my Yale lock to the HC2 but I can't tell the Yale lock to lock and unlock. On the HC2 it says transfer ok but nothing happens.

    My firmware is 4.080.

    Any help guys

    Hey there, I had the same problem but simple fix, remove the device and re add but when you add it you need to hit the secure add device option or similar which is below the normal add button

    Link to comment
    Share on other sites

    • 0

    Hey there, I had the same problem but simple fix, remove the device and re add but when you add it you need to hit the secure add device option or similar which is below the normal add button

    I Love you.. It works now. I'm on a deadline with the client and you saved my life.

    Thanks

    Link to comment
    Share on other sites

    • 0

    Thanks all. Very interesting thread.

     

    Have the following challenge:

    - Yale lock has been added to the HC2 in secure mode and I can remotely lock/unlock it

    - however, the reliability of both the lock/unlock process as well as of the display of the 'locked/unlocked' status is VERY unreliable

    - this makes is very hard using the lock/unlock in a scene

    - for example, my 'good night' scene is meant to automatically lock the door and the 'good morning' scene is meant to automatically unlock. Given that the lock quite often does not unlock in the morning, the HC2 goes ahead and starts the 'leaving home' scene which arms all the devices, etc.

    - I have found that using repeat commands/loops like while..do don't work either, given that the locked/unlocked status is also quite unreliable

     

    Has anyone else come across this?

     

    Any idea how to write the unlock/unlock scenes to overcome this problem and control the lock more reliably?

     

    Any help would be highly appreciated.

     

    Thanks!

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...