Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
  • 0
massano

Yale zWave Lock

Question

Does anyone has or is working on a Yale zWave lock plugin? I'd heard that it would integrate with Fibaro, but it does not anymore.

 

So I'm trying to make it work somehow...

 

Any help available is appreciated.

 

Thanks in advance,

 

Mauro Assano

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I think you have to include it close to the controller and also include it in secure mode. I don't have this lock so I really can not say more than that.

Share this post


Link to post
Share on other sites
  • 0

The lock works fine for reporting of status as well as lock/unlock. Currently you can't do any more with Fibaro

In order to include it you need to have it within 1 metre of your controller to include it. Make sure you untick the box "device is far from HC" and leave it next to your controller for around 15 mins while it does a secure inclusion

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • Fat, I will try that today. In fact the lock is about 2 mts from the HC controler. I do not consider that it is far... but I will follow your recommendation.

     

    Hopefully it will work! 

     

    Regards,

     

    Mauro.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • HC2 was just 10cm from the zWave Yale Lock and it didn't work. I had tried all possible combinations of parameters and it didin't work.

    Before anyone ask me, the zWave frequency is the right one for my region. It just doesn't work.

    I've been following and reading HC2 forums, searching for an answer, and found out that so many other people with the same (frustrating) issue and few of them got rid of it.

     

    If any one is luckier and wiser than me... please advise!

     

    Thanks at once,

     

    Mauro.

    Share this post


    Link to post
    Share on other sites
    • 0

    I suppose you deleted the device in hc2 and did a full reset on the lock before trying to include it again?

    Share this post


    Link to post
    Share on other sites
    • 0

    Is it one of these locks?

    Please login or register to see this link.

    If so down the bottom of the touchscreen does it have a star or a lock icon?

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • I suppose you deleted the device in hc2 and did a full reset on the lock before trying to include it again?

    Joacim, the device has never been added in fact, so there is no way to remove it.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Is it one of these locks?

    Please login or register to see this link.

    If so down the bottom of the touchscreen does it have a star or a lock icon?

    Yes - it is de deadbolt model. It has a lock icon on the top and the zwave module is correctly installed, according to the manual.

    Share this post


    Link to post
    Share on other sites
    • 0

    I use the Yale Keyless Connected Smart Lock and it works fine,

     

    To set it up put your HC2 in learn mode first
    Go to your Yale lock enter your master code then #
    ​Press 4#
    ​Press 1#
    ​You will see the lock install on your HC2

     

    That's it
     

     

     

    Share this post


    Link to post
    Share on other sites
    • 0

    Has Fibaro updated the HC2 so that you can do everything that the Vera can do with the lock?  Right now there's no ability to manage user PIN codes, no status messages showing in the UI and also you can't get a simple Scene to Trigger based on the device status changing.  Strangely lock devices also don't feature in the "Alarm" or "Events" panels.  

    Share this post


    Link to post
    Share on other sites
    • 0

    I have just had the new Yale Conexis L1 installed and the Z-wave module adds it to the HC2 as a generic lock with 4.104 running but refuses to configure. I am told it works with SmartThings.

     

    Wonder if Fibaro has any plans to add the Yale module because as part of Assy Abloy, it is about the biggest locks company in the World.

     

     

    Share this post


    Link to post
    Share on other sites
    • 0

    Did anyone find any solution, because today I got my Yale door lock. I added it in HC2 but it does not send commands to the lock, also there are no parameters of the device in HC2.

    Is there a VD for Yale or what?

    I ordered the European frequency door lock from Singapore.  

    Share this post


    Link to post
    Share on other sites
    • 0

    I have a Yale lock, never had an issue. As @I am the Stig mentioned earlier, Vera is much more capable when it comes to handling locks, I hope Fibaro adds better lock functionality sometime soon!

    Share this post


    Link to post
    Share on other sites
    • 0

    For the avoidance of doubt, my post very clearly states the HC2 does not work well with the new Yale Conexis L1 which is coming out to the market this month so I am not sure if we are talking about the same lock. I checked to see if there was a firmware update, activated security inclusion, made sure the device was within 1 metre of the HC2 and initiated inclusion from the web interface.

     

    The lock I am using was installed by a Yale engineer sent from their UK Head Office. When installed about 10 days ago, the Conexis app was still in beta and I was told that the lock is not officially being released tell the 17th January and any being sold were issued for beta testing and incorrectly placed on Amazon. I am told that I was the 3rd official installation in the UK at that time. The lock functions as described with no problems for the tags, cards and iPhone but I have read some horror stories online because each phase of installation needs to carried out in a precise order and even the qualified engineer had to read the manual in detail to get it to work properly.

     

    The Yale Conexis only works on multipoint locks and engages the bolts etc when the handle is turned upwards.I am told that the mechanism is slightly different as there is no key at all (not even an emergency one). Unlike some other locks which have a split spindle and can only be opened from the outside with a key turn, the Conexis is on a single spindle which means if the multilock hooks are not engaged, the door can be opened from the outside. I wanted the HC2 to lock the door after an elapsed time or if I left home and forgot to lock it on departure. I understand that a few people have been lock out because the door has been set to lock automatically and if they have just stepped outside, can find themselves locked out with phone, tags etc in the house.

     

    The Conexis adds to the HC2 using 4.104 Beta but does not configure. Unlike the Danalock, the icon is the generic lock device but there is no functionality and, in case there was interference with normal operation as I found when adding the Danalock with 4.101 where the HC2 sent commands to the lock to set it up, overwriting the directly implemented set up.

     

    I have added the information I have found on the lock to see if anyone wants to try and work it all out. Please be careful as, according to the Vera info, some commands may cause issues.

     

    Good luck

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0

    Hello

    I have just purchased this lock and have added to my HC2 running 4.120 the latest firmware.

    as said earlier make sure you are adding in secure mode.

    i kept the NWI box checked and all included with no issues at all.

    i can lock and unlock with the fibaro and it updates the icons accordingley.

     

    thanks

    Share this post


    Link to post
    Share on other sites
    • 0

    update to this.

     

    i have noticed that the lock says 'device not configured' under the icon when viewing in the browser window.

    however i can still lock and unlock the device.

     

    i can control by sending the 'secure' or 'unsecure' command so have used in a couple of scenes.

    i do however have an issue when trying to 'trigger' a scene as it doesnt send any trigger commands,

    if i manually use the thumb lock to unlock the door the fibaro does update its status so some communication is definitely taking place.

     

    any thoughts or any updates from anyone else.....

     

    cheers

    Share this post


    Link to post
    Share on other sites
    • 0

    I have a YD-01-CON-ZW-CH Yale Keyless for a night latch.  I've come form Vera where I believe it worked fine for the few days I had it setup before swapping to Fibaro.

     

    It's added to Fibaro seemingly without issue, when it first included I could lock and unlock and the icon would update accordingly.

     

    Moments later the lock still reacts and locks / unlocks but the icon does not update so you never know what the status of the lock is from Fibaro Home Centre 2.

     

    I'm assuming it's a Z-Wave parameter that needs setting but I can't find any Z-Wave details for the device at all!  

     

    Does anybody have any suggestions on ways to fix this?

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×