Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Sonos TTS Voicers API - delay in hearing voices


AutoFrank
 Share

Question

Hi,

I'm using the 1.0.1b beta of the Sonos remote with the voicers API.

 

I have a basic test scene to develop voice usage in my system

 

From when I start the it takes between 8-9 seconds before I hear the sentence. The sonos mutes from when I start the scene

 

The code is a simple function

Please login or register to see this code.

Please login or register to see this code.

The actual code to "speak" is separate as this allows me to call it with the required sentence and not repeat all the code

 

The TTSEngineID code is from the forum here

Please login or register to see this code.

Is there anybody else experiencing this type of delay (or perhaps its normal ??)

Is I used MP3's on my local NAS would it be faster?

 

Thanks

-F

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

I'm using "fixed" MP3's on my NAS for this kind of things!

Way faster.

 

I'm using

Please login or register to see this link.

to create the MP3's (you will need to edit / cut-off the last part of the MP3)

Link to comment
Share on other sites

  • 0
  • Inquirer
  • I'm using "fixed" MP3's on my NAS for this kind of things!

    Way faster.

     

    I'm using

    Please login or register to see this link.

    to create the MP3's (you will need to edit / cut-off the last part of the MP3)

     

    Thanks Guest, I'll take that route as well.....

     

    Could you share the code you use for the MP3 approach ?

    What app do you use to trim the last part of the MP3 /

     

    -F

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I'm using "fixed" MP3's on my NAS for this kind of things!

    Way faster.

     

    I'm using

    Please login or register to see this link.

    to create the MP3's (you will need to edit / cut-off the last part of the MP3)

     

    Just found this one 

    Please login or register to see this link.

     

    There is a good choice of voice types and nothing to trim at the end.......

    Please login or register to see this link.

    Link to comment
    Share on other sites

    • 0

    Nice find, but I need Dutch, and fromtexttospeech does not do this

    Please login or register to see this image.

    /emoticons/default_sad.png" alt=":(" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    Will stick with text2speech for now.

    For the records.. I'm using Audacity to edit the MP3's (see:

    Please login or register to see this link.

     for more info)

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Nice find, but I need Dutch, and fromtexttospeech does not do this

    Please login or register to see this image.

    /emoticons/default_sad.png" alt=":(" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    Will stick with text2speech for now.

    For the records.. I'm using Audacity to edit the MP3's (see:

    Please login or register to see this link.

     for more info)

     

    Ah... now I get your avatar tagline

    Please login or register to see this image.

    /emoticons/default_icon_smile.gif" alt=":-)" />

     

    do you have a code snippet to share that I could use to get it to play MP3 instead of voicers..

    Link to comment
    Share on other sites

    • 0

    Sure..

     

    1st my doorbell scene.
     

    Basically it waits for value 152 to change (the doorbell button). When so, it will populate the global variable MP3_Sonos to the needed MP3 to be played.

    After this it will push the "play" button in a VD to "play" it.

    Please login or register to see this code.

    My VD to actually play the populated MP3_Sonos global variable looks like this. (code is within a button of the VD)

    Please login or register to see this code.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  •  

    Sure..

     

    1st my doorbell scene.

     

    Basically it waits for value 152 to change (the doorbell button). When so, it will populate the global variable MP3_Sonos to the needed MP3 to be played.

    After this it will push the "play" button in a VD to "play" it.

    Please login or register to see this code.

    My VD to actually play the populated MP3_Sonos global variable looks like this. (code is within a button of the VD)

    Please login or register to see this code.

     

     

    Thanks - That'll help a lot

     

    much appreciated

    -F

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thanks - That'll help a lot

     

    much appreciated

    -F

     

     

     

    Sure..

     

    1st my doorbell scene.

     

    Basically it waits for value 152 to change (the doorbell button). When so, it will populate the global variable MP3_Sonos to the needed MP3 to be played.

    After this it will push the "play" button in a VD to "play" it.

    Please login or register to see this code.

    My VD to actually play the populated MP3_Sonos global variable looks like this. (code is within a button of the VD)

    Please login or register to see this code.

     

    Hi Guest,

    I did a quick test last night and it works very well and the latency is down to a 1-2 seconds

     

    BTW - I notice that the Sonos x-object variable seems to be getting corrupted a bit. I'm not sure if its related to the TTS work or not

    Do you notice any issue with your implementation ?

     

    -F

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...