Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

POST v GET query


AutoFrank
 Share

Question

Hi folks,

 

A bit of a puzzler I'm hoping that some of our http/api specialist might be able to offer some advice

 

I'm working with openremote and at it's heart are http calls to the HC2 api

 

I have a GET request working but when I try and create a POST request in a similar manner it doesn't seem to work (both work in a browser)

 

Are their some special conditions/setting that a POST must have that a GET doesn't

 

GET - 

Please login or register to see this code.

Please login or register to see this attachment.

 

POST -

Please login or register to see this code.

Please login or register to see this attachment.

 

I spent a day on this

Please login or register to see this image.

/emoticons/default_icon_sad.gif" alt=":-(" /> - all suggestions welcome......

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
  • Inquirer
  • Hi folks,

     

    A bit of a puzzler I'm hoping that some of our http/api specialist might be able to offer some advice

     

    I'm working with openremote and at it's heart are http calls to the HC2 api

     

    I have a GET request working but when I try and create a POST request in a similar manner it doesn't seem to work (both work in a browser)

     

    Are their some special conditions/setting that a POST must have that a GET doesn't

     

    GET - 

    Please login or register to see this code.

    Please login or register to see this image.

    /public/style_images/master/attachicon.gif" alt="attachicon.gif" />

    Please login or register to see this link.

     

    POST -

    Please login or register to see this code.

    Please login or register to see this image.

    /public/style_images/master/attachicon.gif" alt="attachicon.gif" />

    Please login or register to see this link.

     

    I spent a day on this :-( - all suggestions welcome......

     

     

    Sorted this - so can be ignored...

    Link to comment
    Share on other sites

    Guest
    This topic is now closed to further replies.
     Share

    ×
    ×
    • Create New...