Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

WUWeather scene - version = "{3.0.5}"


jompa68
 Share

Question

Fetch data from wunderground.com, send morning and afternoon forecast to your smartphone using Fibaro app, Telegram or Pushover.

Data from wunderground.com can be from a PersonalWeatherStation(PWS) or nearest LocationID(LOCID)

 

Please login or register to see this attachment.

 

Example of forecast and pushoptions to use. 1'st value is smartphoneID, 2'nd value is morning forecast, 3'rd is afternoon forecast, 4'th is pushoption

Please login or register to see this code.

Sending as Pushover message requires an own scene that monitors Pushover variable, read about it here: 

Please login or register to see this link.

 

All important keys like API keys, tokens etc will be saved to variable panel. 

 

Supports many languages (EN, FR, SW, PL, NL, DE, NO, RO, CZ, GR, PT, RU (default is en))

 

Complete lua code (save in a new scene)

Please login or register to see this code.

Link to comment
Share on other sites

Recommended Posts

  • 0

Updated to this version and all is working, thanks for the update!!

 

I might have an idea that could come in handy for some people:

Set a var for days without rain, user set it to lets say 3 and a var for days temperature above 25C that will send a push like "water the lawn" and after the push the counter is reset. If you don't want to receive these pushes set it to 0.

 

Again, this is not a feature request just a mind-fart of me. I am no programmer else I would have tried my self

Please login or register to see this image.

/emoticons/default_smile.png" alt=":)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

 

Thanks again,

 

Jim

Link to comment
Share on other sites

  • 0

It worked yesterday, now I'm getting this error:

[DEBUG] 17:36:09: Now downloading data from www.wunderground.com
[DEBUG] 17:36:09: this key does not exist

 
 
I created a new WU api key but still the same...
Link to comment
Share on other sites

  • 0

The variable said "NAN" when I try to put it in my self I only get numbers and not letters. 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Remove all variable and save scene, will recreate all again

    Link to comment
    Share on other sites

    • 0

    I deleted the var's, saved scene then I get this:

    [DEBUG] 18:35:50: line 133: attempt to concatenate a nil value

     
     
    No var's where recreated. when I try to add them manually the telegram tokens are to much text 
    Link to comment
    Share on other sites

    • 0

    Okay take your time

    Please login or register to see this image.

    /emoticons/default_smile.png" alt=":)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Code is corrected, first post updated to new version 3.0.2

    Link to comment
    Share on other sites

    • 0

    Udated and it runs now, see if I get my morning push tomorrow.

     

    Thanks again

    Please login or register to see this image.

    /emoticons/default_smile.png" alt=":)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    Link to comment
    Share on other sites

    • 0

    Strange, I use the WU.sendPush = true to my iPhone end get the message two times a day.

    it's not possible to remove this old message, so not in my iPhone and iPad.

     

    Remove App, download again, but not possible to remove post envelope in the screen.

    Can somebody explain how te remove message?

    Link to comment
    Share on other sites

    • 0

    Same problem on Android, phone and tablet app. I think we should raise this issue on the fibaro apps section of the forum.

    Jim

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • if you logon with admin in app it will work to remove post

    Link to comment
    Share on other sites

    • 0

    if you logon with admin in app it will work to remove post

     

    Didn't know that, will do so

    Please login or register to see this image.

    /emoticons/default_smile.png" alt=":)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    My ISP is doing network upgrades so the connection is lost often. Is it possible to add some sort of recovery for network time-outs? the script stops running as that happens.

     

    Jim

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • First post updated

    Please login or register to see this code.

    You can update from 

    Please login or register to see this code.

    to

    Please login or register to see this code.

    Link to comment
    Share on other sites

    • 0

    WU.smartphoneID = .........

    wasn't there. is that ride

    Link to comment
    Share on other sites

    • 0

    and get still

    [DEBUG] 17:42:04: line 606: ')' expected near 'fcst2_mobile'

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • WU.smartphoneID = .........

    wasn't there. is that ride

     

    Is changed/removed and replaced with this

    Please login or register to see this code.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • and get still

    [DEBUG] 17:42:04: line 606: ')' expected near 'fcst2_mobile'

     

    Hmm i don't have that error and the last ")" is there

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...