Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Home Center Light HTTP Commands


kalmanv
 Share

Question

Hello,

 

I have a Home Center Lite. Im trying to playing around a bit with Virtual Device executing HTTP commands since HCL has no LUA.

 

So I created a VD added the HCL IP (or 127.0.0.1) and I set the port to 80.

I wanted to turn on a device from a virtual button to test sending http commands, but when I push the button nothing happens.

 

I used this code:

 

GET /api/devices/DEVICID/action/turnOn HTTP/1.10x0D0x0A
Host:HCLIP0x0D0x0A

Authorization: Basic [MYUSERNAMEANDPASSINBASE64]0x0D0x0A

 

When I paste this url to my browser http://HCLIP/api/devices/DEVICID/action/turnOn its working perfectly.

 

Can anyone help whats the issue?

 

Would be nice to fire some http commands to handle devices:)

 

Thanks

 

 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Authorisation is derived from your unit's login/password it is not static number. if you changed either one you need to calculate new ones.

it is suggested you enter name:password (as in name you use to login devided from password by :) into

Please login or register to see this link.

  base64decode (dot) org

 

i suspect you might have used default one (usually admin login admin password) if i am misstaken and you are awere of this than please accept my apologies for undeestimating the.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Im using the good credentials in base64 format...but thanks anyway.

    Link to comment
    Share on other sites

    • 0

    well maybe text formating problem? My proposal, import my VD and change only the command, but watch the spaces, do not change formating / line breaks, watch the IP/Port used.

     

     

    Edited by tinman
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 9 minutes ago, tinman said:

    well maybe text formating problem? My proposal, import my VD and change only the command, but watch the spaces, do not change formating / line breaks, watch the IP/Port used.

     

    It worked! thx a lot.

     

    Link to comment
    Share on other sites

    • 0

    hi, one question:

    what are the codes here in bold in the example:

     

    GET /api/devices/DEVICID/action/turnOn HTTP/1.1 0x0D0x0A
    Host:HCLIP 0x0D0x0A

    Authorization: Basic [MYUSERNAMEANDPASSINBASE64] 0x0D0x0A

     

    I also have seen something a bit different in other examples.

    I mean, what are they needed for? I have VDs without all those codes and they work perfectly.

    Just a curiosity.....

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • On 2016. 10. 31. at 7:25 PM, Flowy said:

    hi, one question:

    what are the codes here in bold in the example:

     

    GET /api/devices/DEVICID/action/turnOn HTTP/1.1 0x0D0x0A
    Host:HCLIP 0x0D0x0A

    Authorization: Basic [MYUSERNAMEANDPASSINBASE64] 0x0D0x0A

     

    I also have seen something a bit different in other examples.

    I mean, what are they needed for? I have VDs without all those codes and they work perfectly.

    Just a curiosity.....

     

    0x0D0x0A is a code that tell to fibaro its the end of the line and it can send the command.

    Can u explaine how your VD's working then?

     

    Thanks

     

    Link to comment
    Share on other sites

    • 0
    9 hours ago, kalmanv said:

    0x0D0x0A is a code that tell to fibaro its the end of the line and it can send the command.

    Can u explaine how your VD's working then?

     

    Thanks

     

    Simply without using all those codes...

     

    example of working string to reboot hcl:

     

    POST /api/settings/reboot HTTP/1.1
    Host: 192.168.1.10
    Authorization: Basic TDhYWRtaW46SWRtaK
     
    that's it
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...