Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Problems using HTTPClient (not working)


jeeson3k
 Share

Question

Hi,

 

I'm trying to write a Scene in lua using the HTTPClient to get data from IC-Meter's API.

I have tried the code on multiple endpoint all with the same result, the HTTPClient is not returning anything at all, looks like it's just skipped during the execution.

 

My code:

--[[
%% properties
%% globals
--]]

print('Script start...')

local requestUrl = 'http://app.ic-meter.com/icm/oauth/token'
local httpClient = net.HTTPClient();

httpClient:request(requestUrl, { 
    options = {
      headers={['content-type'] = 'application/x-www-form-urlencoded', ['user-agent'] = 'httpClient'},
      method='GET'
    },
    success = function(response) 
      print(response) 
    end, 
    error = function(err) 
      print(err) 
    end
  });
  
print('Begin sleep...')
fibaro:sleep(600000)

 

It retuns only "Script Start" and "Begin sleep" as shown in the atteached screenshot.

 

I have tried multiple examples from the net and from the form, but i can't even get the HTTPClient to print any thing at all. I have also tried multiple support cases but no luck.

 

Any one have an idea on where to start? :-)

 

Best

Jesper

 

Please login or register to see this attachment.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

some notices:

1) net.HTTPClient(); always running async 

2) fibaro:sleep(600000) - here you will never see print result in async thread cuz. main thread was frozen.

 

try this code

 

Please login or register to see this code.

 

Please login or register to see this link.

 

Please login or register to see this attachment.

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Hi 10der.

     

    Thanks for the reply, makes alot of sence and solved my issue.

     

    Best

    Jesper

    Link to comment
    Share on other sites

    • 0

    Hi

    I have tried the solution above in my scene:

    Please login or register to see this code.

    but still it seems the shutdownh() function is executed only after 20 seconds, at the same time the email is sent.

     

    Any idea of what I may be doing wrong?

     

    Thanks!
    Riccardo

    Edited by rcanetta
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...