Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Hass support Fibaro?


Gee
 Share

Question

Hello everyone
Can Hass support Fibaro?
How does this need to configure 'Configuration.yaml'
2, Hass access FIbaro, which needs to install HOmebridge? (Homebridge-fc2)

Edited by Gee
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

If you want to have a switch in Home Assistant that turns on/off z-wave switches in Fibaro Home Center 2 then you could define this in configuration.yaml

switch:
 - platform: command_line
    switches:
      <switch01>: # This is a unique id for switch in home assistant, that can be used in automations etc referenced as switch.switch01     switch.switch02 etc if you have more
        friendly_name: 'Fibaro Wallplug On/Off' # Direct access HC2
        command_on : 'curl -u <userid>:<userpassword> -X POST "http://<HC2 ip address>:80/api/devices/<deviceid>/action/turnOn"'
        command_off : 'curl -u <userid>:<userpassword> -X POST "http://<HC2 ip address>:80/api/devices/<deviceid>/action/turnOff"'

 

It works BUT it has a few inconveniences I have not found out a solution for yet:
- delay of about one minute. If you issue the URL directly from Chrome the on/off is instant, but not using curl
- the icons in Home Assistant does not show that the Home Cneter lights are on. That is even after you pressed the button and the lights are on, it does not show.

It works ok for me in automations where I want to turn on/off according to sun or at specific times where immediate action is not vital. Still irritating though.

 

Please note that you need to change <> and text between to valid information for your installation
 

  • Like 1
Link to comment
Share on other sites

  • 0
  • Inquirer
  • wow,Understand that if I have a lot of Fibaro device, is it necessary to write a lot of corresponding Http request URL

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...