Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Scene not doing anything


15green
 Share

Question

can anyone see why this simple block scene doesn't seem to function on Qubino DC shutter?  (see attached).  It should lower or raise to 50% if temperature between 16 -18 degrees.   I have separate scenes to raise above 18 and lower below 16 which appear to work ok (The module is actually connected to my greenhouse door!).  The LUA converts to this:

--[[
%% properties
149 value
%% globals
--]]

local startSource = fibaro:getSourceTrigger();
if (
 ( tonumber(fibaro:getValue(149, "value")) > 16 )
and
 ( tonumber(fibaro:getValue(149, "value")) < 18 )
or
startSource["type"] == "other"
)
then
 setTimeout(function()
  end, 100000)
end

 

  Thanks.

Please login or register to see this attachment.

Link to comment
Share on other sites

Recommended Posts

  • 0
6 hours ago, 15green said:

can anyone see why this simple block scene doesn't seem to function on Qubino DC shutter?  (see attached).  It should lower or raise to 50% if temperature between 16 -18 degrees.   I have separate scenes to raise above 18 and lower below 16 which appear to work ok (The module is actually connected to my greenhouse door!).  The LUA converts to this:

--[[
%% properties
149 value
%% globals
--]]

local startSource = fibaro:getSourceTrigger();
if (
 ( tonumber(fibaro:getValue(149, "value")) > 16 )
and
 ( tonumber(fibaro:getValue(149, "value")) < 18 )
or
startSource["type"] == "other"
)
then
 setTimeout(function()
  end, 100000)
end

 

  Thanks.

Please login or register to see this attachment.

Hi @15green

 

I don't work with block scenes buy two things stand out for me ...

 

1) if you want the action to execute with 16, 17 and 18 then it should be >= and <= instead of > and <

 

2) I can't see any reference to the action (lower/raise to 50%) that is to take place when the temp is between 16 and 18 

Edited by AutoFrank
Link to comment
Share on other sites

  • 0
  • Inquirer
  • Hi AutoFrank

    1) I take your point with the <= thanks.

    2) Me neither and I don't know what the timeout 1000 part is either. Do we assume the block scene is not converting correctly... Is this a known problem?

     

     

    Link to comment
    Share on other sites

    • 0

    Hi @15green,

     

    First of all, converting block scenes to LUA was always a bit tricky. However, please check whether the block scene works now (after @AutoFrank suggestions).

     

    I've created a sample block scene, similar you yours, to check the block scene to LUA conversion:

    Please login or register to see this attachment.

     

    and the code is much simpler:

    Please login or register to see this code.

     

    Could you tell us what version of firmware do you have, maybe it's an issue which has been resolved.

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  •  

    Hi there (I don't know how to insert user link!)

     

    My scene now looks like this but still fails to operate, I notice yours has another value (15) after the call function that mine does not?  My HC2 runs 4.056.  Thanks.

     

    --[[
    %% autostart
    %% properties
    149 value
    %% globals
    --]]

    local startSource = fibaro:getSourceTrigger();
    if (
     ( tonumber(fibaro:getValue(149, "value")) >= 16 )
    and
     ( tonumber(fibaro:getValue(149, "value")) <= 18 )
    or
    startSource["type"] == "other"
    )
    then
     fibaro:call(166, "setvalue", "50");

    end

     

    Link to comment
    Share on other sites

    • 0

    Okay,

     

    So in that case, please back up your HC and upgrade it to 4.130 and do this scene again, completely from scratch.

     

     

    Link to comment
    Share on other sites

    • 0

    If you do not have Satel devices, upgrade should not break anything.

    Edited by I.Srodka
    Link to comment
    Share on other sites

    • 0

    Here is at least part of your instruction, why and when do the reboot: 

     

    Quote

    Before firmware upgrade with same reason, to make upgrade to clean system

     

    Edited by I.Srodka
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi All

    Can I not perform update from my remote location?  I have done backup & restart but after accepting upgrade terms I get "access denied" to start upgrade. 

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I have backed up, restarted, run ok for a few hours, and started upgrade.  Now I cannot connect just get rotating dots.  Been over 1hr, how long should an upgrade take?

     

    Update- back on after clearing browser cache.   Have re-made scene in block mode which appears to work ok.  Thanks @I.Srodka

    Edited by 15green
    Update
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...