Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
Kfruechtl

Experience with Fibaro's technical support during warranty

Recommended Posts

Fibaro,
 
What an incompetent bunch! Your customer service is an absolute disgrace!
 
- My HC2 has not been working for about a month now, always stuck at starting services
- After a few failed remote support attempts you (Jakub Boch) asked me to send it in, which I did immediately
- As requested, I used DHL and paid about $200 for shipment
- Since then I heard NOTHING from the service desk (Emil Kaciunka), despite multiple emails
- When returning the device, Fibaro surprisingly didn't use DHL but chose a much cheaper shipping service (UPS Saver and it took quite a while to get here)
- Now I have the box again and it still has the SAME F****** PROBLEM! After the first reboot it's again stuck at starting services!
 
ARE YOU F****** KIDDING ME?!?! $200 FOR NOTHING!
 
This is just an absolutely ridiculous service - I hope I can help other potential customers prevent the same mistake I made by buying your products...
 
Karsten

Share this post


Link to post
Share on other sites

Sorry to hear that you had bad experience with Fibaro support.

 

I never needed their assistance even I had my share of troubles with my HC2.

 

Have you try to do complete recovery of the system?

Share this post


Link to post
Share on other sites
  • Topic Author
  • Thanks for your note. Yes, I did try that already multiple times. It's just not working. Wasted enough time with this device...

    Share this post


    Link to post
    Share on other sites

    I have only good experience with warranty service. Yes, i had unit that was repaired 2 or 3 times, but that was my training unit, that is used for dealer training, so i expected it to be broken. But guys from service made it kicking again (always broken motherboard :/). Users unit came back always as a new one in terms of function.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • Glad you had such a good experience. I clearly didn't. 

     

    Communication was non-existent. Emil from the service desk just refused to reply to my emails asking for an update. No comms about how long it would take. or what was broken. Nothing. 

     

    And then they didn't fix the problem. Exactly same as before. 

     

    And I had to pay $200 for shipping as they request DHL from outside Europe (while they use UPS themselves).

     

    All very disappointing... 

    Share this post


    Link to post
    Share on other sites

    I have to say I I had good experience with Fibaro service. My HC2 is after warranty but the recovery memory (the USB stick)  went down.

     

    It was examined remotely by the service and they replaced it without any charges. I had to cover only the shipping cost from my place to Fibaro and back.

     

    The advantage is that I live in Poland so the shipping cost is not high.

     

     

    Edited by gucio1234

    Share this post


    Link to post
    Share on other sites

    The topic has been moved from "

    Please login or register to see this link.

    " to "

    Please login or register to see this link.

    ".

     

    Temat został przeniesiony z "

    Please login or register to see this link.

    " do "

    Please login or register to see this link.

    ".

    Share this post


    Link to post
    Share on other sites

    Hello,

     

    This was unfortunate.

    One of engineers has been assigned to the case and he will make sure that @Kfruechtl will be able to use the system without any issues.

    We hope that similar cases won't happen in the future anymore.

    Share this post


    Link to post
    Share on other sites

    Fibaro,

     

    I want to share my case. I have added the new Greenwave 1 Port PowerNode to my HC2(ver. 4.13). Unfortunately, it inclusion fail to the HC2. In my device list, it shown a not configured device. Due to the fail inclusion action my HC2 completely crash. It cannot control & adding any device. Even doing the recovery process and restore backup. The HC2 still no function. Then I contact the Fibaro Support. One day after, the Fibaro Support via remote access & “fix z-wave” to repair my HC2. 

      

    After repair, my HC2 resume function. Then I trying to add back the device to HC2. But I guess in ver. 4.13 adding “Greenwave” device is not stable. Oh No! my HC2 crash again. So i contact the Fibaro Support again. The same as the last, via remote access to “fix z-wave”. But due to my router setting problem the fixing process fail. Then I email to Fibaro Support explain the reason and request remote fixing again.

     

    But since the last contact one week ago, I think my case was falling to black hole/ ignore list. Every day I send an email to Fibaro Support to asking when will available to fixing my HC2. There is nothing any reply and action!

     

    I have the following question:

    1.      Why add device action can crash the z-wave function?

    2.      Why the “fix z-wave” function cannot make it like a utility software or include it in the recovery in HC2? (I found from this forum “z-wave crash” case is popular happen).

    3.      In my case, what I can do? Waiting?

    Share this post


    Link to post
    Share on other sites

    Hello,

     

    Thank you for notifying us!

    I would like to apologize on behalf of the Support Team, but the engineer that fixed your gateway before got sick and currently he is on a sick leave. Moreover, sending emails everyday puts your case as the fresh one. Send one email and simply wait or if you need immediate assistance call the Support line.

     

    Now to the case. The engineer fixed the gateway twice. Third attempt was interrupted by connection failure caused by your router. Why do you blame the Support Team then? How can the Support Team explain connection issue caused by your router? There is no possible way that we could explain this. We understand that cases which require Support engineer's assistance are emotive and we try to provide necessary help as soon as possible but sometimes a little bit of patience is in place. So if next time you will feel that your case takes longer than before simply call the Support line or even contact me via private message and I will inform you what is going on :)

     

    1 hour ago, harry.leung said:

    1.      Why add device action can crash the z-wave function?

    Adding this specific device crashed the Z-Wave on your gateway. It may be a standalone case. Are you sure that the device is not malfunctioning? Did you contact the manufacturer of the device? On the other hand, is the gateway working properly and this was the only issue you encountered?

     

    1 hour ago, harry.leung said:

    2.      Why the “fix z-wave” function cannot make it like a utility software or include it in the recovery in HC2? (I found from this forum “z-wave crash” case is popular happen).

    I will forward the suggestion to the team, but I believe that security reasons do not allow us to create such solution (I may be wrong).

     

    1 hour ago, harry.leung said:

    3.      In my case, what I can do? Waiting?

    Yes. The case has been assigned to another engineer. I explained in the beginning of the post the one who solved the case before is on a sick leave. You will be contacted today and hopefully your system will be fixed and the root of the issue eliminated :)

     

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×