Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

[SOLVED]Soft reconfigure shows difference in ID


kunoch
 Share

Question

Now got the ID, it is the ID, shown in the general tab on the master of the device.

Strange however is, that in VD's the ID listed as shown below is to be used. Question now is, which is the ID within the Z-wave network.

 

I just wanted to get the latest and greatest features of my devices, so I started to soft reconfigure.

I took the one I could easiest live without and/or reconfigure the hard way.

 

Strange: in the device page, it shows me ID 134 in the information window it shows me ID 133.

Might be related to 1.140 might also not be related to 1.140. I have so far never noticed this difference.

I also did reconfigure with other devices and every time the ID differs by 1 (ID in device page is +1 compared to the ID in the info window)

 

Scenes however still work with these reconfigured devices.

 

any clue?

Please login or register to see this attachment.

 

Update: soft reconfigure done with a fibaro relay switch, the difference is 11. Things are getting weird.

Also here when I manually trigger scenes, activating/deactivating the device it all works.

 

Please login or register to see this attachment.

Edited by I.Srodka
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

The topic has been moved from "

Please login or register to see this link.

" to "

Please login or register to see this link.

".

 

Temat został przeniesiony z "

Please login or register to see this link.

" do "

Please login or register to see this link.

".

Link to comment
Share on other sites

  • 0

@kunoch, that ID 133 is a master device, that represents one physical device. Slaves are devices that provides you control.

 

E.G. RGBW if set into Out/In mode has 6 slaves, 4 controlable channels (dimmers or sensors) and RGBW and virtual channel if i'm not mistaken.

 

But, why soft-reconfiguration assigned new ID is mistery even for me. Maybe there were some changes, that resulted into assigning of new IDs.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • @jakub.jezekThanks for the confirmation. I know this master device thing, but I was and still am puzzled which ID is now really the one used for the device. OK, in HCL I do not need these IDs except fro VD usage but then it is scenes, otherwise I can address a (physical) device by its name. I would fully understand, if some sort of a garbage collector is reshuffeling the tables in the background when a (soft) reconfiguraiton is done.

    So far no problem due to the soft reconfiguration with these devices, I was just wondering and still am :/

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...