Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Calibration successful but rollter shutter not working correctly


gotocu
 Share

Question

Hello,

 

I'm struggling with the roller shutter 2 to get it working correctly with my Liwin L25 window-drive. I tried to calibrate the shutter using all 3 methods explained in the handbook (manual, using the z-wave, push button). The calibration immediately starts. Depending on the current state of the window (e.g., closed) the shutter correctly opens the window and than close it completely and then stops (it is not opened again as described in the handbook - in neither of the calibration techniques). After the calibration it is possible to open and close the window completely (using on and off commands). However it isn't possible to drive to a certain position (using dim command) - the commands are ignored like described in the case of a failed calibration. I think the calibration failes - but why?

 

Another odd effect: to get the shutter working the motor operation detection value must be set to 1 or zero. All other values have the effect that the motion starts and stops within one second.

 

Any ideas?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This sound like the motor current is too low for Roller Shutter 2 to detect when the motor is active. Are there multiple rollers connected to a single Roller Shutter module using a cut-off relay, like

Please login or register to see this link.

?

In this setup it's still possible to calibrate roller shutter with fake loads an a stopwatch. Alternatively you can replace the relay with 2 or more Roller Shutters, but depending on where the relay is installed this may be very difficult.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • The motor current is 0.14A at 3 - 10W. There are only oner roller connected. No futher relays. In case of too low current - how to apply fake loads?

    Link to comment
    Share on other sites

    • 0

    I don't really understand the information on the motor power and current. Isn't the motor running at 230V? How did you measure that current?

     

    3-10W seems very low. I would expect power consumption during operation in the range of 50..200W for a roller motor.

     

    Anyway, here is how to work with fake loads... it's a hack really, everything at your own risk and I take no responsibility whatsoever:

     

    - Use a stop watch to check the time it takes for the roller to go fully up and then fully down. Let's take 20 and 18 seconds in this example

    - Connect to light bulbs to the up/down outputs of the Roller Shutter. Use bulbs that use some power, e.g halogen bulb

    - Set the motor operation detection to something reasonable below the bulb power, eg. 25W in case of a 50W bulb

    - Start the calibration process. The "up" bulb will light up.

    - When 20 seconds are over, quickly disconnect the "up" bulb. I used mechanical switches for that.

    - After a second or so the "down" bulb lights up. Disconnect it after 18 seconds and don't forget to switch the "up" bulb back on.

    - After another 20 seconds turn off the "up" bulb. Calibration is finished now.

    - Finally, set motor operation detection to 0W

     

    So far I haven't found a way to do it in a more convenient way. It would be great if Fibaro allowed to set the up/down time via the GUI or API.

     

    Cheers,

    jayrock

    Edited by jayrock
    typo
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thank you for your help. This way I managed to got the calibration done!

     

    Edited by gotocu
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...