Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team



jgab

Recommended Posts

Sorry Jan,

rule("phoneID=447")

error>>call global nil value

447 and 470 are listed in IOS Fibaro both have error

Please advice.

 

My compliments about the version 3.0

It showed a lot of errors I never have seen before still surprised it was still working.

 

Link to comment
Share on other sites

  • Topic Author
  • 1 hour ago, Sjakie said:

    Hello Jan,

    Please can you explain??

    This rule gave error index field

    I was checking the rule the debug window refreshed(full) and error gone, without edit anything.

    Is it your magic hand?

    Please login or register to see this link.

     

    The scene auto-updates when you restart if there is a new version. Maybe that’s what happened?

    Link to comment
    Share on other sites

    1 hour ago, jgab said:

    for -> trueFor

    Great, that works. What about this?

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

  • Topic Author
  • 16 minutes ago, jompa68 said:

    Great, that works. What about this?

    Please login or register to see this code.

     

    Sorry, seems to have accidently removed support for #event triggers inside nested expressions (the trueFor in this case)

    I'll fix it tomorrow morning.

    Link to comment
    Share on other sites

  • Topic Author
  • 7 hours ago, jompa68 said:

    Great, that works. What about this?

    Please login or register to see this code.

     

     

    I fixed #event triggers in nested expressions so it behaves as the old version. (v3.0 B8)

    Please login or register to see this code.

    the .start() is unnecessary as the condition will always be false as there is no #VirtualSensor event available that have triggered the rule.

     

    Link to comment
    Share on other sites

    Looks like "osDate" have been adjusted, this is not working anymore and osdate does not fit in

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

  • Topic Author
  • 2 minutes ago, jompa68 said:

    Looks like "osDate" have been adjusted, this is not working anymore and osdate does not fit in

    Please login or register to see this code.

     

     osDate has gone and you just use os.date (on ZBS I patch os.date and os.time to work with simulated time)

    (In ER rules you can use osdate())

    Edited by jgab
    Link to comment
    Share on other sites

    and this?

    Please login or register to see this code.

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

  • Topic Author
  • 5 minutes ago, jompa68 said:

    and this?

    Please login or register to see this code.

    Please login or register to see this code.

     

     

    OR is single '|'

    Please login or register to see this code.

    The old parser was a bit more "forgiving"... for "test1 || test2" it generated "test1 OR false OR test2"...

    Edited by jgab
    Link to comment
    Share on other sites

    Ah, ofcourse. 
    so now all 138 rules have status "OK" and seems to be running. 

    Link to comment
    Share on other sites

    Hey,

    Recently I do not have time to update the ER, but I see that the time has come and I started to do it today, unfortunately I encountered a problem with this:

     

    [DEBUG] 08:33:36: 2019-07-31 08: 33: 36.335398 [fatal] Unknown exception: /opt/fibaro/scenes/392.lua:2986: attempt to call global 'eventConsumer' (zero value)

    Please login or register to see this attachment.

     

    i'll be appreciated with any help, what i've missed:)?

    Link to comment
    Share on other sites

  • Topic Author
  • Just now, jompa68 said:

    Ah, ofcourse. 
    so now all 138 rules have status "OK" and seems to be running. 

     

    Great!

    @Sjakie, you and @FrankT have helped me kill a lot of bugs the last 24 hours. Thanks!

    There are of course more bugs to be uncovered but I feel the code is improving. 

     

    Link to comment
    Share on other sites

  • Topic Author
  • 4 minutes ago, domin12 said:

    Hey,

    Recently I do not have time to update the ER, but I see that the time has come and I started to do it today, unfortunately I encountered a problem with this:

     

    [DEBUG] 08:33:36: 2019-07-31 08: 33: 36.335398 [fatal] Unknown exception: /opt/fibaro/scenes/392.lua:2986: attempt to call global 'eventConsumer' (zero value)

    Please login or register to see this attachment.

     

    i'll be appreciated with any help, what i've missed:)?

     

    My bad, made a quick fix this morning that made eventConsumer disappear - I pushed a new version B9, or just remove the 'local' infront of 'function eventConsumer()' in the upper part of the scene where it's declared.

    Link to comment
    Share on other sites

    6 minut temu, jgab napisał:

     

    My bad, made a quick fix this morning that made eventConsumer disappear - I pushed a new version B9, or just remove the 'local' infront of 'function eventConsumer()' in the upper part of the scene where it's declared.

     

    1 pass , another to resolve  ? :   

     

    [DEBUG] 08:51:22: 2019-07-31 08:51:22.671862 [ fatal] Unknown exception: /opt/fibaro/FibaroSceneAPI.lua:146: Assertion failed: Expected string

     

    Link to comment
    Share on other sites

  • Topic Author
  • 14 minutes ago, domin12 said:

     

    1 pass , another to resolve  ? :   

     

    [DEBUG] 08:51:22: 2019-07-31 08:51:22.671862 [ fatal] Unknown exception: /opt/fibaro/FibaroSceneAPI.lua:146: Assertion failed: Expected string

     

     

    Ugh, I should not push changes without testing on the HC2.

    I pushed a new version v3.0 B10.

    Please login or register to see this code.

    If you want to patch your existing code it's inside eventConsumer. The calls to _getGlobal and _setGlobal should have a nil as first argument.

    Link to comment
    Share on other sites

  • Topic Author
  • 3 minutes ago, jompa68 said:

    Update .version also

     

    Done.... now! :-) 

    Link to comment
    Share on other sites

    Thats resolve the problem, and getting new one , sorry guys , but to many new post to find solution quickly, 

    what is change , this rule previously working fine :

    [DEBUG] 09:17:25Error in '#location{user='[email protected]',place='away'} => $placeDominik = '%s',$pozDominik': /opt/fibaro/scenes/392.lua:1720: Parser error char 77 (',') in expression '#location{user='[email protected]',place='away'} => $placeDominik = '%s',$pozDominik' (/opt/fibaro/scenes/392.lua:1472: attempt to index field '?' (a nil value))
     

    Edited by domin12
    Link to comment
    Share on other sites

    sorry, you have missed to update evenrunner3.lua with new version. Patching is looping

    @jgab

    Edited by jompa68
    Link to comment
    Share on other sites

  • Topic Author
  • 10 minutes ago, jompa68 said:

    sorry, you have missed to update evenrunner3.lua with new version. Patching is looping

    @jgab

    Yes, didn't check it in. Done now.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...