Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


Recommended Posts

I have relatively simple automation to develop. If temperature is too low - switch on Wall-Plug. If too high - switch it off. I have three temperature sensor in disposal: "Motion Sensor", "CO Sensor", and Elgato Eve. I was trying several automatons with different sensors, IFs, WHENs, etc - no way. I am not able to control Wall-Plug using temperature value. Any idea to solve my issue?

 

Regards,

Tomek 

Share this post


Link to post
Share on other sites

I have a scene for temperature sensor to turn on or off the wall plug. But i use a binary sensor with a temperature sensor. The motion, co sensors give not the actual temperature because the wakeup interval. 

But i wil share if you like the script but you need a different temperature sensor. 

Share this post


Link to post
Share on other sites
  • Topic Author
  • 52 minuty temu, Reinhold napisał:

    I have a scene for temperature sensor to turn on or off the wall plug. But i use a binary sensor with a temperature sensor. The motion, co sensors give not the actual temperature because the wakeup interval. 

    But i wil share if you like the script but you need a different temperature sensor. 

    To be perfectly honest I don't really care about "actual temperature". The problem is that the temperature value on the sensor doesn't trigger an Automation. Simply not working. Whatever value is detected - is ignored.

     

    Please share the script and tell the name of the temperature sensor if it is not a problem. Thank you!

    Godzinę temu, tking napisał:

    Try setting this automation from Eve app.

    Conditions from Fibaro app don't work.

    Hmmm? I have to test it for some time but it seems that this could be some workaround. At least something happened. Is ON - will see if it will go to OFF state also

    Share this post


    Link to post
    Share on other sites

    @big_lynx

     

    This is a part of the script that turns on or off my wall plug.

     

    343 is the id of the temperature sensor and 300 is the id of my wall plug

     

    I use far the temperature a universal sensor with Ds18b20 temperature sensors.

    --[[
    %% autostart
    %% properties
    %% weather
    343 value
    %% events
    %% globals
    --]]

    if fibaro:countScenes()>1
    then
    fibaro:abort()
    end

    local sourceTrigger = fibaro:getSourceTrigger()
    function tempFunc()
    local HuidigeTijd = os.date("*t")
    local startSource = fibaro:getSourceTrigger()

    if ((tonumber(fibaro:getValue(343, "value")) < 19.5)
    then
    fibaro:call(300, "turnOn")
    elseif ((tonumber(fibaro:getValue(343, "value")) > 19.8)
    then
    fibaro:call(300, "turnOff")
    end

    setTimeout(tempFunc, 5*60*1000)
    end

    if (sourceTrigger["type"] == "autostart")
    then
    tempFunc()
    else

    local currentDate = os.date("*t")
    local startSource = fibaro:getSourceTrigger()

    end




    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @Reinhold

    Thank you. Let me understand correctly the script and sorry for the newbie question - is it for native Fibaro Home Center device? Nothing dedicated for Apple homekit?

    Share this post


    Link to post
    Share on other sites
    15 godzin temu, big_lynx napisał:

    Hmmm? I have to test it for some time but it seems that this could be some workaround. At least something happened. Is ON - will see if it will go to OFF state also

     

    Setting the automation with the conditions from the Fibaro application does not work (at least for me). I have a Fibaro motion sensor and I tried to set the automation triggered by a change in light intensity. After lighting the flashlight in the sensor, the reading from the sensor changed and the automation did not work. After removing this automation and setting the same from the Eve application, the same scenario activated automation. Since then, I have not set up any automation from Fibaro.
    With the Home app, unfortunately, it is impossible to set the automation based on the intensity of light or temperature, so Eve's application remains for such automations.

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • @tking

    It seems that Eve App also works for me. I am not sure if for all cases but at least for one not working on Fibaro - yes. What I am missing on Eve.App is IF conditions based on location (e.g. - I am at home)

    Share this post


    Link to post
    Share on other sites

    You can define automation in Eve app, and after that add if conditions based on location in Apple Home app. It works.

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...