Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

HUE VD. Why triple click needed to activate??


baliya
 Share

Question

Hi everyone

I'm dissapointed new user of fibaro HCL, my fault. Thought that the plugin for hue will let me use all hue components as they are, lights, sensors etc.

Only way to use is with virtual devices, after digging a lot i've found a solution for my lamp, but when tested it only works doing 3 clicks in one seccond, so is useless.

 

Some help will be greatly apreciated.

Edited: Sorry may be this mut go on on¡thwer forum section

  

Please login or register to see this attachment.

Edited by baliya
May me published on wrong section
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
  • Inquirer
  • On 6/9/2019 at 1:47 PM, baliya said:

    Hi everyone

    I'm dissapointed new user of fibaro HCL, my fault. Thought that the plugin for hue will let me use all hue components as they are, lights, sensors etc.

    Only way to use is with virtual devices, after digging a lot i've found a solution for my lamp, but when tested it only works doing 3 clicks in one seccond, so is useless.

     

    Some help will be greatly apreciated.

    Edited: Sorry may be this mut go on on¡thwer forum section

      

    Please login or register to see this attachment.

    Investigating I've found the solution.

    The most importat is to check the box wait for response (centre bottom) otherwise it will never work. Aafter that, the key was the value of Length. Too short no action, too log delays, so the right commands for me are:

    ON:

    PUT /api/Q...cJT/lights/6/state HTTP/1.10x0D0x0AHost: 192.168.1.710x0D0x0AContent-Length: 110x0D0x0AContent-Type: application/json0x0D0x0A0x0D0x0A{"on":true}

    and OFF:

    PUT /api/Q..cJT/lights/6/state HTTP/1.10x0D0x0AHost: 192.168.1.710x0D0x0AContent-Length: 120x0D0x0AContent-Type: application/json0x0D0x0A0x0D0x0A{"on":false}

    Deleted 0X0D0x0A at the end on both cases

    Note that length at "ON"  is 110 and at "OFF" is 120. Curiously both110  lights don't go off, and both 120 about 6 secons of delay when turning on.

     

    Does anyone know how to turn on, change the brightness, saturation and hue  it all together at once? somefhing like {"on":true, "hue":8402, "sat":140, "bri":77} but it doesn't works

     

    Edited by baliya
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...