Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Hikvision PTZ - DS-2DE2A404IW


jnbjc
 Share

Question

Hello, 

Does anyone know the correct urls for Hikvision Pan and Tilt ?
need the following urls
Turn left, Turn right, move up, move down and stop movement

 

Jpg and mjpg urls are working fine.

Thank you

 

Please login or register to see this spoiler.

 

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Please login or register to see this code.

PTZ/channels/1/PTZControl?command=PAN_LEFT&speed=1&mode=start
PTZ/channels/1/PTZControl?command=PAN_RIGHT&speed=1&mode=start
PTZ/channels/1/PTZControl?command=TILT_UP&speed=1&mode=start
PTZ/channels/1/PTZControl?command=TILT_DOWN&speed=1&mode=start
PTZ/channels/1/PTZControl?command=GOTO_PRESET&presetNo=1&speed=1&mode=stop

  • Thanks 1
Link to comment
Share on other sites

  • 0

hi,

 

i have the Hikvision DS-2DE2A404IW i am having trouble using these urls is there different ones or is this camera not supported. any help welcome.

 

thanks,

Link to comment
Share on other sites

  • 0

Hello, 

 

When I take below commands and put them in the browser, they work perfrctly and camera is moving. But From Fibaro they don't do any movement. 

 

I tried with the full URL and with only PTZ/channels/...

 

I also tried putting the user name and password in the URL it self, works fine in browser, but not from Fibaro. I can view the camera JPG and MJPG, but PTZ not working.

 

http://192.168.10.28/PTZ/channels/1/PTZControl?command=PAN_LEFT&speed=3&mode=start

http://192.168.10.28/PTZ/channels/1/PTZControl?command=PAN_RIGHT&speed=3&mode=start

http://192.168.10.28/PTZ/channels/1/PTZControl?command=TILT_UP&speed=3&mode=start

http://192.168.10.28/PTZ/channels/1/PTZControl?command=TILT_DOWN&speed=3&mode=start

http://192.168.10.28/PTZ/channels/1/PTZControl?command=GOTO_PRESET&speed=3&mode=stop

Edited by Malath
Link to comment
Share on other sites

  • 0

Just figured it out, after changing Hikvision CGI authentication to digest/direct under integration protocol tab, every thing started to work.

 

Thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...