Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Fibaro RGBW Controller and SmartThings - cannot get it to work


forrest_holleman
 Share

Question

Hello,

 

I've got a Samsung Smartthings WiFi hub and I'm trying to add an RGBW LED strip via the Fibaro RGBW Controller model FGRGBWM-441.

 

I've tried using the default FIbaro RGBW Controller device type in Smartthings.  Then, after reading some forum articles, I added the Device Handler created by richb1 on github (

Please login or register to see this link.

).

 

In both cases, the LED strip lights and flashes a few times (both the white channel as well as a greenish hue on the RGB LEDs.  Then it shuts off and I get an error message:  "A network or server error has a occurred. Try again later" on my SmartThings app (on a Samsung Galaxy Note 9 smartphone).  The two devices are next to me less than one meter apart.  I've excluded and then re-added the Fibaro controller a number of times, but for the life of me I cannot get this to work.

 

I've tried two different ways of physically connecting the Fibaro controller to the LED strip - one as pictured on the instructions (with the four "In" pins being tied to Ground) and I've also tried it without the "In" pins being connected.  Same result in both cases.

 

I got a cheaper German-designed RGBW ZigBee controller to work out of the box the first time with this same LED RGBW strip - one would think getting a Fibaro to work with SmartThings would be simpler than this.

 

I'm open to any suggestions the community might have!

 

Thanks,

 

Forrest

  • Like 1
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
  • Inquirer
  • Update:   I figured out the primary issue - my power supply appears not to have delivered enough power for the Fibaro (I didn’t even think to check this as it works fine for the 3A Nue ZigBee controller). Anyway, changed to a different power supply it it appears to be working fine - EXCEPT the fact that I cannot find a way to get the white LEDs to light now at all. I can generate “white” using the RGB LEDs, but that kind of defeats the purpose. I’m also still getting the same error message when I use the app.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...