Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


10der

HC(x) + NODE-RED

Recommended Posts

  • Topic Author
  • docs

    Please login or register to see this code.

    so

    Please login or register to see this code.

     

    Share this post


    Link to post
    Share on other sites

    I send as string but, I don't why its not work after upgrade to 0.18. Before work fine. 

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 4 minutes ago, drboss said:

    I send as string but, I don't why its not work after upgrade to 0.18. Before work fine. 

    Please login or register to see this code.

    be careful after import node-red added fake HC2 server with empty params - please remove it and choose rigth!

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • przyjacielu

    Please login or register to see this image.

    /monthly_2020_01/image.png.59eff6982ba82415375f51468f781412.png" />

     

     

    image.png.a56bfff25c6ef16c594260271f76dca4.png

     

    is any diff?

     

     

     

     

    Edited by 10der
    • Thanks 1

    Share this post


    Link to post
    Share on other sites

    When I open forum topic to write that I find error:

    {
        "Test1": {
            "name": "setThermostatSetpoint",
            "arg1": 1,
            "arg2": 25
        },
        "Test2": {
            "name": "setThermostatSetpoint",
            "arg1": 1,
            "arg2": 17
        }
    }

    I read that You find my problem too. Thanks ;-)

    I confirm for thermostat it's work, but in the older version (before 0.18) I sure that list of args [ ] work fine because I use it :-) in "production"

     

    Second observation for thermostat "sensor" - module "type": "com.fibaro.operatingMode" . If module change property.state ex from 1 - heating to 0 - off or from 2 - cooling to 0 the "Sensor" report changing of property.mode to 0. But when you check in HC2 (via api or www) the mode stay set to 1 (for heatnig) or 2 (if you set before cooling)

    The same situation is happen if  module "type": "com.fibaro.operatingMode" start working and change property.state to heating or cooling. In this case "sensor" report that "mode" set to 1 or 2 on place to report "state" change.

    image.png.042c2dd5f3a32ee396028765d2291ef5.png

             state                              heating

    this happen if "Handle additional events" is uncheked, but if you check this box the reports is ok.

     

    image.png.2d4cf70b2c5494a0769bd5ba3b55df67.png

     

    Tested on version .20

    ps. I have read that You will abandon HC2 :-(, when I after starting use your project I decided to keep using it.

    To what platform are you migrating your HA? I started testing the RPI with z-wave module, but I not ready to migrate yet. Ofcorse I stay with z-wave in my home and apartments of parents because I have more z-wave devices that others but time to time I test zigbee, BLE etc.

    Stay with as ;-)

     

     

    Edited by drboss

    Share this post


    Link to post
    Share on other sites

    Version 0.20

    When I connect a Fibaro wallplug and toggle on or off - I get a lot of true/falses (8 times) and also a bunch of undefined (>10 times)

    Is it still code debug info?

     

     

    Please login or register to see this attachment.

    Edited by petrho

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...