Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


Matz1977

Push Notifications stopped working on iPhones (but iPad and Android are ok)

Recommended Posts

Dear Community.

 

I was wondering if any of you experience the same issue… since a few days I stopped receiving Push notifications on all my iPhones. However, on an Android phone and also on my iPad they work fine.

 

I already updated HC2 to 4.5.81, deleted the Fibaro App on all devices, deleted the phones from HC2 (Access Control -> Mobile devices list), rebooted HC2, reinstalled Fibaro App, read new device IDs from http://<IP>/api/devices... but no success. Same picture as before. I also checked iPhone notification settings for the Fibaro app, they are all turned on just like for the iPad.

 

Any idea?

 

iPhone 7, iOS 13.4.1 -> not OK

iPhone 7, iOS 13.4.1 -> not OK

iPad Air, iOS 12.4.6 -> OK

Samsung SM-G930F -> OK

 

Fibaro HC2, 4.5.81

 

Thanks for your help.

 

Kind regards,

Martin

 

PS: here's what I see in /api/devices - only difference is "sendPush": 0 under "actions" for iPhone vs. iPad which has value 1 there ... but the working Android phone also has "sendPush": 0. And the DeviceToken looks different on the iPhones (starting with a length indicator and two values connected by ...

 

--------------------------- NOT working iPhone -----------------------------

Please login or register to see this code.

--------------------------- working iPad -----------------------------

 

Please login or register to see this code.

--------------------------- working Samsung -----------------------------

Please login or register to see this code.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Same here since a few days (without updating iOS).

The notification via email still works immediately, but no push and no interactive push notification on iPhone7 (iOS 13.4) & 11 (iOS 13.4.1).

 

Android tablet still works.

 

@T.Konopka: Is there any known issue, yet ?

Edited by Orgli

Share this post


Link to post
Share on other sites
  • Topic Author
  • Posted (edited)

    Update: I was hoping that by updating to 4.582, the problem would be solved… but no. So today I played around with the Pop-Up Service as potential alternative to Push Notifications and was surprised that suddenly I started receiving Push Notifications again, but only on the phone I was using for my tests. I am still not sure about the details, but here's what helped me get back Push on all phones (iOS and Android):

     

    1. Create a Pop-Up scene that tests pop-ups to all your phones as listed under HC2 -> Configuration -> Access Control -> Mobile devices list

    --------------------------------------------------------------------

    --[[
    %% properties
    %% globals
    --]]


    local imgUrl = 'http://<URL to the image you want to use in your pop-up>'
    local datetime = os.date("%I:%M:%S %p | %B %d, %Y"),

    HomeCenter.PopupService.publish({
     title = 'Test Pop-Up',
     subtitle = os.date("%I:%M:%S %p | %B %d, %Y"),
     contentTitle = 'Pop-Up Notification Test',
     contentBody = 'If you can read this, the Pop-Up Test has been successful',
     img = imgUrl,
     type = 'Success', -- use Critical, Warning, Info or Success
     buttons = {
     { caption = 'OK', sceneId = 0 },
     { caption = 'Cancel', sceneId = 0 }
     }
    })

    fibaro:debug(datetime .. ': Alarm Pup-Up sent to all phones');

    --------------------------------------------------------------------

     

    2. Open the app on your mobile device: Fibaro for iPhone (version 2.28.1), Fibaro for iPad (version 1.210.0) or equivalent on Android

     

    3. With the app opened, start the pop-up test scene above and verify that it works.

     

    4. With the app still opened, send a push notification test via e.g.

    --------------------------------------------------------------------

    fibaro:call(<PhoneID>, "sendPush", "Test-Message | DeviceID = " .. PhoneID);

    --------------------------------------------------------------------

    Be aware: You won't see this push notification as these only appear on the mobile device when the app is closed!

     

    5. Now close the app(s) on the mobile device(s)

     

    6. With the app closed, send the test push notification again

     

    For me, push notifications work again on all the phones that I worked through this procedure.

     

    However, there's still an issue with pop-ups (or maybe it is new - I cannot tell, because I have not been using pop-ups before): Pop-Ups only work with the app being opened at the time when the pop-up is being sent - except for the iPad where I never experienced a problem. There, push has always been working fine and pop-ups come up also when the app is closed.

     

    Hope this helps and hope even more that Fibaro fixes this issue soon.

     

    PS: Be sure to use the correct Device-ID of your mobile device (it may have changed in the meanwhile, I had this problem in the past after one of the HC2 SW updates). If you are unsure, do the following:

     

    - Delete all (!) your mobile devices under HC2 -> Configuration -> Access Control -> Mobile devices list

    - Open the Fibaro app on your mobile device and access your HC2. IMPORTANT: be sure that you are connected to the same (W)LAN as your HC2! Remote access won't do the job.

    - Now check if you find your mobile device listed under HC2 -> Configuration -> Access Control -> Mobile devices list

    - Copy the device name to your clipboard (Ctrl+C)

    - Open http://<HC-2 IP address>/api/devices in your browser

    - Search for the mobile device name (Ctrl+F --> Ctrl+V -> Enter)

    - Note the numeric ID left to your device name, e.g. 353 in my case

    {"id":353,"name":"MatzPhone",[…]

     

    Edited by Matz1977

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...