Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


Verisure HC3 Quick App


Sagittarius
 Share

Recommended Posts

You need to set this:
self.userid = "######@###.com" -- Username
self.password = "###########" -- Password
self.keycode = "####" -- Keycode
 
Make a global variable called: Alarm
line: 221  fibaro.setGlobalVariable("Alarm", state)
 
I call my quick app (device) from a loop scene every 1 min. to get state
fibaro.call(deviceid,"uibutton1OnReleased")
DO NOT call more than every 30 sec. or I think you will be bloked by Verisure
 
DECLARATIONS (Conditions/Triggers)
{
    type = "date",
    property = "cron",
    operator = "matchInterval",
    value = {
        date = { "*""*""*""*""*""*" },
        interval = 60
    },
    isTrigger = true
}
 
ACTIONS
fibaro.call(deviceid,"uibutton1OnReleased")
 
-----------------------------------
 
You can get devices variable from a scene by
api.get("/devices/DeviceID").properties.quickAppVariables[1].value
api.get("/devices/DeviceID").properties.quickAppVariables[2].value
api.get("/devices/DeviceID").properties.quickAppVariables[3].value
etc...
 
------------------------------------
 
line: 3   local debugging = false (show all) in debug window
line: 4   local debuggingtrace = true (show alarm state/users/devices) in debug window
 
------------------------------------
 
I dont know yet how to show icon "red" Armed-away
 

Please login or register to see this attachment.

Please login or register to see this attachment.

Please login or register to see this attachment.

Please login or register to see this attachment.

Edited by Sagittarius
Link to comment
Share on other sites

  • Topic Author
  • you mean what output you get? I guees all...

     

    I try to make a file without all my password and stuff

    Link to comment
    Share on other sites

    • 6 months later...
    • 2 months later...

    Hi there. I'm a user in Norway with Home Center 3. I downloaded the file and uploaded it to my HC3. Replaced username, pwd and keycode. When I run it it doesn't arm/disarm the alarm. Does it still work in feb 2021(or have there been som new updates in software that make this error?).

     

    I haven't found out how or if I need to make a global variable(perhaps this is why I get the error?) - or is there other adjustments I need to know about. I have only done what I have described in this post.

     

    Hope @Sagittarius or some of you other guys can pass some help on this issue and can confirm it still works. It would have been great to make a scene where lights are switched off and alarm armed when you go to bed, etc.

    Edited by Kgudmund
    Link to comment
    Share on other sites

    • 3 months later...
    Posted (edited)

    Hi there, thanks for putting the effort in! With your example it works to turn on the lights scene when the alarm is breached. I was wondering what LUA script command to use to call the Verisure device to enable the alarm? 

     

     

    Edited by MartinvdB
    Link to comment
    Share on other sites

    • 1 month later...

    Please login or register to see this link.

      - I've been trying to set this up.

    Something is not working correctly.. after verisure forced MFA the QA won't work out of the box.

    I followed this HA guide to create a service account and remove MFA for that user:

    Please login or register to see this code.

     

    But all I get (still) is Post Break error. 

    I can't get more debug info so I have no idea where to look for the solution.

    could you possibly assist?

    I set up the global variable.. put in a dummy value and ran the QA.. it clears the variable so there is no data in the QA get state.

    Link to comment
    Share on other sites

    @Sagittarius - So.. I got a bit further.. 

    I changed the links from 01 to 02:

    Please login or register to see this link.

     
    Just a question.. can the qa not get status of lock.. is the door locked? is it unlocked?
    Where do you find the info returned from the api call?
    Link to comment
    Share on other sites

    • 4 months later...

    I see verisure changed the dns name again from 02 to 01 (at least for me it's now 01)

     

    Oh and I can now check the lock status.

     

    One thing I think we need (unless the dns thing only happens to me) is to test the dns before starting anything else.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...