Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

QuickApp - Philips Hue - All in One


Question

QA for Philips Hue devices (for HC3 5.040 GA or above):

- support of philips hue lights, switches and sensors (motion, temperature, light) and some ikea lights connected to hue bridge
- unlimited number of hue bridges
- all logic and setup are centralized in QA HueMain
- creating of hue devices via click on buttons in HueMain
- a lot of parameters for advanced users
- automatic update of all devices in case of new versions
- centralized setting of favorite buttons,colors and icons (also possibility to override settings via local variables in every QAs)

- power consumption calculation for lights

- supported languages: en,cz,de,se,nl,sk,fr,ru,it,pl

 

Please login or register to see this image.

/monthly_2020_08/image.thumb.png.89768d5ac25bcbe213f35ac9fe971499.png" />

 

image.thumb.png.3d4e23ecfca469eaaf43eee82bafd820.png

 

image.png.8dcdb45ade949b7158f77f4be2bb3dd5.png

 

Installation:
1.    Download HueMain.fqa
2.    Install HueMain.fqa to HC3
3.    In Variables in HueMain you have to setup:
- HueBridgeName1     - you can choose any name of your bridge - it can be whatever – allowed characters: a-z, A-Z, 0-9, _ - for example MyBridge1
- HueBridgeIP1    - IP address of your bridge for example 192.168.1.200
- Save variables - HueMain should start if everything is OK
4.    And than you have 2 options:
a)  you know your user in bridge - you can add it to Variables  - item HueUser1  ie.vPCj123VmJ18uWSHqpXfidxq5sjsP1q4Wi6DiCm 
b) you can create user in HueMain - last part - button Create user (you will need physical access to your Hue bridge and press button there)

+ save/restart
5.    HueMain should run (if everything is OK) and show your hue devices in menu
6.    You can create QAs for group of lights, lights and sensors in menu in HueMain

 

Files:

1. QA - HueMain

Please login or register to see this attachment.

 

2. Icons:

Please login or register to see this attachment.

 

HOW TO CALL from other QAs or Scenes:

Please login or register to see this code.

 

Please login or register to see this code.

 

How to add icons where is not direct QA support for icon selection - for example for QA Hue Switches:

There is not possible to change icon for switch via user interface but you can do it via my QA:

1. you have to upload icons for hue switch:

  •  In HueMain - tab General - add Icon
  • Select your user icons and save it. You don't need to change icon for your HueMain

2. You need to get icon number - user icon has number with 4 digits (I hope that you don't have more 9999 icons currently :) )

  • right click on icon in your browser and select save picture - there will be - ie. User1007.png  - your icon number is 1007 (in some of icons ie. for lights you can see longer number ie. User1018100.png, always use only first 4 digits - 1018

3. In HueMain - tab Variables - add your icons number to IconSwZLLxxx (default icon is 0)  or IconSwZGPxxx based on your hue switch type - btw. you can set also default icons for all your hue devices

4. Save your variables and HueMain will be restarted and your HueQAs will have new nice icons :)

 

Edited by petrkl12
  • Like 12
  • Thanks 3
Link to post
Share on other sites
  • Answers 86
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

Popular Posts

QA for Philips Hue devices (for HC3 5.040 GA or above): - support of philips hue lights, switches and sensors (motion, temperature, light) and some ikea lights connected to hue bridge - unlimit

New version of HueMain 3.00 is available (version of "child" hue QAs like lights, sensors etc. is 2.10).   What is new: - enabling/disabling of motion sensors - fix key id for frie

I can try to add button and method for disabling motion sensor   btw. my wife had similar problem with long shower without lights  so I had to add another hue motion sensor above shower and

Posted Images

Recommended Posts

  • 0

Thanks for the quick app.

 

I'm using the friends of hue switch. I added the switch.

The key id of the up right switch is None. Can you modify?


up left : 2
down left : 3
down right id 4

 

Thanks again

Link to post
Share on other sites
  • 0

hello @

Please login or register to see this link.

Thanks a lot for your QA

 

EDIT: my bad, was because of space in my bridge name, works super fine thx!

When I install it, changing hue bridge name, and ip, I go to the Device preview and press add user after pressing my hue bridge

I get, user can't be created

 

what did I do wrong?

Please login or register to see this attachment.

 

thx for your help

Edited by istyrl
Link to post
Share on other sites
  • 0

I'm new to HC3 and quickapps: Many thanks for this - works great! Only thing I dont know is how to instal the icons. Can someone explain please?

Link to post
Share on other sites
  • 0

Hello,

 

Do you know if this Quick App also recognizes the 'Friends of Hue' Switches? 

 

Please login or register to see this link.

 

Link to post
Share on other sites
  • 0

Hell everybody,


Is it also possible to control color temperature of the HUE bulbs by the app?

If yes: How do we set this up?

 

Yours sincerely,

Tom

Link to post
Share on other sites
  • 0
On 10/24/2020 at 6:00 PM, petrkl12 said:

I can try to add button and method for disabling motion sensor

 

btw. my wife had similar problem with long shower without lights :) so I had to add another hue motion sensor above shower and persuade philips to add cooperative mode for two sensors :)

 

Hi there,

 

Thank you for this great work. Any update for this function ?

 

Regards,

Link to post
Share on other sites
  • 0

@petrkl12, thanks a lot, amazing app. Would you know if we can add a Lua command in a scene to set Color Temperature to a specific level? I was looking at some info I found in the device and could find the following: 

 

fibaro.call(QAID_HueMain, "HueCommands", {type='Hue', action='colortemp', deviceID=QAID_HueLight, value=50})

 

I tried to use that as a basis but couldn't figure out if that could work or not.. Any help?

 

My goal is to setup a scene where it turn on a White Ambiance bulb with certain brightness and certain color temp value.

 

Thanks a lot!

Link to post
Share on other sites
  • 0
On 12/17/2020 at 3:55 PM, AntoineF said:

@petrkl12, thanks a lot, amazing app. Would you know if we can add a Lua command in a scene to set Color Temperature to a specific level? I was looking at some info I found in the device and could find the following: 

 

fibaro.call(QAID_HueMain, "HueCommands", {type='Hue', action='colortemp', deviceID=QAID_HueLight, value=50})

 

 

@petrkl12 and all other who might need same solution. I found out by looking further into the forum... this was not working because it seems that QA uses some encoding that scenes are not using. Therefore some atributes not read/understood properly. To solve this, need to add json.encode before your arguments:

 

fibaro.call(36"HueCommands", json.encode({type='Hue', action='colortemp', deviceID=40, value=100}))
 
With this, the scene runs properly!
Link to post
Share on other sites
  • 0

A big and very big thank you for your work!
This is really what I needed and I don't think I'm the only one.
Do you think you can make the duration of the on and off transitions persistent?

Thank you very much see you soon !

Link to post
Share on other sites
  • 0


solved 

 

Hi, 

First of all thank you for your work!

Now to may problem, i can not create a user, it keeps saying "can not create user" 

Whats is I´m doing wrong?

BR

Niclas

Edited by nicman
Link to post
Share on other sites
  • 0

Hi everyone. Just curious, anyone's experiencing unexpected gateway restarts ? I asked Fibaro support and they said I had, literally, over a million records in the events database.

 

I'm suspecting this QA to be a little bit verbose... Is there a way to make the QA silent ? I already set the "Logs" variable to "No", but I'm still having a lot of events : 

 

Please login or register to see this attachment.

Link to post
Share on other sites
  • 0
  • Inquirer
  • onAction messages is not possible to switch off in current QA APIs :(

     

    Link to post
    Share on other sites
    • 0

    First of all, your QA looks amazing. I migrated from my Vera 3 to HC3 last week and I've migrated all my Z-wave devices. Since I've been reading on this forum and blogs. I tried the Hue-sollution offered by Fibaro, but apparently it is much more limited. I was looking at the QA's, however I have limited IT-knowledge. Most of the time this is not a big problem and after reading, help of others ans trial and error, I can mostly help myself out. However, I seem to be having some problems to create a user in the QA. When i push the button on my bridge and in the QA, nothing seems to happen, the bridge is not detected.

     

    I've read previous users who had a similar problem and reporting some problem with de DNS of the router. Could somebody explain me how i could resolve this problem (I have limited IT-knowledge as I said before), however I can go into the router settings and with a step by step guide I'm sure I will be able to figure it out with the help of more experienced users.

     

    If it helps: I'm running a Scarlet/Proximus Modem from a belgian provider (I think it is from Motorola), have u Unifi Switch and a Netgear switch between the Modem and the HC3/Hue Bridge. Both are detected fine by the modem, but the HC3 doesn't seem to detect the Hue Bridge.

     

    Any help with DNS-settings or other, that could help me out would be grately appreciated.

     

    Thank you for the development of the QA and the assistance.

     

    If a translation to Dutch is still necessary, I will gladly help out.

    Link to post
    Share on other sites
    • 0

    It looks really great, unfortunately it does not detect my Hue Bridge. The IP address is correct, and the standard Philips Hue app from the marketplace finds the bridge without issues. Is there anything else i can try? My main issue is that i cannot connect the philips motion sensor, and (still in the box) the outdoor motion sensor. 

    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 9 hours ago, JohanJD said:

    It looks really great, unfortunately it does not detect my Hue Bridge. The IP address is correct, and the standard Philips Hue app from the marketplace finds the bridge without issues. Is there anything else i can try? My main issue is that i cannot connect the philips motion sensor, and (still in the box) the outdoor motion sensor. 

    Could you show me your Variables in HueMain?

     

     

    On 1/17/2021 at 9:04 PM, Rafal_ll said:

    Hello, can you add Polish. if there is a need, I will help

    Polish translation is welcome :)

     

    Please login or register to see this code.

     

    Edited by petrkl12
    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...