Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 1

QA: Twinkly Lights ON / OFF


10der
 Share

Question

subj 

V3 

Please login or register to see this attachment.

 

 

Please login or register to see this image.

/monthly_2020_11/image.png.67a9821257fa15c65153073cb32a3616.png" />

 

 

Please login or register to see this attachment.

 

 

Please login or register to see this attachment.

Edited by 10der
  • Like 4
  • Thanks 2
Link to comment
Share on other sites

Recommended Posts

  • 0

According to the description, the device is marked as dead => it should not be queried (used from HC3).
Logically, I would put it as disabled and for sure as dead ...
Or I misunderstood the idea of Fibar ...
The whole thing is discussed here, among other things, because QA does not behave like a HW device (from this point of view). It would probably want some light on the issue directly from Fibaro.

Link to comment
Share on other sites

  • 0

Hi

Once I am still

not have HC3 to try this QA, I

made a small IoT hub to control my twinkly devices using HomeKit

Please login or register to see this link.

 

This is temporary solution, because next Christmas Gen2 will

have native HomeKit support

 

Twinkly REST API is not perfect, because of auth token makes only one session active at a time. So, if someone polls the device it will make problems to mobile app to map, set up effects etc

 

The MQTT API (used by google assistant) is much more convenient but works only on Gen1, because Gen2 uses SSL broker

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • @m.roszakhi!

    Sir, can i find out how went a process for fix net.HTTPClient with keep-alive connections issues?

    in one month Xmas, Sir.

    Link to comment
    Share on other sites

    • 0

    This one is in backlog, it is planned for one of next versions. 
    I will keep you posted about any timeline when I will get it. 

    • Thanks 1
    Link to comment
    Share on other sites

    • 0

    I have tried to create my own Twinkly QA - in @jgab enviroment it works OK but in HC3 login generates errors:

     

    [28.11.2021] [20:39:35] [[32mDEBUG[0m] [QA_TWINKLY_1001]: [L] basicLogin - stat - {"status":200,"data":"{\"authentication_token\":\"0ecQo85HxG4=\",\"authentication_token_expires_in\":14400,\"challenge-response\":\"efb280e1830f02746a1f09be19b6f18612c96097\",\"code\":1000}","headers":{"connection":"close","content-type":"application/json","content-length":"155"}}

     

    but in HC3

     

    [28.11.2021] [20:41:31] [ERROR] [QA_TWINKLY_1001]: [ERROR] basicLogin - Respond is ERR - Operation canceled

     

    I have 

    Please login or register to see this code.

    I have also tried different headers, increase timeout, also same header that I have in Postman but nothing work.

    Is it bug in HC3?

     

    Thanks

     

    Edited by petrkl12
    Link to comment
    Share on other sites

    • 0

    OMG

    In scenes it works OK but in QA not 🙄

     

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

    • 0

    What if you add ['Connection']='keep-alive' ?

    I've used it with success with the Telegram service where POST used to get connection closed in my QA...

     

    Link to comment
    Share on other sites

    • 0

    @jgab

    test scene:

    Please login or register to see this code.

    Result in scene:

    Please login or register to see this code.

     

    test QA:

    Please login or register to see this code.

     

    Result in QA:

    Please login or register to see this code.

     

    As you can see even with keep-alive it doesn't work in QA but in scene it is OK .... :(

    Workaround could be calling scenes and save results to global variable but this really stupid :)

     

    @m.roszak

    @btatarski

    Could you please check this behaviour of http calling? I can grant you the access to my HC3 (I have the newest beta firmware).

    Thanks 

     

    Edited by petrkl12
    • Thanks 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 17 hours ago, m.roszak said:

    And we are working on it :)

    💗

    Link to comment
    Share on other sites

    • 0

    i am using

    a little trick


    HA Integration -> Works on HC3

     

     

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0
    2 hours ago, SmartHomeEddy said:

    @minsad79 Promising 👍

     

    But integrated as Zigbee in Home Assistant and combined with HC3?

    no

    Integration component

    and HC3

     

     

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0
    On 11/29/2021 at 12:57 PM, m.roszak said:

    And we are working on it :)

    I hope it will be till Christmas 

    QA is prepared :)

    Please login or register to see this attachment.

    • Thanks 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 16 minutes ago, petrkl12 said:

    I hope it will be till Christmas 

    but he that believes not shall be condemned.

    Link to comment
    Share on other sites

    • 0
    On 11/29/2021 at 12:57 PM, m.roszak said:

    And we are working on it :)

    Tested in Alpha version and it works! Thanks

     

    Please login or register to see this attachment.

     

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 1 hour ago, petrkl12 said:

    Tested in Alpha version and it works! Thanks

    That’s moment when old Fibaro user and developer f*cked off as alpha beta test but newcomers users welcomes 

    thank you Fibaro 

    thank you mr @m.roszak

    Sometimes TBH I want also direct Fibaro and Fibaro products to /dev/nul 

    Link to comment
    Share on other sites

    • 0

    newcomer from 2017 with one of the biggest setup in HC3 that helped Fibaro to solve a lot of issues 😉 

    Link to comment
    Share on other sites

    • 0
    18 minutes ago, petrkl12 said:

    newcomer from 2017 with one of the biggest setup in HC3 that helped Fibaro to solve a lot of issues 😉 

     

    Who is that?

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...