Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

ggoetz56
 Share

Question

Hi,

it seems to me that it is a general issue. I can't delete Power data of a certain device.

Here it is a Plug, but it could be any power recording device like switch, RGBW or so. Using "clear power data" in the configuration section deletes all data except "Total consumption" and "This year". Even in the graph section there are no values reported.

But the the figures of "Total consumption" and "This year" above remains. I didn't export data in tge Gereral-section yet.

 

Is there a way to delete them too? Except of Fatory Reset the device.

 

Btw. the total consumption reported in the icon doesn't match that in the configuration  section.

 

Thanks

Gerhard

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 1

I think that you shoiuld write simple code to clear these data from lua code level, by using update Property function. Please look at on Swagger and investigate structure of properties of your devoce and adjust source code

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Thanks you care about,

    but unfortunately Swagger means nothing to me. This is the environment to create api commands. Never understood the sense in using it.

     

    But I can't believe I'm the only one who would delete consumption Data of a single device. " Clear Power data" should delete all power data and not part and it seem that the database is cleared by using the button ,because in the graph section there are no longer any values reported. 

     

    So no one who could confirm this issue?

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...