Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

24 units bought, 1 returned, 13 not working properly...


Pedro Lima
 Share

Question

Posted (edited)

Hi,

 

I've bought on Amazon, 24 units of FIBARO FGDW-002-1.

 

I own a Raspberry Pi 4 8Gb with openHAB (OH) 3.3 on a 250GB SSD via USB and I use a Aeotec Gen5+ USB pen for the Z-Wave communications, as well as two Aeotec Range Extender 7.

 

The house have a Cave floor (where one extender is placed), a Ground floor (where the RPi and Z-Wave pen is placed) and a First floor (where the second extender is placed).

 

I am using multiple switches for lights, blinds and blackouts from Simon brand, Serie 100 iO, which communicates via Z-Wave and act also as node repeaters, since they are main powered.

 

So the Z-Wave network works without problems.

 

These are the steps I did so far:

 

  1. Installed Fibaro sensors one-by-one, using the "discovery" option within OH and 23 where found (one was never found, the sensor was clearly openned and used before so it was returned to Amazon as defective)
  2. After having them in the system, 20 of them I could setup the different channels with items (status, temperature, battery power, etc.) - some have less than 50% battery
  3. Only 10 I got information from (and not even consistently, because sometimes they do not transmit data)
  4. 11 units never sent any information (so it's represented as NULL in OH system)
  5. 2 units never even properly connected to the system (channels were never available, so I cannot setup items)
  6. Tried multiple times to reset those 13 units and reconnect them to OH, never worked (sometimes I even waited days to see if somehow it would start communicating)
  7. After a full month without success, removed those 13 sensors from OH and then connected the Aeotec USB pen to a PC and used the PC Controller software (previously known as Zensys Tools) from Silicon Labs, to be able to declare as Failed and then remove those failed nodes completely from the USB pen
  8. Tried multiple times to reconnect the sensors to OH after that, but now they never even show up in discovery mode nor directly on the PC Controller software

 

So I am sitting here with 13 units that never actually worked (more than 600€) and countless hours already lost trying to connect this to a Z-Wave system.

 

This is unbelievable and I never thought it would require such difficulty to simply connect some basic sensors.

 

I've worked with many different sensors from different brands, communicating via WiFi, ZigBee and 433Mhz and none of them ever gave me any headache, but these are simply a real pain and I will surely NEVER again buy these, since it is just a huge waste of money.

 

Now, since I cannot simply return this because it has already gone too much time since I bought it (something like a month and a half), I need to know what can I do to be able to connect this to the system since I will not simply have 600€ sitting there wasted in 13 expensive sensors doing nothing...

 

Any help will be obviously appreciated, but I will have to share this experience online with the communities.

 

Thank you.

 

Best regards,

Pedro Lima

Edited by Pedro Lima
Correcting writting mistakes
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Posted (edited)

Very good post with lots of information.

 

My first thought in similar cases is "you need Zniffer to find out what is going on" - but we will come to that later

 

I guess, but you do not say it, that you have been thinking "it is quite unlikely to get so many bad devices" and furthermore you have researched and do not get any similar complaints, right? Neither here, nor on the OpenHAB forum, correct?

 

We have to start somewhere and I'll pick two things.

 

First, you really need to press and hold the tamper switch while including, and while including every few seconds redo the "wake up click rhythm" so OpenHAB driver can "interview" and control the device. You do that preferably where you want that sensor but if it is too far away, you bring it closer to the stick to include. Then when you move it back in position, "update the mesh" on this device (or whatever that is called in OpenHAB, I don't use this gateway software very often).

 

Second thing:

 

20 hours ago, Pedro Lima said:

some have less than 50% battery

That is indeed unexpected when these devices ar new. But measuring batteries is tricky and I recently spent a lot of time and effort to work out when and how batteries are measured and levels reported. It probably doesn't work the way you think it does and it depends on the device. If you can, please try the "resistor test" with a voltmeter, it is mentioned here along with results of different sensors. I think it is worth reading a few of the posts here:

 

The fact that you mention this tells me you are aware of the possible problems caused by batteries but since this is a public forum I am going to mention it anyway. The "inclusion" does not take more power than reporting "open/close" but the time it takes is much, much longer. I certainly have seen cases of batteries that were still "good enough" to report state or temperature, but would fail inclusion. It isn't very common though. IMHO with some experience, the brightness of the blue LED can actually tell you how good the battery is...

Edited by petergebruers
  • Like 1
Link to comment
Share on other sites

  • 0

For sake of completeness... Linking to your topic on OpenHAB

 

Please login or register to see this link.

 

Correct me if I am wrong, Amazon accepted the return of your sensors, so problem "solved".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...