Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

LED colors Philio PSK01 stopped changing green<->blue



Hello everyone,


I've been running my HC3 for a couple of months now. Main target was replacing my old alarm system and until now I've succeeded quite well. I'm running a Philio keypad to run Away, Night and Home scenes & profiles.


I'm using a simple script to change the configuration of the keypad when the alarm is armed / disarmed:

fibaro.call(DeviceID, "setConfiguration",1,1,1) for Entry Control Mode - meaning the user has to enter PIN and "unlock" button to disarm the alarm. LED color should be Blue.

fibaro.call(DeviceID, "setConfiguration",1,1,2) for Central Scene Mode - meaning the user can enter the "lock" and "9" buttons to arm the alarm for Away and Night profiles respectively. LED color should now be Green.


Since upgrading to firmware 5.140.17 the scenes running this, still work. However, strangely enough the keypad LED color doesn't change from blue (central scene mode) to green (entry control mode) and the other way around when the scenes are run.


Any ideas?


Thanks in advance!



Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Inquirer
  • In the end I decided to remove the device and add it again, which would cost a lot of work. Was not successfull removing it, then tried resetting the device. After a reset only the usernames of everyone with access to the house were gone, but everything else was the same and the keypad was working like before.


    Really don't get what happened, but my problem is gone. For now.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • The problem returned after a couple of hours, so decided to try to remove it again. (Normal procedure: PC - unlock/enter - 0 - 1 - unlock/enter.) Now removing worked.

    After that, I added the keypad again, only to find out it immediately falls asleep after using it.... Even though I set config parameter 4 to value 0. Also tried switching the buzzer off using parameter 2, value 0. Doesn't work either.


    In the end I have all the functionality I need, but it is just not working as nicely as it has been since I started using it.



    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...