Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Wall plugs lost z-wave communication



I have two FGWP-102 (FW version 3.2) which have worked normally for some years. During the last weeks, they both have malfunctioned in a strange way, first one then the other. The first observation was that they did not respond to remote controls, neither from the HC2 UI nor from scenes. The plug could still be operated using the button on the plug. The UI indicated "communication problem", which could not be corrected by clicking the icon to re-establish connection. It seems that the plug lost all connections to the z-wave network. The HC2 runs SW version 4.630.


The firmware version of the plug is confirmed as the last version. Several attempts to "soft reconfigure" all failed, with a message displaying a strange device ID. See attached screen dump, where the plug has device id =  324 (the master unit is 323), while the error message shows reconfiguration failure for "id 4097". There is no such id in use in my system. Full reconfiguration also fails. Trying to change some parameter to a different value and storing it did not kick-start the unit. 


When this happened on the first plug, I was able to correct it by excluding the device from the system (forced exclusion), factory resetting the plug, and then re-install it. This, of course, gives it a new device id, and changes had to be made to all scenes where this device is used, but the "new" plug functions normally. This shows that the problem is not with the hardware. I have two questions:

  • What may have caused these units to lose communication? Can the firmware be corrupted by an outside event?
  • Is there any way I can rectify the problem without resetting and re-installing the plug? 


Any ideas?

Please login or register to see this attachment.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
18 hours ago, knuth said:

It seems that the plug lost all connections to the z-wave network.

Yes, that is the most likely cause. This problem has been reported since 2017... occasionally. The plugs act is if they got "excluded" from the network, so only local control works


There have been many attempts at explaining what is going on (eg non volatile memory corruption)  but AFAIK this issue is still unresolved


Long discussion here



18 hours ago, knuth said:

Is there any way I can rectify the problem without resetting and re-installing the plug? 

IMHO the only resolution is "force delete" the misbehaving device on the HC to clean up the mess and then "add" the device back, ... which leads to new device IDs which never makes anybody happy...

  • Thanks 1
Link to comment
Share on other sites

  • 0
  • Inquirer
  • Thanks, Peter. I expected that there was no easy solution - which you confirmed. I failed to find the 2017 discussion when I searched the forum for answers.

    I may add that force delete was not sufficient, I had to do a factory reset to be able to re-add the device.


    I appreciate that you are still active on the Fibaro Forum, keeping it alive when activity seems to have dropped. Glad to have you here!

    Link to comment
    Share on other sites

    • 0


    You can find my posts about plugs here.
    My plug always worked in a certain place (near the refrigerator and microwave oven) for about 14-21 days. ONLY complete exclusion, factory reset and inclusion in HC3 always helped. Tested several times with placement in another place (she was always in the service for several months elsewhere). When I put the plug back above the kitchen counter near the microwave, the outage occurred again within 2-3 weeks! Now there is a Shelly plug in this place and a Fibaro plug is in another place without failure for 1.5 years!

    BEWARE of any nearby sources of electromagnetic radiation. Watch out for nearby wi-fi, microwaves, watch out for nearby PIR+MW security device detectors.




    Link to comment
    Share on other sites

    • 0

    I had 26 Fibaro plugs ordered through last several years. One came faulty out of the box and one ordered 5 years ago died. So now I have 24 Fibaro plugs of which are all working as expected and without any problems. The one that died, before it died get disconnected from my HC2 two times and I had to reinstall it. Unfortunately third time it was not possible to reconnect it since it just died.


    I think that Fibaro plugs are very reliable even more than their gateways :-D


    On the other hand, I have 15 Fibaro motion sensors, none of them ever died, but few of them likes to get disconnected from HC2 about once a year and I have to include them again.


    Also I have bunch of old door/window sensors (1st gen) that were working fine for years, but now lately they like to drain batteries more quickly. Also, some of them are at least once per day reported as dead (disconnected), but then they get connected back either by themselves or by changing state of the sensor. I noticed that on some of them LED flash once every few minutes even state is not changed and are not waked up to send report to gateway. Oh, but now I'm OT :-)



    • Like 1
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...