Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

Trying to connect a Tapo C100 IP Camera

Recommended Posts

Hi, I have an HC3L and have been trying to connect a Tapo C100 IP Camera but have neither the JPG nor the MJPG streaming paths which both seem to be needed in the "Advanced" settings view. (I have tried using a RTSP path which works with the program ManyCam on my Laptop, but no picture is seen in neither in the Yubii app nor the FIBARO HC3L. The camera works well in the Tapo app however...)

Link to comment

@Erik NorrmanHello and welcome to the community.


I don't know your Tapo C100 IP camera.


But I've also connected a wifi IP camera to hc3l. It's one from D-Link, and it's working fine.


Can you see your camera image in the preview window on the hc3l?  Maybe you have to turn off the cameras own connection to the internet.

Below my settings.  IP and Password settings are not on the pic.



Please login or register to see this attachment.

Link to comment

As far as I know, the preview in the web user interface uses the JPG or MJPG path, depending on the Preview settings.

And in the (new) Yubii app the RTSP path is used. 

Link to comment

Hi Erik

Its not possible to connect Tapo directly Tapo uses only RTSP and not Http.

Fibaro does not support rtsp unfortunable


I might be wrong, but i only manage to get http camera into hc2 and hc3

Link to comment
  • Topic Author
  • Thank you! I have managed to connect Tapo C100 via RTPS to the program ManyCam and it works fine but it seems, as you say, that It does not work in FIBARO although there is a box in the HC3L interface for device IP Camera named RTPS.  (I know that no picture shall appear in the HC3L interface but in the Yubii app under "Surveillance".)

    I had a D-Link 2132L earlier and it worked perfectly well in FIBARO when I used the JPG and MJPG stream paths mentioned by Fabir above. But the camera has started to behave kind of strange since it turns off itself after a while. I have not managed to identify why. Anybody has an idea why?



    Link to comment
    • 1 month later...

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...