Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


Sign in to follow this  
alutke

Calibration Roller Shutter with Somfy Glydea 35 WT

Recommended Posts

I have two Glydea 35 WT curtain motorisation, by Somfy. And each added a module Fibaro Roller Shutter 2 FGRM-222 , the problem arises in calibration. When I try to perform the calibration, the curtain opens fully, but in the process they should fully close it closes only about 2 inches.

If I try to trigger it closes sometimes closes just those two centimeters, and sometimes completely closes it to open.

Could not identify any pattern for closing / opening full or not. Sometimes it works, sometimes not.

I suspect that may be why limit the curtain is automatic, unless the seller told me it was that way. But I tried to select the "Roller Blind Mode, without positionin" option, but that way the commands do not perform any action.

If the curtain is connected directly, without going through fibaro module, work normally.

Any suggestions of what I can accomplish for my curtains work-integrated fibaro?

Share this post


Link to post
Share on other sites

The problem is with Gladea model. Though it works on AC power, It is actually a DC motor inside with a AC to DC converter and electronic limiting switching circuitry integrated inside. FIBARO roller shutter calibrates and sets positioning depending on Power consumption limit we set(default 10W) and This can will only work if motor(AC Load) is directly connected with FIBARO RS module with out any electronic circuits in between.

In short, you have to use it with blind positioning inactive only.

Share this post


Link to post
Share on other sites

Connect Roller shutter 2 normally and switch it to "roller blind with positioning" mode, and set parameter 18 to 0. Then use switches to manually open/close the roller. Observe power consumption in the module. When roller reaches the end the power should drop significantly. Take that value, increase is a little (e.g. when it is 6 enter 8 and so on) and enter it to parameter 18. When you see that power reacts slowly on pushing switches, increase parameter 17 to e.g. 2s.

Share this post


Link to post
Share on other sites
  • Topic Author
  • I was able to test only today, but to leave a message if someone has the same problem. It worked perfectly as indicated by j.nowacki, thanks.

    Share this post


    Link to post
    Share on other sites
    Connect Roller shutter 2 normally and switch it to "roller blind with positioning" mode, and set parameter 18 to 0. Then use switches to manually open/close the roller. Observe power consumption in the module. When roller reaches the end the power should drop significantly. Take that value, increase is a little (e.g. when it is 6 enter 8 and so on) and enter it to parameter 18. When you see that power reacts slowly on pushing switches, increase parameter 17 to e.g. 2s.

    I am using the roller shutter 2 to control a window opener. The calibration process does not complete. It opens the window, shuts the window and then stops. The window does not open again. I have followed the above procedure, but the calibration process does not seem to honour parameter 17. The calibration doesn't pause between direction changes. I think it stops because although the motor starts to spin the opposite way the gearbox has a small amount of slack in it and the power required before the gearbox slack is taken up is too small to register, and the relay thinks it is back open again.

    Is there a way to get the calibration to honour parameter 17?

    Share this post


    Link to post
    Share on other sites

    With the window closed I set parameter 29 to 1. The calibration seems to start up fine. Whilst the calibration takes place the led flashes.

    The window opens, the led flashes green whilst it gets to full opening. As soon as it gets to full opening the motor reverses and the led flashes red. It gets to fully closed and the led flashes green very briefly but the window stays closed.

    [ Added: 2014-07-18, 16:58 ]

    I have a vera lite as a controller, rather than a Fibaro controller. The window operation works if you click open or close, but to get it to an intermediate opening, say 70% it will only turn in the motor for a fraction of a second.

    Share this post


    Link to post
    Share on other sites
    Connect Roller shutter 2 normally and switch it to "roller blind with positioning" mode, and set parameter 18 to 0. Then use switches to manually open/close the roller. Observe power consumption in the module. When roller reaches the end the power should drop significantly. Take that value, increase is a little (e.g. when it is 6 enter 8 and so on) and enter it to parameter 18. When you see that power reacts slowly on pushing switches, increase parameter 17 to e.g. 2s.

    I tried these steps, still the same. When the 'Blind with Position Active', Curtain moves a little and stops. I tried resetting, Add/Delete RShutter module, but No luck. When i set 'Blind with Position Inactive', I am only able to Close/Open completely.

    Has anybody got it the Calibration working correctly? Any help?

    Share this post


    Link to post
    Share on other sites

    If am right the calibration procedure is as following

    1. Shutter goes to open position (green led blinking) in order to get to first end point. The end point is detected electronically on power consumtion by param.No.18 (if it is already on endpoint it swiches off after about 4 sec.)

    2. Shutter goes to close position (red led blinking) to the other endpoint and stops again electronically detecting power going down.

    3. Shutter goes back to open position (green led blinking) to the other endpoint.

    4. The shutter calculate moving time between 2(fully open/close) endpoints in order to do positioning later (led goes off)

    The problem with Glydea 35WT is that it moves with acceleration (for about 2 secs) and the other our problem is that the moving between opposite position is too short (about 4 sec, we have only 1 meter width blind). Because of the that it is not possible to do fine positioning with FGRM (duiring short ON time the glydea does almost no move because of acceleration) and problem with detecting electronic endpoints (only 3W for Par.No.18 works for me)

    j.nowacki could your provide more info on how power consumption is used duiring detecting end points? Should it rise to something defined value? Should it drop to some percantage of par.18 after?

    Thank you

    Share this post


    Link to post
    Share on other sites

    Roller Shutter module has power meter included. When blind reaches limit switches, the engine turns off and decrease in power consumption is detected. Parameter 18 contains power use (in watts) below which the Roller Shutter module will assume that the limit switch was enabled.

    Share this post


    Link to post
    Share on other sites

    Hi guys, can somebody tell me where and how did you connect the Roller shutter 2 to the somfy glydea motor? First you rip off the hall electronics and then just connect RS2 directly to the 3 motor wires and prform calibration as j.nowacki said?

     

    Everywhere i look, the somfy dry switches are connected to its RJ45 socket but this is not the way to go with RS2, is not it?

    can someone explain exactly how it should be done?

     

    Thank you in advance!

    Share this post


    Link to post
    Share on other sites

    I'm struggling to find any answers on the forum to the issue I'm experiencing.

     

    I have a Somy Glydea 35 WT connected to a Fibaro Roller Shutter 2. It is controlling a 4 metre wide curtain.

     

    When I calibrate the Fibaro Roller shutter, the curtain closes fully, but when it then tries to open the motor just judders back for less than 1 second increments moving a centimetre or so each time. If I leave it long enough, over 30 minutes the curtain may have move a foot open.

     

    I have tried @j.nowacki's suggestion above, but it changes nothing. I'm wondering if I have a broken motor?

     

     

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    Sign in to follow this  

    ×
    ×
    • Create New...