Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Aeon Labs Home Energy Meter DSB28-ZWEU





I apologize my bad English.

The aeon labs energy meter, installed strictly in accordance with the instructions given in the user documentation, is reporting incorrect measurements.
Specifically, the measured voltage is incorrect in all three phases. It is showing about 57V for each phase of 220V. As a result, watts and KWh are miscalculated.

All configuration parameters are related to reporting frequency, so changing these settings does not affect the voltage measurement.


Please login or register to see this image.

Aeon Labs Home Energy Meter DSB28-ZWEU, 3 phases, 4 wires, (3P4).

z wave controller: Fibaro Home Center 2. Software version 4.063 Beta (also tested on 4.056 stable).


Has anyone experienced a similar issue?
Any clue on how to fix it?


thanks in advance!






Please login or register to see this attachment.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I have exactly the same issue. Also 85~86 volts and 57~58 volts measured by the Aeon Labs DSB28-ZWEU, for two years now.

Still no solution.


Device type: Home Energy Meter DSB28-ZWXX E2

Firmware version: 1.5


Fibaro version: 4.080


I think there is never come a fix for it.

I have multiple time reported in the bug tracker but the problem is still there.

If parameter 1 can be set to the correct voltage the problem should be solved, but it is impossible to set parameter 1.

Link to comment
Share on other sites

  • 0

I have a similar problem in  New Zealand 2 phase and I use the 3rd clamp on the HWC supply.


in HC has the 4 reouts for voltage. They are not correct but close enough for this post.


Parent  240v

Clamp 1 120v

Clamp 2 120v

Clamp 3 240v


I can not get the device to correctly tell me the voltage on Phase 1 and Phase 2 and HWC... 

Link to comment
Share on other sites

  • 0

Are you 100% sure that you put clamps on live phase wires only and not one on neutral wire? Did you also check arrow and correctly install all three clamps? What about parameters? Do you really use correct HEM for your system? If you have only 1 phase on incoming cable then you can use only 1 clamp meter, for 2 phase 2 clamp meter and for 3 phase 3 clamp meter and you can not use  extra clamp to measure consumption of some specific device like 3 clamp meter used on 2 phase system and then third clamp connect to measure consumption of heater or something.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...