Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Dimmer 2: S2 association isn't always responding


keldertrapken
 Share

Question

Hi,

 

My Dimmer 2 has a second switch (push button) installed on it. This push button is wired on the S2 input. Via association in group 5, it does wat it has to do.

 

BUT: after it's not used for a while, the associated dimmer is not working when pushing the button. After a second push, all is back to normal for a while... Does anybody has an idea what causes this? A solution? Did I forget sometjing?

 

Thanks for responding!

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 1

Contacted Fibaro support and got the explanation. Really disappointed that this doesn´t work better...

 

My question:

Hi,

I have two dimmer 2 where I have direct associations to other sources on S2.

#1 Dimmer 2 connected to other Dimmer 2 (endpoint 0, group 4 and 5, single associations)
#2 Dimmer 2 connected to domitech led lamp and Fibaro wall plug (endpoint 0, group 4 and 5, single associations)

My problem is that on both it often takes two tries to turn on the lights on S2. The lights connected on S1 always works on first try. It seems like it´s sleeping and uses the first press to wake up.

Both dimmer are updated to version 3.4.

How do I fix this?

 

The answer:

 

Hello,

Yes, it is true. It does change the status accordingly if you use just the physical switch.
In case you use physical switch (turn ON) and then use BUI or mobile app (to turn OFF)

You can disable the association in 4th group and create a scene that would activate it instead.
Please set parameter 28 Scene activation functionality – activated.
I attached the scene that you need to operate ON / OFF the second Dimmer 2 with S2.
Not to double the event, please erase the association in the group 4.

There is also possibility to create scenes in Lua and use code to brighten or dim. The problem is that you cannot use both on the same button (choose either startLevelIncrease or stopLevelDecrease – both actions cannot be used at the same time and for the same button).
fibaro:call(ID, “startLevelIncrease”)
fibaro:call(ID, “stopLevelDecrease”)
fibaro:call(ID, “stopLevelChange”)

 

Best regards

  • Like 1
Link to comment
Share on other sites

  • 0

I have exactly the same problem:-(

Øystein

Sorry to hijack but, Kort spørsmål, kan knapp 2 styre en annen dimmer som sitter et annnet sted?

Sliter med å få styrt lys som ikke har strøm fra stedet bryterene er.

Hvordan i svarte får jeg satt HS til factory default, support her er ikke veldig pro aktive

Please login or register to see this image.

/emoticons/default_icon_sad.gif" alt=":-(" />

Jeg mangler Add device i GUI

Kim G

Link to comment
Share on other sites

  • 0

@soft -q1 yes this is called association one of the more powerful features of z-wave. check the manual on how to use it on your particular device or search the forum.

Q2 - it's in the manual.

@All

I think associations have to compete with the rest of the z-wave network and I suppose if there is other traffic going on at the same time the device will either not send to interfere with the other traffic or the transmission collides and fail.

Link to comment
Share on other sites

  • 0

Joachim, Q2: the problem I have is that the press plus while power up, and release when the first light is solid, is not working. 

Link to comment
Share on other sites

  • 0

@joachim, thank you for clearing up the association bit, mos helpful.

Link to comment
Share on other sites

  • 0

OK!, solved it myself, sort of embarrassing, I was NOT admin user, RTFM!

Sorry for all the hassle.

Link to comment
Share on other sites

  • 0

Yep, I get this delay also when the system has been idle. Almost like it needs to wake up then it's all fine and the association works as it should.

Link to comment
Share on other sites

  • 0

Hi again, just trying to understand,

With the second switch (push button) installed on it. This push button is wired on the S2 input,

can this button then control a different dimmer, sitting in a different location?.

i.e the dimmer 2 will control "itself" from switch one, and communicate with a different dimmer from switch two?.

 

Or do I need a Dimmer 2 behind the second switch to control a remote Dimmer 2 ?

The problem I have is lack of space behind the switches, I need 5 switches in the space of 3.

 

Link to comment
Share on other sites

  • 0

Hi again, just trying to understand,

With the second switch (push button) installed on it. This push button is wired on the S2 input,

can this button then control a different dimmer, sitting in a different location?.

Every dimmer has 2 inputs that can be programmed to control anything else.

S1 will always control the dimmer but can also control other lights at the same time.

S2 can be ascoosiated with any other dimmer within z-wave range (or start scenes etc etc)

So with 3 dimmer as you can get 6 separate switches where S2 can control whatever you want.

Link to comment
Share on other sites

  • 0

I have the same behavior in two separate homes. Based on the Fibaro Support response above, it seems when I turn off the lights with mobile app, and try to turn them on with S2 (associated to two dimmers) the first click doesn't work. Will be investigating it later, maybe the two dimmers gets "unsynrchronized" due to turning off them via mobile app and the first click will synchronize the dimmers, and the second click then works. But that is just my guess.

Link to comment
Share on other sites

  • 0

So I'm able to always reproduce the issue. When both of the lights are turned off by the mobile app (external Z-wave source), when trying to turn them on via S2 association, the lights stays off. The second S2 click works. According to Fibaro support info above, on the first click the dimmers are synchronized. But, both of the dimmers are set to 0 brightness, so there's nothing to synchronize. I'm considering this as a bug.

 

I'm turning off these lights every night via the mobile app, so I'm experiencing every day the first S2 click to do nothing. I've wrote a rule in my home automation system (OpenHAB) which detects S2 click (scene 26 activated) and it checks the lights status, if they are off it will turn them on, if they are on, it will turn them off. In the code there's a sleep part to not interfere with Fibaro's "synchronization" attempts.

 

After testing it, it works. But it's a workaround.

 

Not the prettiest code I've wrote but for now it works (OpenHAB rule):

Please login or register to see this code.

 

  • Like 1
Link to comment
Share on other sites

  • 0
Posted (edited)

And this bug is still present in Dimmer 2 firmware v3.5 ...

Edited by swain
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...