Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Dimmer 2 S2 input not honoring max brightness in three-way switching setup





I'm currently using a Fibaro Dimmer 2 in a three-way (we in the UK would call it 'two-way') lighting setup, where S1 & S2 are used to control the same lighting circuit.


I want the switches to operate in a basic 'on-off' fashion - No dimming required as smart bulbs are fed by this circuit.


I have installed a Dimmer 2 bypass, as we were experiencing flickering with the relay in the 'off' state. However, following installation of the bypass, the auto-calibration, and 'red' menu option calibration failed, meaning the overload protection kicked in after about 5 seconds of use.


I have therefore manually set my max brightness to 45, a value that seems to be stable.


Operating the relay via an app, everything performs as expected. When I press the momentary switch on S1, everything works correctly.


However, when I use the S2 switch, the brightness level is set to 99%, which triggers overload protection.


My options settings are as follows:


        zwave.configurationV1.configurationSet(parameterNumber: 2, size: 1, scaledConfigurationValue: 0),    // Manual Min Brightness Setting
        zwave.configurationV1.configurationSet(parameterNumber: 2, size: 1, scaledConfigurationValue: 45),    // Manual Max Brightness Setting
        zwave.configurationV1.configurationSet(parameterNumber: 13, size: 1, scaledConfigurationValue: 2),    // Bypass Calibration
        zwave.configurationV1.configurationSet(parameterNumber: 19, size: 1, scaledConfigurationValue: 45),    // Switch on brightness level 
        zwave.configurationV1.configurationSet(parameterNumber: 20, size: 1, scaledConfigurationValue: 0),    // Enable Dimmer to work with Toggle Switch
        zwave.configurationV1.configurationSet(parameterNumber: 26, size: 1, scaledConfigurationValue: 1),    // S2 can control dimmer as well
        zwave.configurationV1.configurationSet(parameterNumber: 32, size: 1, scaledConfigurationValue: 1),    // On/Off Mode (0=Dimmer,1=On/Off,2=Auto)
        zwave.configurationV1.configurationSet(parameterNumber: 35, size: 1, scaledConfigurationValue: 0),    // Auto Calibration (0=No after Power On, 1=On First Power On, 2=On Each Power On)


Any advice please? I'd dearly love to get the switch on S2 to behave correctly.

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...