Jump to content
  • 0
jmenoud

Firmeware update for FGS-213

Question

Hello,

 

I just bought some new FGS-213 relay switch and add them to my domitic system.

 

I found out some issues (regarding to FGS-212 modules that I have and do not have those problems):

- If I press the switch, the relay need 0.5 till second to change the state

- If I press the switch 2 times with 2 seconds delay, the second state change is lost

- If I command the switch from the domotic box, I need to wait ~30 second for the next command, otherwise it is lost

- If I command the switch from the domotic box, the state sometimes in the domotic box is not updated

I check and re-check the Z-Wave network and change the location of the switches. It's definitively not a Z-Wave network issue.

I contacted the dealer and he told me the my problems are due to firmware problems in the first versions of the switch. Do somebody else have the same issues?

 

Which solutions do I have to update my firmware (I do not have a HC box)? Which alternative do I have? Can I ask the dealer to replace them?

 

Thanks for your answers.

 

Jean-Philippe

 

PS. I won't buy an HC box only to update the firmware of my modules

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Dnia 22.10.2016 o 14:28, jmenoud napisał:

Hello,

 

I just bought some new FGS-213 relay switch and add them to my domitic system.

 

I found out some issues (regarding to FGS-212 modules that I have and do not have those problems):

- If I press the switch, the relay need 0.5 till second to change the state

- If I press the switch 2 times with 2 seconds delay, the second state change is lost

- If I command the switch from the domotic box, I need to wait ~30 second for the next command, otherwise it is lost

- If I command the switch from the domotic box, the state sometimes in the domotic box is not updated

I check and re-check the Z-Wave network and change the location of the switches. It's definitively not a Z-Wave network issue.

I contacted the dealer and he told me the my problems are due to firmware problems in the first versions of the switch. Do somebody else have the same issues?

 

Which solutions do I have to update my firmware (I do not have a HC box)? Which alternative do I have? Can I ask the dealer to replace them?

 

Thanks for your answers.

 

Jean-Philippe

 

PS. I won't buy an HC box only to update the firmware of my modules

Hello,

 

In this case, you will have to send the Single Switch 2 to our service on your warranty agreement.

If you did not do such procedure, please contact our Support at support@fibaro.com . Explain the issue and ask for the warranty procedure. When you receive your case number, please send it to me via private message on the Forum.

Share this post


Link to post
Share on other sites
  • 0

Oh my god, I'm so glad I found this issue even if just to confirm that I'm not the only one.

 

I have 22 of these devices. They were an investment meant to control every light in my house but I hit upon exactly these issues.

 

I also don't have an HC box (and have no intention of buying one) but I really need a solution here. If a firmware upgrade will solve these issues, is there any way I can do it on my devices using a z-wave USB stick or something?

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • Hello,

     

    I don't think there is a solution to update the firmware of these modules. The firmware update can only be done with HC boxes and when I did my researches, I saw that the list of module, which can be upgrade by the HC box, is very limited and the FGS-213 are not in the list.

     

    I think that you don't have any other choice the remove them all and send them back to your supplier...

     

    Hope it helps you.

    Share this post


    Link to post
    Share on other sites
    • 0
    11 hours ago, nunofgs said:

    Oh my god, I'm so glad I found this issue even if just to confirm that I'm not the only one.

     

    I have 22 of these devices. They were an investment meant to control every light in my house but I hit upon exactly these issues.

     

    I also don't have an HC box (and have no intention of buying one) but I really need a solution here. If a firmware upgrade will solve these issues, is there any way I can do it on my devices using a z-wave USB stick or something?

     

    as @T.Konopka said, you can send it to Fibaro, or to us, or buy (for less than 14 days) HC over amazon and send it back after you did the updates o.O

    Share this post


    Link to post
    Share on other sites
    • 0
    2 hours ago, tinman said:

     or buy (for less than 14 days) HC over amazon and send it back after you did the updates o.O

    Seriously? Come on, @tinman ;)

     

    14 hours ago, nunofgs said:

    I also don't have an HC box (and have no intention of buying one) but I really need a solution here. If a firmware upgrade will solve these issues, is there any way I can do it on my devices using a z-wave USB stick or something?

    Well, we cannot guarantee that updating the modules will solve the issues. Honestly, we are not certain what causes the issues as the modules work with third party gateway.

    Share this post


    Link to post
    Share on other sites
    • 0
    On 22. 10. 2016 at 2:28 PM, jmenoud said:

    - If I press the switch, the relay need 0.5 till second to change the state

    - If I press the switch 2 times with 2 seconds delay, the second state change is lost

    - If I command the switch from the domotic box, I need to wait ~30 second for the next command, otherwise it is lost

    - If I command the switch from the domotic box, the state sometimes in the domotic box is not updated

    I check and re-check the Z-Wave network and change the location of the switches. It's definitively not a Z-Wave network issue.

    I contacted the dealer and he told me the my problems are due to firmware problems in the first versions of the switch.

     

    1. Problem: If I press the switch, the relay need 0.5 till second to change the state.
      Waiting for double/triple click. So i gues it's feature.
    2. Problem: If I press the switch 2 times with 2 seconds delay, the second state change is lost.
      Interesting, they are pretty quick to me (in my models). Maybe isse in Switch itself.
    3. Problem: If I command the switch from the domotic box, I need to wait ~30 second for the next command, otherwise it is lost.
      Do you have other switches to confirm that Switch is a problem? Wild guess: Something get lost on receiving command by switch or in sending command in your gateway. Or can your dealer test it. He should have some model, where they can verify this.
    4. Problem: If I command the switch from the domotic box, the state sometimes in the domotic box is not updated.
      I do not know domotic box, but can you check "association group 1" if it's set to Z-Wave gateway?

    Share this post


    Link to post
    Share on other sites
    • 0
    On ‎22‎-‎10‎-‎2016 at 2:28 PM, jmenoud said:

    Hello,

     

    I just bought some new FGS-213 relay switch and add them to my domitic system.

     

    I found out some issues (regarding to FGS-212 modules that I have and do not have those problems):

    - If I press the switch, the relay need 0.5 till second to change the state

    - If I press the switch 2 times with 2 seconds delay, the second state change is lost

    - If I command the switch from the domotic box, I need to wait ~30 second for the next command, otherwise it is lost

    - If I command the switch from the domotic box, the state sometimes in the domotic box is not updated

    I check and re-check the Z-Wave network and change the location of the switches. It's definitively not a Z-Wave network issue.

    I contacted the dealer and he told me the my problems are due to firmware problems in the first versions of the switch. Do somebody else have the same issues?

     

    Which solutions do I have to update my firmware (I do not have a HC box)? Which alternative do I have? Can I ask the dealer to replace them?

     

    Thanks for your answers.

     

    Jean-Philippe

     

    PS. I won't buy an HC box only to update the firmware of my modules

    do you use a usb aeon labs z-wave stick? try to update the firmware of the stick.

    Share this post


    Link to post
    Share on other sites
    • 0

    Well, that's it for me. I RMA'ed 22x FGS-223 devices that exhibit this behaviour. Here is the cover letter I sent with my package:

     

    Quote

     

    Dear Fibaro,

     

    I purchased 22x Double Switch 2 (FGS-223) devices on the 27th of April, 2017.

     

    Before I describe the problem, I just want to say I love Fibaro devices and I also have many Fibaro rollershutters, door sensors, etc. I also have relay switches from other brands (even one with a simple ESP8266) and they all work instantaneously and as expected.

     

    I am extremely disappointed with the quality of these FGS-223 Double Switch devices.

     

    In short, I’m having the following issues:

    1. There is a large delay when pressing the physical switch until the light actually turns on/off. This delay is very noticeable (at least 500ms+) and extremely unpleasant to use day-to-day.

    2. Sometimes toggling the physical switch does not turn on the light, even though I can hear the relay clicking!

    3. When controlling via software, most commands are lost. Only about one toggle per 30 seconds is accepted. The rest seem to be ignored.

    4. When controlling via software, the state of the relay does not match the actual physical state.

    After a long discussion with your email support, I was advised to send these devices to you for RMA. (case number #94161)

    It is my hope that one of the following happens (by order of preference, from most preferred to least):

    1. Update the firmware on the 22x FGS-223, since the newer firmware appears to fix these issues, and confirm that none of the above issues continue to occur. (https://forum.fibaro.com/index.php?/topic/22901-firmeware-update-for-fgs-213/&tab=comments#comment-123676)

    2. Exchange the 22x FGS-223 for 22x FGS-222, as apparently they do not have that issue (I have no way to confirm, but seems to be the consensus on the internet).

    3. Return the amount I paid, in full.

     

    Sincerely,

     

     

    I am EXTREMELY disappointed with Fibaro Support, to the point that I will never buy or recommend a Fibaro product again. The response from their support was literally:

     

    Quote

    Dear Sir,

    we have sent back to you all devices back yesterday.
    We can not replace devices with another, for example FGS223 to FGS213 etc.

     

    and:

     

    Quote

    Hello,

    there is  only one version of firmware for FGS223.
    There is just nothing to do in this case.

     

    Which means I am now SOL. I'll be selling these devices on ebay to try to recoup some of my losses. 

    Share this post


    Link to post
    Share on other sites
    • 0

    Same here, switches are slow and sometimes not responding even to mechanical input:

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×