Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Which ports required for home.fibaro.com


Question

Hello,

 

Which ports are required for remote access via home.fibaro.com and/or master/slave configuration?

I've forwarded port 80, but this is apparently not enough.

 

With kind regards,

 

René van Meulenbroek

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hi @ReMi ProduXions,

 

To put it simply, the public IP and public port 80 of master Home Center must be publicly accessed and forwarded to port 80. So when you put those details in a slave device without port, it will automatically forward to the right port in the master device.

Link to post
Share on other sites
  • 0
  • Inquirer
  • I don't think I understand.

    I need to put the ip-adress of the slave device into the master device, am I correct?

    The situation is this:

    1:

    I already have 2 slave HCL's in the HC2. These devices are accessable through an internet connection and I've altered the modem/router via DMZ.

    I want to access another HCL through my HC2, this one is also on another site/location. The only problem is that I cannot change the modem/router to DMZ so I need the exact ports needed for the master/s;lave settings.

    2:

    Another client has a massive securitysystem installed and needs the exact ports required for accessing the HC2 via home.fibaro.com.

     

    With kind regards,

    Link to post
    Share on other sites
    • 0
    1 hour ago, ReMi ProduXions said:

    Which ports are required for remote access via home.fibaro.com and/or master/slave configuration?

     

    The HC only "calls out". It establishes an outgoing connection, to Fibaro server(s). When you connect to home.fibaro.com, it uses this established connection to tunnel from your device to the HC (sometimes called a reverse proxy setup). So no incoming ports are needed (and not wanted either!) on your firewall, but the HCs should have access to some public IPs. If you do not like this arrangement, the best alternative know to me is VPN, site- to site and/or between your client and your LAN. But this disables access via home.fibaro.com. It is considered somewhat bad practice to enable http to a public address (incoming port map to your HC),  "forum search" will turn up some posts regarding safety and also some ports and addresses if you want more details. I cannot tell you if a master/slave setup can work over VPN , without  rules that also allow the HCs to connect to the aforementioned public servers.  I do not have  such a setup and I do not know the answer.

    Link to post
    Share on other sites
    • 0
    On 10/25/2017 at 4:43 PM, petergebruers said:

    The HC only "calls out". It establishes an outgoing connection, to Fibaro server(s). When you connect to home.fibaro.com, it uses this established connection to tunnel from your device to the HC (sometimes called a reverse proxy setup)

     

    Hello,

    Could you please help me out with some info?

    I have a problem with my HC2 and can not connect to it via remote access. In home.fibaro, the HC2 is 'not available'. I tried various network settings but with no success. I checked port 22 and it is open (i did a 22 to 22 port forwarding rule). Is there a difference between an open 22 port and an outgoing 22 port? I mean, could the port be open but the HC2 call out be refused? Or could it be from the router DNS settings (I have a yes/no 'Connect to DNS server automatically' option)? Any thoughts?

     

    Thank you!

     

    Link to post
    Share on other sites
    • 0
    6 hours ago, mihai7785 said:

     

    Hello,

    Could you please help me out with some info?

    I have a problem with my HC2 and can not connect to it via remote access. In home.fibaro, the HC2 is 'not available'. I tried various network settings but with no success. I checked port 22 and it is open (i did a 22 to 22 port forwarding rule). Is there a difference between an open 22 port and an outgoing 22 port? I mean, could the port be open but the HC2 call out be refused? Or could it be from the router DNS settings (I have a yes/no 'Connect to DNS server automatically' option)? Any thoughts?

     

    Thank you!

     

    I have a DSL connection and a DNS was my only option to get access outside my local network and I'm able without any issues gain access to my HC2 and other home automation system. You might look into a paid DNS server. It's relatively cheap for a yearly subscription. 

    Link to post
    Share on other sites
    • 0
    On 1/27/2018 at 4:35 PM, matt1981 said:

    I have a DSL connection and a DNS was my only option to get access outside my local network and I'm able without any issues gain access to my HC2 and other home automation system. You might look into a paid DNS server. It's relatively cheap for a yearly subscription. 

    Thanks, I did just that as I found no other solution. A bit disappointed by Fibaro support... and by the system itself... 

    Link to post
    Share on other sites
    • 0

    I've been searching for a solution and have gained access now so thought I'd post the solution for others in a similar boat.  I only have a single home centre though.

    For me, it was a case up port 22 out to the internet to DNS name lb-1.eu.ra.fibaro.com - this resolves to 195.88.50.103 and 195.88.50.104 for me.

     

    On 1/27/2018 at 7:03 PM, mihai7785 said:

    I checked port 22 and it is open (i did a 22 to 22 port forwarding rule)

     fwiw, my source ports are 46906 and 47198, but I suspect they're somewhat random.  I made my firewall source port 1:65000 - it's an outbound port and i'm limiting it to the DNS name anyway.

    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...