Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
  • 0
Sign in to follow this  
Sirhideo

VD pressButton confused

Question

Hello,  I have the following VD to control Sony HT-Z9F soundbar, each individual button is working fine if pressed manually.

 

Please login or register to see this image.

/monthly_2019_03/Z9F-VD.jpg.00d055a4f7273d3750b0032f5a34070d.jpg" alt="Z9F-VD.jpg.00d055a4f7273d3750b0032f5a34070d.jpg" />

 

Buttons.jpg.1e6de336f172ca754e43c7b1baa01fb1.jpg

 

I would like to press HDMI1 or maybe 2 in a scene.  It looks like fibaro:call(vdID, "pressButton", 2) is not doing thing correctly.  Is it because it is a 2 buttons per line?  If so, what is the lua code to press HDMI1 or HDMI2 correctly?  Thanks!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @Sirhideo,

 

Try following format:

Please login or register to see this code.

 

In your case:

Please login or register to see this code.

 

Best regards,

Jakub

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, Sirhideo said:

Oh, didn't know button id can be used, thank you very much!

One tip. In LUA programming in HC2 it's about IDs, not names.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×