Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 2

Problem push notification with android 9 PIE


ciappi
 Share

Question

I have a galaxy note 9 with android 9 PIE

do you know why push notifications don't arrive in real time but only when I turn on the smartphone screen?
I deactivated the various battery energy savings
if I leave the smartphone with the screen off for at least 4 minutes, afterwards I don't receive any push notifications until I turn on the screen, and after I receive all the notifications I don't arrive before

 

thanks

Link to comment
Share on other sites

18 answers to this question

Recommended Posts

  • 0

This issue has nothing to do with the new update. Push notifications on Android Pie didn't work properly before the update and still do not work correctly after the last Fibaro app update. If the phone is closed they always arrive late. Battery management for Fibaro app is disabled.

 

A solution would be great :) 

  • Like 1
Link to comment
Share on other sites

  • 0
  • Inquirer
  • I'm worried, because those with Android can't receive notices in real time.
    please find a solution,
    communication for developers !!!

    a question, who has Iphone I don't think he has the same problem
    correct?
    Thank you

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • luckily I didn't use fibaro as a burglar alarm.
    otherwise the thieves had time to rob my house without being disturbed.

    • Like 1
    Link to comment
    Share on other sites

    • 0

    Interesting. To me it works everytime flawlessly, but it could be isue of Android and not Fibaro. Guys can you turn off battery optimized apps, if you using some, to check if problem is still there?

     

    Please login or register to see this link.

     

     

    Link to comment
    Share on other sites

    • 0
    On 4/12/2019 at 11:18 AM, Momos said:

    Battery management for Fibaro app is disabled.

     

    Battery management is disabled for Fibaro app, so are any restrictions for data usage.  Still notifications arrive late.

    @jakub.jezek are you using Pie ?

     

     

    Link to comment
    Share on other sites

    • 0

    ok so i was set of getting this resolved.  Turns out there is a problem in android Pie , at least on certain phones.  Disabling battery management and optimization through the menu doesn't disable Doze.  So notifications arrive late or when the phone is woken up. 

    I have disabled Doze using the adb command line and now notifications work again as they should.  The only downside is that after reboot Doze is enabled again.  Now how to keep Doze disabled for good :roll:

    Link to comment
    Share on other sites

    • 0

    install adb drivers, enable developer mode and usb debugging on phone, connect to pc, then run "adb shell dumpsys deviceidle disable" in a command prompt inside the adb directory

     

    • Thanks 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • i try your solution and it works

    great

     

    Edited by ciappi
    Link to comment
    Share on other sites

    • 0

    Now to find a way to make this survive a reboot ... without requiring root

    Link to comment
    Share on other sites

    • 0

    Hi!

     

    I have a Samsung Galaxy S7 with Android 8.0 Oreo and are experiensing the same thing. Push notifications uses a few minutes to arrive if my phone is sleeping.

     

    Maybe it has something to do with Samsung?

    Link to comment
    Share on other sites

    • 0

    I have the same problem with Yubii app version 1.12.0 and Samsung Galaxy S21 Ultra. I tried the adb command method and so far it works! thanks! 

    Edited by klumpo
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...