Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Restart calibration from Zero ?


Streetchat
 Share

Question

Hi all.

I am new to this forum and totaly newbie with those Fibaro FGR 223.

I just installed one on a roller blind last week to use it whit Homeassistant.

 

I use a toggle swith with three buttons (up stop and down)

 

Secure inclusion worked immediatly

I set the parameter 20 to 1 (Toggle switch)

i check the parameter 151 was on 1

up stop and down from the button works well too.

 

So i start a calibration by setting the parameter 150 to 2 and start.

The blind was opened at this moment (up), so the blind start to down, then up, then down.

Calibration Done.

 

But, in homeassistant, the blind is shown as open when it is close and close when it is open.

 

So i decided to restart the calibration by exluding the fgr223 first, then include it back.

 

This time, i down completly the blind and start a new calibartion (as stated in documentation, the blind is supposed to up, then down, then up).

But in fact, i hear two clic from the fgr223, then one clic and the blind up then one clic, then one clic and the blind down then one clic when it reached the bottom.

Then nothing, the calibartion seems to be done and again, appears as open in home assistant when in reality it is close and close when it is open.

 

So, my question is:

How can i start again a new calibration from the begining, to be correctly visible in homeassistant ?

I already tried to reset the fgr223 to factory before include it once more to the system (and now, i have 3 unused node...), but the calibration from the start (with blind closed) is doing exactly the same thing.

How can i completly delete this fgr223 from the zwave network to make disappear all old nodes ? (i.e: node 1 is the aeotec zstick, node 2 was never seen, node 3 is the first try with this module, node 4 the second try,....)

 

Many thanks by advance for any help.

 

Kind Regards.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Outputs Q1 is blinds up, and corresponding to switch input S1. Q2 is corresponding to S2 and means blinds down. When you swap outputs and you have a switch with arrows and it will acctivate blind in wrong direction, you have to swap s1 and s2 also. When you're done, make calibration againg, no parameters has to be changed.

 

I've missed in previously post that we talking abaut ver. 3 shutter. There you can swap inputs and outputs in settings, without hardware changing. Take a look on parameter 24 and 25.

Link to comment
Share on other sites

  • 0
3 hours ago, Streetchat said:

Hi all.

I am new to this forum and totaly newbie with those Fibaro FGR 223.

I just installed one on a roller blind last week to use it whit Homeassistant.

 

I use a toggle swith with three buttons (up stop and down)

 

Secure inclusion worked immediatly

I set the parameter 20 to 1 (Toggle switch)

i check the parameter 151 was on 1

up stop and down from the button works well too.

 

So i start a calibration by setting the parameter 150 to 2 and start.

The blind was opened at this moment (up), so the blind start to down, then up, then down.

Calibration Done.

 

But, in homeassistant, the blind is shown as open when it is close and close when it is open.

 

So i decided to restart the calibration by exluding the fgr223 first, then include it back.

 

This time, i down completly the blind and start a new calibartion (as stated in documentation, the blind is supposed to up, then down, then up).

But in fact, i hear two clic from the fgr223, then one clic and the blind up then one clic, then one clic and the blind down then one clic when it reached the bottom.

Then nothing, the calibartion seems to be done and again, appears as open in home assistant when in reality it is close and close when it is open.

 

So, my question is:

How can i start again a new calibration from the begining, to be correctly visible in homeassistant ?

I already tried to reset the fgr223 to factory before include it once more to the system (and now, i have 3 unused node...), but the calibration from the start (with blind closed) is doing exactly the same thing.

How can i completly delete this fgr223 from the zwave network to make disappear all old nodes ? (i.e: node 1 is the aeotec zstick, node 2 was never seen, node 3 is the first try with this module, node 4 the second try,....)

 

Many thanks by advance for any help.

 

Kind Regards.

 

You have to swap cables to the motor, Q1 and Q2, then will it go in the right direction.

Roller shutter doesn't know which way blind goes. When you make a calibration, it's just learning how long time it to full open/close, and afterwards you are able to set blinds in fx 50%

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • OK cool. 

    So if I swap the cable from Q1 and Q2, the wall switch will continue to work as desired, but home assistant will then know when the blind is up or down? 

    Is there a parameter to set after swapping cables? 

    I will read again documentation because to my mind, swapping Q1 and Q2 reverted the way the switch control the motor. I.e push up and the blind will down.. 

    I surely misread something here. 

    Many thanks for your answer. 

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • On 6/26/2019 at 6:45 PM, jires said:

    Outputs Q1 is blinds up, and corresponding to switch input S1. Q2 is corresponding to S2 and means blinds down. When you swap outputs and you have a switch with arrows and it will acctivate blind in wrong direction, you have to swap s1 and s2 also. When you're done, make calibration againg, no parameters has to be changed.

     

    I've missed in previously post that we talking abaut ver. 3 shutter. There you can swap inputs and outputs in settings, without hardware changing. Take a look on parameter 24 and 25.

    Hi,

     

    Many thanks for your help.

     

    this is working well now.

    After swapping S1/S2 and Q1/Q2, i started a new calibration and this time, the blind up, down and up well.

     

    Now, Homeassistant is reporting the correct up or down position.

     

    the refresh is not immediate (i.e: i need to wait some seconds on HA to see that the blind is down), but this is not a real problem.

     

     

    Link to comment
    Share on other sites

    • 0

    Roller shutter not reporting blind  position when it is "on the way". It wait until blind stops, and then sending value report to controller, therefore it's looks like delay, but it is normal.

     

    BTW. If my post was useful, you can give me a thanks on forum (just hover mouse over a heart icon in lower right corner of useful post and thanks button will show up). It will help other users to find an answer for similar to yours issues.... :)  

    • Thanks 1
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...