Jump to content
  • 0

HC2 - connectivity issues


Question

Hi,

 

I got my first Fibaro system installed mid December 2019 (only lightning and wall plugs first) and a HC2 by a dealer. I almost right away went on vacation and controlled the system through the app. It went smooth and I even used my laptop to build some very basic scenes remotely from my cabin. When I got back beginning of January I got an issue with not being able to connect through the app. It then turned out I had to reboot the HC2 by turning off and on the power through the unit's own power button. I thought that maybe I should updated to v4.57 and it will be more stable but no, it only increased in frequency. Hence I re-installed v4.56 but it hasn't help, that version is working as poorly now. 

 

After re-booting the HC2 it works fine, sometimes for a couple of days, other times only for a couple of hours before I can't reach it again. Looking at the HC2 unit front panel buttons the three right hand side ones are always lit and when I log into my router the HC2 is always there and with access to Internet. Sometimes I can reach the unit through the Fibaro Finder but I still have to do a re-boot to get back access through the Fibaro app. I have heard about issues using dynamic IPs so I switched the setting of the Fibaro to static and assigned a specific IP (192.168.1.14) to the HC2 but after approx 30 hours it lost connection again. Now I have returned to my previous settings in both HC2 and Orbi router. 

 

I can add to the above that when I tested the Static IP mode in the HC2 and it lost connection the "Connection timeout" sign came right away when I tried to connect through my phone. When I have it in DHCP it always takes like 10-20 seconds of "thinking" before it tells me "connection timeout". 

 

Any suggestions or ideas on what to change to get this working with reasonably stability? I would guess it has something to do with IP-settings but I'm really not an expert within this field... It is a bit sad after spending close to 3k EUR on hardware and installation and have this experience - all ideas are welcome!

 

Some facts:

Fibaro HC2 running on v4.56

Router: Netgear Orbi RBR50 with one satellite, running on latest software v2.3.5.30

iPhone 8, iOS 13.3

Fibaro app v1.5.0

 

Current HC2 settings - this is where I tried to change from DHCP to static when I assigned a specific IP for the HC2 in the router. 

Weather.thumb.png.ac9321edbaadbbbf6b36453cb28589be.png

 

 

Error message on app in iPhone:

806336348_Validitthus.thumb.png.74a487a2b23259459b8b565b78b641e0.png

 

HC2 unit in Router's device list - device type in drop-down is set automatically by the router. 

47591447_RouterFirmwareVersion.thumb.png.0fdc850356a5df5abef15b1ceae48dcd.png

 

1003571667_FibarGroupsp_zo.0.thumb.png.6b28e28931dc8d1ad6d1a864326324f7.png

 

 

Basic settings of router

966151413_BetterWiFi.Everywhere.png.3accf490eebce719fa56d740f51cdcad.png

 

This is the designated IP I tried to use (then check circular check box on the left was marked but I have now deleted it completely). 

1596203369_RouterFirmwareVersion.thumb.png.48991bc78c936ca1c555f75446ff02b2.png

 

Thanks! 

/Hans

Router Firmware Version.png

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 1

Unfortunately the new mobile app. does that.... to HC2. It's not the controller issue.

Since new app is still under "heavy" development phases I suggest to use the old fibaro app.

Currently new app doesn't have any advantages over old app ( I'd say vise versa)  and old app is stable and doesn't "freeze" your controller, so use it.

Link to post
Share on other sites
  • 0

Realized while browsing through the Orbi router settings that I didn’t change it to static from DHCP earlier so I decided to once again assign a specific IP address for the HC2. But with the difference of keeping the HC2 in DHCP mode, it works after an initial re-boot to get everything in place. Let’s see how long it holds. 

Link to post
Share on other sites
  • 0

It held until today (Tuesday evening) before I got into the same problem. I started then to change the router from DHCP to static and so also the HC2 but I ran into connectivity issues with other devices and didn't have the patience to sort that out. I have sent my question to the support now with a link to here for full problem description. Will be interesting to see what they propose as solution. 

Link to post
Share on other sites
  • 0

Since I have a heatpump which is connected through an old wireless Netgear wifi extender (with cable) I decided to test with connecting the HC2 directly to that unit. And it has worked very smooth ever since (almost two weeks). The only exception was when I had to reboot the Router due to an issue with another unit in my network (when your TV is lagging while your wife is watching it has high priority to fix quickly!). 

 

Meanwhile Fibaro support has come with the below solution after reading this thread. I haven’t tried it yet but struggle to believe it will work since the above fix seems to work.  

 

Hi,

First of all I am sorry for such late answear.

I’ve read your posts on forum and I think we can handle it.

It shouldn’t make a difference either you use DHCP or static IP.

Please make sure that you can log into your Home Center and you have remote access turned on (configuration → LAN Settings → Remote Access? Yes. → change it to no, save and change it to yes, save.)

After that please go to Configuration → Access Control → slide to the very bottom of the site and remove your iPhone from mobile devices list.

That should help you. If not – please contact us again.

 

 

Link to post
Share on other sites
  • 0

Thanks for input, let's see if I will try your way and scrapping the newest app in the end. After a new drop-out I'm now trying the solution provided by Fibaro support *fingers crossed*. 

Link to post
Share on other sites
  • 0

It took like a week after I did what Fibaro's help desk recommended until the HC2 stopped working and I had to reboot. After that I did as you, cag014, proposed and deleted the latest app and only use the old. Works like a charm, no issues at all after a little more than two weeks of use. 

 

Thanks! 

Link to post
Share on other sites
  • 0

Excellent. Glad to hear that you don't have problems anymore on that

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...