Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Disable default behaviour on Double Switch 2 when double clicking


Scott
 Share

Question

Hi All,

I've just had added a Double Switch 2 to a light (only using S1) and I've set Param 20 to Momentary and checked all of the Param 28 boxes. So now if I double/triple/hold click I can do different things with CentralSceneEvents via lua and that is working fine :D  

However only when I single click do I want the light to toggle on/off. I don't want this behaviour of the light toggling when I double/triple/hold click. Is there another parameter I should be changing to achieve this?

Thanks,

Scott

 

Edited by Scott
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

@Scott I have the same requirement as you.  Lots of double switches where I use the triple-click function to activate a scene, but I don't want the triple-click to change the state of the connected light.  

 

Like @baskalex said, you can't prevent the light from changing state once BUT you can add a toggle command to the scene, to change the state of the light back again.

 

By doing this, you get your double-click or triple-click scene to work and your main connected light (let's say it was on) flicks off and back on again. Actually kind of nice as it acts as a confirmation that the triple-click scene ran successfully.

 

Edited by Greenhippo
Link to comment
Share on other sites

  • 0

Hi @Scott,
I apologize for my bad english, i use a translator :(
I also had the same problem and I solved it in this way. Instead of plugging the button on S1, I plugged it into S2 and left everything else unchanged. In this way the direct command is not activated and therefore the following parameters are set
- parameter 20 switch type (set 0 momentary switch)
- parameter 29 S2 switch - scenes sent (Key pressed 1 time - Key pressed 2 time - Key pressed 3 time)
At this point I set up the scenes for button # 2 1x, 2x and 3x and everything works perfectly, without the annoying flash of the light connected directly to the button, even when you want to get a different result.
I hope I was helpful.
Hello

Please login or register to see this attachment.

Edited by tommasoalfonso
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...