Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0
SOO

HC3 Dimmer 2 S2 input

Question

Hello, 

 

I have a HC3 (sw 5.040.37). I try to use the S2 input on a fibaro dimmer 2. I connected a dimmeble lamp to the dimmer and it works whit the S1 switch. I connected S2 to another switchbutton. (I used Homey befor this and also used S2 to toggle Fibaro wall plugs. It worked great. Just had a flow when button S2 is puched turn on/off lichts and used also the same wallplugs as i have now). 

I try to make it work on HC3 but no luck yet. 

 

The light on S1 works, both switches are pulse. I turned on scene activation (parameter 28) and maked a block scene. Look at the picture. But is doesnt work.

 

Why dont i have the same functions as a dubble switch, see attatchment Fibaro scene2.JPG. Like when i push S2 turn wall plug .... on / off.

 

 

Please login or register to see this attachment.

Please login or register to see this attachment.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Just tried this and it works for me with momentary switch.

 

Please login or register to see this image.

/monthly_2020_08/HC3.png.8b757dbbdc58eb8368df2e0079823bba.png" />

Share this post


Link to post
Share on other sites
  • 0

Hi!

I have the same problem with Fibaro Dimmer 2 and momentary switch.

When S2 is pressed, it just activate the slave i.e. 134.2 (on 99%) or (off 0%).

 

Does not seem to send the Scene Activation code..

 

Any suggestion on what could be wrong? 

I have tested multiple Fibaro Dimmer 2, S2, same result.

 

In my mind this log should show me the scene activation code for the number og times S2 is pressed.. Not turn the slave on/off.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites
  • 0

Yes. I have set parameter 28 to 1. And i have pressed the switch 1, 2 and 3 times.

 

I had this working fine on my HC2, i use scene activation on 6 different Dimmer 2, so i feel confident that the setup is correct. But still, does not work.

On HC2 you can see on the remote-icon the scene activation ID when pressing the switch, but here on HC3 nothing.

 

Can it be assosiations there is something wrong with in HC3? (i have default setup on assosiations)

Because for me it looks like S2 is turning on/off a "slave", a slave that is within the same Dimmer 2 - see picture attached on previous post.

Share this post


Link to post
Share on other sites
  • 0

hi

what you need to do with scene activation is to use the ID of the remote icon that is generated and not the switch icon ID like in HC2.

eg

{
  conditions = { {
      id = 77,
      isTrigger = true,
      operator = "==",
      property = "sceneActivationEvent",
      type = "device",
      value = 15
    } },
  operator = "all"
}
 
my light switch ID = 78
my remote icon ID = 77
 
choose ID of remote
Edited by morpheus75
formatting

Share this post


Link to post
Share on other sites
  • 0

Whats strange is that i think i do everything correct, its just that the S2 of the dimmer sends the wrong message when S2 is activated.

I dont use LUA for the sceens im trying to fix here, only block-scenes.

Anyway, in the log i can se what happens when S2 is activated once/twice/trice

 

I put in here screenshots of my settings, maybe its obvious whats wrong?

 

Please login or register to see this attachment.

Please login or register to see this attachment.

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites
  • 0

convert the scenes to LUA and post back on here

also what events do you see when switch pressed 1/2/3 times

Share this post


Link to post
Share on other sites
  • 0

 

Here whats happening when activating S2: (two at the top=1 time, two at the bottom=2 times, nothing happens when pressing 3 times)

Please login or register to see this attachment.

 

Here is the scene converted to LUA: 

Please login or register to see this attachment.

 

Thank you for taking the time to help me out with this! Very much appreciated!

Share this post


Link to post
Share on other sites
  • 0

im assuming you change the 'value' number for 1 click and 2 clicks

also what type of switches are you using.

 

when i did mine i used the following:

{
    conditions = { {
          id = 56,
        isTrigger = true,
        operator = "==",
        property = "sceneActivationEvent",
        type = "device",
        value = 24
      }  },
   operator = "any"
  }
 
       
{
    conditions = { {
           id = 56,
        isTrigger = true,
        operator = "==",
        property = "sceneActivationEvent",
        type = "device",
        value = 25
      } },
    operator = "any"
  }
 
the remote ID is 56 - the scene activation values are
24 - 2 clicks
25 - 3 clicks
my switch parameter 20 setting is momentary switches hence i use codes 24/25 and triple does work.
ID 26 in your example is single click code.
 
 
also your LUA is showing ID 26, whereas your block is showing ID 24...
which indicates 24 is 2 click and and 26 is 1 click.
use code 25 for triple click 

Share this post


Link to post
Share on other sites
  • 0

 

I have the user-manual open when choosing 26(1), 24(2), 25(3). My switch-type is momentary switch.

 

The issue here is that S2 is not sending 26/24/25 code/command... So HC3 is receiving the wrong code/command. Also 3 times is not sending anything at all.

Its a mystery... have contacted FIbaro support also, but seems like they have long response-time. 

Share this post


Link to post
Share on other sites
  • 0
20 minutes ago, NORFRED said:

 

I have the user-manual open when choosing 26(1), 24(2), 25(3). My switch-type is momentary switch.

 

The issue here is that S2 is not sending 26/24/25 code/command... So HC3 is receiving the wrong code/command. Also 3 times is not sending anything at all.

Its a mystery... have contacted FIbaro support also, but seems like they have long response-time. 

that is a mystery, only other suggestion i can make is to do a soft reconfiguration on the device. and try again.

i have found a few dimmer 2 modules are not saving their parameters correctly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...