Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 1

Heatit Z-TRM3 shows incorrect temperature


Question

Hi,

 

I have an HC2 4.600 and just added a Heatit Z-TRM3 thermostat.

The thermostat itself operates properly: shows setpoint and room temperature on its display and activates heater depending on setpoint.

It also correctly reports energy consumption to the HC2.

The heating panel in HC2 is also able to properly update the setpoint according to a schedule.

 

But the Z-TRM reports a constant temperature regardless of the actual temperature in the room.

None of the temperature sensors (internal and floor temp) ever change their values in HC2, even though
the thermostat is operating and I can see how the heater is turned on/off in HC2 power consumption panel.

 

Does anyone have a clue as to what my problem is?

 

Images below show the devices and the power/temp reports.

Please login or register to see this image.

/monthly_2020_10/devices.jpg.381cab2782a3135f4dc956db61816578.jpg" />

(Device 198.3 is hidden since it is an external sensor that I'm not using.)

 

power.jpg.b94a4c86498667edcf88b128b4d28a30.jpg

 

 

temp.jpg.31ea24d4163591e54821cbb7d6bcdbbb.jpg

During this period, actual room temperature varied between 20 and 25 degrees C.

 

Edited by sanojn
Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

first of all set the association to multichannel only (unselect single, save refresh page, set multichannel again, save refresh).

Then set the group 3,4 and 5 association to your HC2

Link to post
Share on other sites
  • 0

Hi. 
I’m looking to replace the bathroom termostats. Do you recomend the Heatit z-trm3 with the fibaro home Center 2?

Has there been any issues?

 

Link to post
Share on other sites
  • 0
On 10/22/2020 at 6:33 PM, sanojn said:

Worked like a charm!

Thank you!

 

Jonas

I have the same problem and can't seem to solve the problem.

Does the temperature reporting works for you?

Can you please share a screenshot at your associations?

 

Link to post
Share on other sites
  • 0

hi tinman,

i also got a heatit Z-TRM3.

you wrote "first of all set the association to multichannel only (unselect single, (also group 1 and 2?) save refresh page, set multichannel again, save refresh). Then set the group 3,4 and 5 association to your HC2"

do you mean multichannel in every single one? or only where i can control the temperature? 

i am running a scene the temperature is going up for two hours. from 21 to 23. that works. after two hours its going down, also works. from 23 to 21. but the temperature at the controller stays at 23.  where is the problem.

thanks a lot for your help. i tried it for hours

 

 

 

Link to post
Share on other sites
  • 0

Hi,

I also just connected TRM3 with HC3 and it seems to work correctly manageing the temperature but all sensors showing 0 zero-voltage sensor, and all three temperature sensors ( i don't use external sensor) but anyway all of them showing zero. Did you manage to correct the issue?

Link to post
Share on other sites
  • 0

I have 3 Heatit Z-TRM3 termostats. FW4.

Everything is running on Fibaro HC3 update:  5.070.42

There are climate programmed per hour.

 

Issues: 

1. Sometimes one of the thermostats switches off (once a day - recently started to be more frequent)

2. Termostats are not following schedules, they might turn ON (increase temp) but not go OFF (decrease temperature) or vise-versa.

 

I have tried excluding/including and reseting HC3. Nothing helps.

 

Fibaro support is now looking into my issue, so I'll try to comment here if I'll have an update.

Just to point out that this issue (whatever it is) have costed me $100ds in electricity bills for few months, before It get noticed.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...