Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Adding RGBW2 to HC3L and changing its type


mioiox
 Share

Question

Hi all,

 

I am trying to figure out if I did anything wrong when adding RGBW2 (with four single-coloured led strips) to HC3L (5.080). I followed the typical procedure and the module was added and configured successfully, as per the messages. However, now I see 5 multilevel switches that I cannot change the dimming levels of (even turning them on and off does not work quite well through browser nor iOS app). Furthermore, I recall that when I add the RDBW2 module in HC2 I was getting a pop up to select its type. In HC3L I don't get such a pop up or an option to change the type and I am not sure that the Multilevel Switch type is the one I need for LED strips.

I tried removing+adding, as well as soft reconfiguration, but nothing changes for the better.

 

Thanks in advance for your input! 

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hi,

 

Make all devices visible in the device window. Then the 'mother' RGBW-module will become visible.

On my (not yet updated) HC3 it shows like:

 

Please login or register to see this image.

/monthly_2021_07/afbeelding.png.10fc4b5b9476dbeeb9ad535487939e1c.png" />

 

This is the device were you change the role of the RGBW 2 device.

 

Hope this helps!

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Thanks for your input @deSmartHomeChef. Unfortunately, things are not exactly the same on my side. I assume I miss something. When you add your RGBW2 device at the beginning, does it look like this:

     

    Please login or register to see this attachment.

     

    When I start expanding the devices one by one (starting from the top), for the parent I cannot change the role: 

    Please login or register to see this attachment.

     

    The Color Controller looks somewhat in the right direction (I still cannot change its role; it was a hidden device):

    Please login or register to see this attachment.

     

    However the On/Off button does nothing, the brightness slider - nothing as well; so the only way to turn the strips off is by sliding the respective color slider all the way to the left - and I need to open the card on the right, which is somewhat inconvenient, compared to HC2's interface:

    Please login or register to see this attachment.

     

    For the other devices below - for some reason there are six (6) multilevel switches and not 4 - I can change the role, but RGBW option is not there:

    Please login or register to see this attachment.

     

    All that being said, I still believe that:

    A) I did something wrong

    or

    B) There should have been an automatic step during inclusion that is not happening for me.

     

    I would still appreciate any assistance :)

     

    Thanks and regards!

    Link to comment
    Share on other sites

    • 0

    everything "looks ok" ... you switched to latest z-wave engine (z-wave 3.0), and the device looks now different than on z-wave engine 2.0 on HC3 or HC2.

     

    Link to comment
    Share on other sites

    • 0

    hehe i see, there is no parameter 14, which is responsible on RGBW1 (the pictures you posted, i see firmware 25.25, so it is rgbw1 not rgbw2) to set the working mode:

     

    Please login or register to see this link.

     

    Please login or register to see this image.

    /monthly_2021_07/image.png.66df8fd5578a1ead1478c62ea350fdb7.png" />

     

    no problem, you can upload own parameter template (attached) in order to get parameter 14 available

     

    image.png.95b165ea75e2322b7e55cb072ca80a3b.png

     

    Then based on the link above, calculate the value and enter it for the parameter 14. Thats' all, the RGBW1 will then use the mode you selected.

     

    From app you might control the xx.0 endpoint (you have to unhide it first), as normal RGBW, or you can control the single channels (the other endpoints) as dimmer.

     

    image.png.4c58e8c33bd84b8ba6077a2f46209577.png

     

    It make sense to hide the other channels, when you use RGBW controller, and versa, hide the color controller and unhide channels, when you use as input/output mode.

     

    Please login or register to see this attachment.

     

    The param template is attached, simply upload it to your HC3L

     

    image.png.4c287c7a9fd9896fc273e405cf8c5db1.png

     

     

     

     

    @m.roszak  👀

    Edited by tinman
    • Like 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thanks @tinman! I will try this tonight and will get back to you. Indeed there is no parameter 14, but I based on the Fibaro manual, I decided this is so because it is usable on only non-HC devices.

    Indeed, I am now on Z-Wave 3.0, that might be the reason for the difference in naming/roles.

     

    I will try with the template attached and will get back to you (and the forum). Thank you again!

    Link to comment
    Share on other sites

    • 0

    on Zwave 3.0 old RGBW is not fully supported right now.
    We have this one in backlog.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @tinman, I took me longer than anticipated. Even worse, it did not work out with the template - it was uploaded ok, however nothing changed from configuration or usage point of view. As @m.roszak said, obviously it's not supported and not working entirely as expected.

     

    And something else in this regards - RGBW is shown in the interface with security level of None (not S0). Consecutively, trying to associate a Dimmer 2 switch as a master switch for even a single RGBW channel proves to be impossible - the HC3L interface displays an error message Error message: Security class mismatch between source and destination., although I have explicitly cleared the "Equal security level devices" in the association page. So, several questions arise:

    1. What's the point of marking that you want to show devices with security mismatch, if you cannot associate them later? Is there a working use case for that?
    2. What does "security level: None" mean and how does it differ from S0?
    3. Is there a timeline for fully supporting Fibaro's own RGBW module?

    Thanks and regards!

    Link to comment
    Share on other sites

    • 0

    Ad1.
    We are showing them for transparency, to avoid questions "where is my device and why I cannot associate it".
    Just and only that. As you have seen those are hidden by default.
    The behavior related to Dimmer 2 and disabling security encapsulation when controlling other nodes using associations - we have done it in the device before Z-Wave Alliance decided that this should not be possible - so in theory we should not allow that.
    Newer Dimmers (like Walli Dimmer) does not allow this anymore.  
    Ad2.
    None means no security encapsulation during communication, S0 means Securty S0 command class used for encryption.
    Ad3.
    New RGBW is already supporetd, old one (not produced for some time) is the backlog - I will try push it up :)
     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @m.roszak, thanks for the quick responses! I do appreciate it.

    Regarding Q3, that would be great - since I bought them brand new a couple of weeks ago, obviously there is some old stock somewhere (and I didn't check they were the 441 version, my bad). It seems they will stay for a while, I guess not only as part of my installations.

     

    Thanks and regards

    Link to comment
    Share on other sites

    • 0
    On 8/2/2021 at 11:12 AM, m.roszak said:

    on Zwave 3.0 old RGBW is not fully supported right now.
    We have this one in backlog.

    As you have updated, I have HC3 5.080.9+

    Thx

    Link to comment
    Share on other sites

    • 0

    Hi, find hiden child device(that is main when you control rgbw strip) and turn it ON, then you will able to control multilevel devices. 

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...