Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Smart Implant, Bug or incorrect configuration?


RH_Dreambox
 Share

Question

I will use a Smart Implant to read a level sensor (0-10 V) in my water well.
Smart Implant is configured to display the sensor values where 0 V = 0 cm and 10 V = 400 cm.


But as soon as the input signal changes, the configuration changes back from cm to V!


This means that the Dashboard shows an incorrect unit, volts instead of cm.

Did I miss something in the configuration or can Smart Implant not show the unit cm?

 

Please login or register to see this image.

/monthly_2021_08/701892231_Sensorsettings.png.0ee15808f9b217380603530b0a8ae01f.png" />

 

1803382405_Waterlevel0-400cm.png.a00600d4aee3513b8faff0943857d7c8.png

Configured unit

 

331792721_Waterlevel0-400V.png.572cbd013658ee985df49242f2654a5e.png

Wrong unit

Edited by RH_Dreambox
Spelling
Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hmm, that's strange - this issue was recently fixed for RGBW device.

I will check it out :)

Thanks for the report.

Link to comment
Share on other sites

  • 0

Ok, I know what is happening.

We have added a redundancy but missed other sensors with custom unit.
I am adding this to the backlog right away.

  • Thanks 2
Link to comment
Share on other sites

  • 0

Hello,
I have the same problem. I only use unit (m) and (bar for pressure).

I have noticed since SW version 5.080.9.

Link to comment
Share on other sites

  • 0

One more thing:
Is it an intention or a mistake?
In QA, 2 lines of text were displayed in the log.
Ex.
self: updateProperty ("log", "🔋 Batteries are> = 30% of capacity status.")
Up to version 5.071.52beta was displayed in the QA icon:
🔋 The batteries are> =
30% of capacity.


As of SW version 5.080.9, it is as follows:

Please login or register to see this image.

/monthly_2021_08/image.png.b6c2ace493f4f29645925fac18cd2a3a.png" />

 

Preview QA:

image.png.9fab302389b9a3ad9e845e1907f06e43.png

 

So now it looks like the text "log" is limited to only 20 characters.
Maybe I missed something with the arrival of new SW versions.

Link to comment
Share on other sites

  • 0

I think this is expected behavior (there were some issues with longer texts which will go over the tile).

Maybe for battery value use interface "battery" which adds property "batteryLevel" to API of your QA - then battery icon and its value will be visible in a native way (as with other devices which reports batteries like any Z-Wave battery operated device)?
Just update "batteryLevel" propery with values 0-100 (255 - critical).

Link to comment
Share on other sites

  • 0

m.roszak

Ok. Thanks for the quick reply.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • The latest version 5.080.20 still shows V and not cm as I have configured.
    Is this Bug forgotten or have Fibaro not had time to correct it?

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...