Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Disable Q1 reaction when S1 push


Frosch13
 Share

Question

Hi,

It is difficult to phrase this question, but I try it:

I want to trigger another item than connected on Q1 through pushing the S1, this triggers scene "Key pressed 1 time", this sends a command to item I want to switch.

The problem is: If I push the S1 - button the scene is triggered but the Q1 relay is also triggered.  How can I avoid to trigger the Q1 relay when pushing the S1. 

Many thanks for yours advice

Cheers 

 

Edited by Frosch13
wrong word
Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

In Advanced tab in Settings -> Devices there is a really big button to change it - on HC3. On HC2 it is similar.

If you are using different controller I won't be able to help you.
This functionality is handled by Command Class Protection in version 2 in those modules.

  • Like 1
Link to comment
Share on other sites

  • 0

I'm not sure which device you are using, but with some devices you can use S2 instead to achieve what you want. Eg for the double switch you set parameter 29 to allow scenes to be sent.

Link to comment
Share on other sites

  • 0
8 hours ago, Tim__ said:

I'm not sure which device you are using, but with some devices you can use S2 instead to achieve what you want. Eg for the double switch you set parameter 29 to allow scenes to be sent.

 

Single Switch 2, Dimmer 2, Smart Module, all have a S2 but not a second output. 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • 12 hours ago, pnutp0wer said:

    That is not possible, you can do that by using the s2 or smart implant 

    Thank you.

    On the Q1 is a Outdoor Plug connected.

    I want to use scenes from S1 to trigger other events in smart home. Especially with scene "Key Press one time" I wan't to switch a z-Wave bulb in my smart home. But "key press one time" also cause to trigger Q1, which has outdoor plug connected. My intention was to switch ON/OFF the Outdoor Plug with scene "double click S1". This means I have to disable the S1 reaction for Q1 and only scenes should triggered with S1. As you wrote, this is not possible.

     

    Your advice was good. I will disconnect Outdoor Plug from Q1, install the smart switch FIBARO FIBEFGS-213 into the Outdoor Plug and trigger this switch with a S1 scene or with what ever I want.

    Link to comment
    Share on other sites

    • 0

    It should be possible by enabling "Local Protection" in the device, this will cause that both S1 and S2 buttons won't affect outputs but scenes triggers will be send.
    This depends on the version the Switch you have, older one may not be able to do so.

    Of course controlling outputs using radio will still be possible.

    • Like 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 7 minutes ago, m.roszak said:

    It should be possible by enabling "Local Protection" in the device, this will cause that both S1 and S2 buttons won't affect outputs but scenes triggers will be send.
    This depends on the version the Switch you have, older one may not be able to do so.

    Of course controlling outputs using radio will still be possible.

    This would be great. I have an FIBARO Double Smart Module FGS-224. I only found this about "Local Protection" for FIBARO Roller Shutter :

    Quote

    Once the Local Protection is activated, the module stops
    responding to S1 and S2 push buttons. SCENE ID and association
    commands will not be sent as well. The only exception is the
    B-button. Menu and Z-Wave network inclusion, after the B-button
    or S1 push button triple click, are still active.

    Unfortunately "Local Protection" seams also to disable from sending any scene IDs. This would doesn't help me. But maybe this function would be a good feature request for FIBARO. 

    Link to comment
    Share on other sites

    • 0

    Ah, this behavior changed in time at least once - due the Z-Wave Specification and certification, I think that now it is now allowed to send anything from the modules when local protection is enabled.
    I am sure that some of our devices allows that. 

    • Like 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Great!

    7 minutes ago, m.roszak said:

    Ah, this behavior changed in time at least once - due the Z-Wave Specification and certification, I think that now it is now allowed to send anything from the modules when local protection is enabled.
    I am sure that some of our devices allows that. 

    Now I only have to discover how to enable "Local Protection" on FGS-224 or do you have an idea how to enable this mode? I didn't found any information about it.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 10 minutes ago, m.roszak said:

    In Advanced tab in Settings -> Devices there is a really big button to change it - on HC3. On HC2 it is similar.

    If you are using different controller I won't be able to help you.
    This functionality is handled by Command Class Protection in version 2 in those modules.

     

    I've integrated my FIBARO modules in OpenHab. I use no HC. 

    But I think I can enable it:

    see:

    Please login or register to see this link.

     

    Great advice from you. Many thanks!

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...