Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

AEOTEC ZW-095 single phase / HC3 / "not configured"


M.Bar
 Share

Question

Hello guys,

 

I already found 3 topics about this but answer was not clear and I'm still confused.

So :

I tried to fill parameter all as unsigned but still not configured.

I tried to add the device near to the HC3, same result

 

Any idea, I wish to access to the data from my phone (by the app).

 

Thanks for support guys,

 

Leny

Please login or register to see this attachment.

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

@M.Bar

I do not know which version of HEM you have, but you can try the settings that work for my HEM3 G2.

 

 

Please login or register to see this attachment.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • @RH_Dreambox, many thanks I will tri it, just for information I have the following configuration:

    HC3 5.091.41 and my energy meter is

     

     

    Please login or register to see this image.

    /monthly_2021_12/image.png.319ced555b080934675afe8b044ddd0b.png" />

    Link to comment
    Share on other sites

    • 0

    A small hint: after saving parameter values, try to force synchronization using a button on the device or from the HC3 UI

     

    or use below code (in Quick App)

     

    function QuickApp:configuration()
        deviceId = 334 
        
        self:changeParameter(deviceId, 111)
        self:changeParameter(deviceId, 21100)
        self:changeParameter(deviceId, 311)
        self:changeParameter(deviceId, 411)
        self:changeParameter(deviceId, 511)
        self:changeParameter(deviceId, 610)
        self:changeParameter(deviceId, 710)
        self:changeParameter(deviceId, 810)
        self:changeParameter(deviceId, 910)
        self:changeParameter(deviceId, 1010)
        self:changeParameter(deviceId, 11230)
        self:changeParameter(deviceId, 12230)
        self:changeParameter(deviceId, 132 ,30)
        self:changeParameter(deviceId, 1420)
    end
     
    function QuickApp:changeParameter(deviceid, set_parameter, set_size, set_value)
        local url = "/devices/"..deviceid    
        local data = {properties={parameters={{id=set_parameter,size=set_size,value=set_value}}}}     
        local responseData, status = api.put("/devices/"..deviceid,data)
        if status == 200 then
            self:debug("Parameter " .. set_parameter .. ": set correctly")
        else
            self:error("Parameter " .. set_parameter .. ": some error")
        end    
    end
     
    function QuickApp:onInit()
        self:configuration()
    end
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hello Guys,

     

    Many thanks for support.

     

    So I retried to add parameters one by one as described by RH_DreamBox... no change still not configured...

     

    So I retried to add all parameter as decribed in the HEM documentation... no change

     

    I wonder how this information is given to the interface... I mean is the device which send the information or it is an assumption of the interface?

     

    I will try with your code... but I will described my process...

     

    To add my device:

     

    Please login or register to see this image.

    /monthly_2021_12/image.png.6721562bbb2c0385d008582778a56ee4.png" />

     

    Then I wait all information from HC3

     

    Please login or register to see this attachment.

     

    Then I click on the first in this example (id:200), I add all parameters following the aeotec documentation considering all data as unsigned.

     

    Please login or register to see this attachment.

     

    Then I go back to ask for read configuration in the interface... no change.

     

    Do you see something wrong?

     

     

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Next step done...

     

    I implement the QuickApp as follow:

    function QuickApp:configuration()
        deviceId = 210 
        
        self:changeParameter(deviceId, 212)
        self:changeParameter(deviceId, 310)
        self:changeParameter(deviceId, 4250)
        self:changeParameter(deviceId, 5250)
        self:changeParameter(deviceId, 6250)
        self:changeParameter(deviceId, 811)
        self:changeParameter(deviceId, 911)
        self:changeParameter(deviceId, 1011)
        self:changeParameter(deviceId, 1310)
        self:changeParameter(deviceId, 1014592143)
        self:changeParameter(deviceId, 1024592143)
        self:changeParameter(deviceId, 1034592143)
        self:changeParameter(deviceId, 1114300)
        self:changeParameter(deviceId, 1124300)
        self:changeParameter(deviceId, 1134300)
    end
     
    function QuickApp:changeParameter(deviceid, set_parameter, set_size, set_value)
        local url = "/devices/"..deviceid    
        local data = {properties={parameters={{id=set_parameter,size=set_size,value=set_value}}}}     
        local responseData, status = api.put("/devices/"..deviceid,data)
        if status == 200 then
            self:debug("Parameter " .. set_parameter .. ": set correctly")
        else
            self:error("Parameter " .. set_parameter .. ": some error")
        end    
    end
     
    function QuickApp:onInit()
        self:configuration()
    end
     
     
    On the console I have for each parameter [23.12.2021] [11:12:33] [DEBUG] [QUICKAPP255]: Parameter 113: set correctly
     
    Then I retried to click on read the configuration and I also repressed the rear button on the HEM... No change 😢
     
     
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I wish to add information...

     

    When I execute the script... some parameter are missing

    I re execute the script and I do not have same result in term of display of parameter .

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • the non repeatability comes from the distantce between the box and the device...

     

    So that's meaning all configuration of the device shall be done near to the box (less than 1 meter)

     

    But I still have the "not configured" message. I will looking for information from Aeotec regarding to the HEM gen5 module.

     

    If someone owns idea to fix it... (maybe felix...)

    Link to comment
    Share on other sites

    • 0

    I have 2 Aeotec ZW-095 HEM, one 3 phase and the other single phase. On both I get that "Not configured" warning/error...

     

    The 3 phase is on
    Version 1.2

     

    The single phase is on 

    Version 1.35

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @VascoFilipe, I sent a mail to AEOTEC to have support, I will do the same for Fibaro

     

    I also looking for documentation about Z wave protocol to understand how this information is built

    Edited by M.Bar
    Link to comment
    Share on other sites

    • 0

    @M.Bar

    If the unit is not properly included (not configured), it may help to do a factory reset of your HEM.
    Hold down the button for 20 seconds. The device starts flashing fast and then flashes slowly again.
    After reset, you can include it to HC3 again.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Good morning, and happy Christmas,

     

    @RH_Dreambox, I tried the HEM reset, but after a new reconfiguration of the HEM (around 10 parameters one by one) still not configured.

    I'm in contact with AEOTEC, they gave me a procedure but still not working....

    please find below the AEOTEC's anwser:

     

    "

    Try these steps to get the total report to report all the time, this setting only sets total and will set Clamp 1 to never report. We do this for 1 clamp because:

     

    Clamp 1 = Total for the 1 clamp version. So its unnecessary extra 4 reports so we only have it report the overall total. 

     

    1. Add the HEM in non-secure mode

    2. Open the settings (gear in the lower left corner)

    3. Select Devices

    4. Select Z-Wave

    5. Find your device and click on the device name

    6. Go to the Associations item

    7. Remove all associations by clicking on the trash can on the right side of the screen

    8. Add the HEM in non-secure mode 
      Source Endpoint: endpoint 0
      Group: Group 1
      T
      arget Device: controller (singlechannel).

    9. Confirm with +.

    10. Go to Parameters and set the following parameters

    11. Press Add parameter

    12. Enter parameter number 101

    13. Press the arrow on the right side

    14. Now select
      Set Value
      Select Type: insigned int
      Size: 4 byte
      Value: 15

    15. Press Save

    16. Add parameter 111 in the same way
      Select Type: insigned int
      Size: 4 byte
      Value: 60 ( 1 minute update time ) 

    17. Press Save

    "

     

    Link to comment
    Share on other sites

    • 0

    @M.Bar

    I'm a little confused with what you mean by "not configured".
    By "not configured" I mean the red text on my image (general tab).
    "not configured" then means that the device's inclusion in HC3 has failed.

     

    If, on the other hand, it says "Device configured", then your HEM is correctly included.
    By "not configured" you might mean that it does not display any information in the HC3 user interface?
    Then try changing parameter 101 (4 bytes) from recommended 15 to 2307 and see what happens.

     

     

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @RH_Dreambox,

     

    Please login or register to see this attachment.

     

    Your understanding is right, I mean that not configured as you highlight.

    But the HEM is visible on device, with correct value, but it is not visible on app (on the phone) due to "Not configured"

     

    In same way I tested  your value 2307... but still not configured so I can't access to the value outside from the home center inferface.

     

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0

    @M.Bar

    If "Configuration:" shows "Not configured" then you can not fix this error by manually configuring the device.
    With your manual configuration, you can only configure how the device should behave and how it should report to HC3.

    Your problem is caused by the device failing to properly include HC3.


    You can only fix this by including it again and try to fix what prevents proper inclusion.
    Do a factory reset and include it again near your HC3.
    Do not select "Network-Wide Inclusion" or "Security mode".


    Wait a few minutes and make sure that the device adds all the child's and does not report any error messages.

    If this does not work then the device may need to be updated, which you unfortunately can not do via your HC3 "Game changer".

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hello Guys,

     

    Finnaly I create QuickApp to retrieve information from the AEOTEC, because still not configured even if I had help from AEOTEC...

     

    @RH_Dreambox, "If this does not work then the device may need to be updated, which you unfortunately can not do via your HC3 "Game changer".", hum we can update/upgrade such devices, I wll check this way, but it is quite strange that AOETEC doesn't suggest to do it.

     

     

    Link to comment
    Share on other sites

    • 0
    13 hours ago, M.Bar said:

    "If this does not work then the device may need to be updated, which you unfortunately can not do via your HC3 "Game changer".", hum we can update/upgrade such devices, I wll check this way, but it is quite strange that AOETEC doesn't suggest to do it.

    @M.Bar

    It could be as simple as there is no update available and then a factory reset is the only thing you can do.
    And if there is an update, you will need to use an Aeon Z-Wawe stick for that purpose.

    Please login or register to see this link.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...