Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

All my QA devices show as "lamp" in Google Home


_Wilco_
 Share

Question

Hello,

 

Coming from Homey, I mostly work with virtual devices to control my home using Google Home. With Homey, the virtual devices can be of different types. And when I set the virtual device in Homey to "outlet" i can set in Google Home what type of device is connected (switch, heater, tv lamp, etc.) which makes it easier to control by voice. 

With Fibaro (HC3) al my virtual devices (QA's) show as lamp in Google Home, despite the "role" and "category" I set.

 

Are there any solutions to overcome this issue? Can there be set other devices for use in Google Home?

 

 

Thanks,

 

Wilco

Link to comment
Share on other sites

Recommended Posts

  • 0

This problem happened for us only with Plugs. And even Plugs got altered in Google to plugs after some time. I dont know the reason, but i can confirm that after some time,appr  4-5 days i think,all the plugs are represented in Google as plugs. As far as it concerns QAs, there is one thing to be metnioned. The major decisive factor is the device type itself. When you create a QA, select the device type you want Google to use. 

Please login or register to see this image.

/monthly_2022_04/QA-GOOGLE.png.1446056b884acd78e5b508e712b284b2.png" />

If it doesn't work either, there is very little you can do about it. It is still a magic for me, how is the syncing process done between Google and Fibaro, but my experoences say, that try to wait a few days, while keep using the device.

For me, in case of plugs it worked all the time.  In case of other devices, if I had choosen the correct device type in Fibaro, ex Door lock, the device would show up in Google as Lock. See the picture below, and check my Main door.

Please login or register to see this attachment.

 

 

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • @Neo Andersson Thanks for your reply,

    I will wait a couple of days and see wat happens.

    What do you mean with "plugs"? I cannot select "plug" as "QA Device Type". And what "QA Device Type" did you choose for the "Garage", "Garage 2", etc.? I used the "Binary Switch". I also tried "Remote Controller", but these don't even shop up in Google Home.

    How come a cheaper product like Homey can do this right and Fibaro can't ?

    Link to comment
    Share on other sites

    • 0

    As my Garage is controlled by Fibaro Implant, i have created a Quickapp to controll my garage.

    The quickapp itself is a binary switch, what is in reality. I switch on - the garage openes, I switch off - the garage closes..

    It must show up in Google, if you have choosen Binary Switch..100%

    You must have missed something.

    1. Check what account is linked to Google. Is it the same as your admin Fibaro account?

    If not, did you give all the permissions to the other account?

    2. After creaeting a Quickapp or adding a new device, did you sync your accounts?

    3. If your Fibaro account has the acces rights to that binary switch, and you have synced the two accounts, there is no way, that it doesn't show up in Google.

    4. For the Plugs i have choosen Other devic

     

    Please login or register to see this image.

    /monthly_2022_04/googleplug.png.e86aeb8f1f09b907915596ad01434ea1.png" />e.

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0

    And after you double checked all the permissions, and devices in Fibaro, and you pressed the Synchronise button on Fibaro access TAB, also don't forget to say "Hey Google, sync my devices", and wait until the sync is finished.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @Neo Andersson Tanks for the extend reply.

    I understand the way of "syncing" between the HC3 and Google Home (it's the same as with the Homey and other systems), and the "Binary Switches" show up in Google Home and also work (only still showing as "Lamp"). But for example the  QA with "Remote controller" as "Device Type" doesn't.

    It is a bit hard to experiment with the different device types if you have to wait 4~5 days to see the actual result in Google Home.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @Neo Andersson Do you know which setting defines the type in Google Home?

    The one on QA creation:

    Please login or register to see this image.

    /monthly_2022_04/image.png.d3de331fe58e31e28ffefe8eb172698f.png" />

     

    Or the "Role" and/or "Category" in the general settings of the QA:

    image.png.7336e6f73b5f68d32d57407e6ab6f7b9.png

    Link to comment
    Share on other sites

    • 0

    What i know, i know by my own experiences. Not a confirmed solution from Google support or so.

    The only thing I noticed, that if I wanted to avoid a switch to be represented as light, i had to set role and category to Other and choose Binary Switch as device type.

    I can not tell you which one defines the behaviour in Google, but from my experiences it seems to me, that it is the Device type.

    If you set role/category to Other, and choose the correct device type it will define it in Google. I have tested it with Switches, or with Thermostats.

    Unfortunatelly sometimes it not happens immediatelly. I dont't know why, but for me, many times it needed a few days, maybe more.

     

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I just added all the possible "Device Types" for a QA and synced:

     

    Please login or register to see this image.

    /monthly_2022_04/image.png.fdff5d669acd608383f077de488395e0.png" /> 

     

    I will wait for a couple of days and then add the results, if they change.

     

    The "Player" shows as a switch, but when switching using Google, the Fibaro console shows these actions are not implemented for this type.

    Please login or register to see this code.

     

    Can I add these actions myself? 

    Link to comment
    Share on other sites

    • 0

    Yes, you can extend your QA by any functionality..

    I hope, i understood you properly, and you asked me about this

     

    s.

    Please login or register to see this attachment.

     

    Edited by Neo Andersson
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Great, it works! I had added "QuickApp:on" and "QuickApp:off" (the "turnOn" and "turnOff" where not showing in intellisense).

    So I guess the "Player" QA is the best option for my situation.

     

    Thanks for your help!

    Link to comment
    Share on other sites

    • 0

    but you need to add to the function some functionality, or what else is it good for you?

    you need to code the turnOn functionality, not just define the function..

    or maybe i didnt uderstand your goal..

    what is it good for you to have Player device type, if it won't do anything until you create the functionality?

     

    On the other hand, i am pretty sure, it doesn't need to be a "player" type device..it can be switch too.

    Just need some time for Googel and Fibaro to sync

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 10 minutes ago, Neo Andersson said:

    but you need to add to the function some functionality, or what else is it good for you?

    you need to code the turnOn functionality, not just define the function..

    Yes, I know. ? That's step two. But I had to be sure I can switch it with Google Voice commands.

     

    11 minutes ago, Neo Andersson said:

    On the other hand, i am pretty sure, it doesn't need to be a "player" type device..it can be switch too.

    Just need some time for Googel and Fibaro to sync

    Maybe it would, I will see in a couple of days, but most of the time I am not that patient to wait 4~5 days for it to be like I want it to be. ?

    Link to comment
    Share on other sites

    • 0
    37 minutes ago, _Wilco_ said:

    Yes, I know. ? That's step two. But I had to be sure I can switch it with Google Voice commands.

     

    Maybe it would, I will see in a couple of days, but most of the time I am not that patient to wait 4~5 days for it to be like I want it to be. ?

    Yes, ofcourse you can. At the moment it is recognized as a switch, you can always use the turn On voice command

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 18 minutes ago, Neo Andersson said:

    Yes, ofcourse you can.

    I wasn't convinced about that (as for why I opened this topic), because al QA's are showing as "lamp", Google groups all "Lamp" devices per location in one group.

    Please login or register to see this image.

    /monthly_2022_04/image.png.1f9c803746c1bee5422d46b1ac833856.png" />

     

    So when I say "Hey Google turn on the light", Google turns all devices in that group on even though some of them aren't lights. So the have to be of another type ("Switch") to be shown separately.

     

    But now I've seen it is possible with the "Player" type (or maybe the "Binary Switch" after a couple of days) I can start implementing the actual code for actions.

     

    Thanks

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Today al my "Binary Switch" QA's are turned from "Licht" to "Switch" in Google Home. Also the the "Multilevel Switch" has been added.

    I still think it is a strange behavior that it has to take a couple of day to change to the actual type.

     

    Please login or register to see this image.

    /monthly_2022_04/image.png.6d306e06a9546263f78f7695b5979f73.png" />

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • ? I now still have some binary switches that are shown as lamp even after 10 days. There seems to be some inconsistency. I hope Fibaro can fix this. I now if I have an idea to implement some thing using a binary switch, I have to wait days before I can actually use it in "production".

    Link to comment
    Share on other sites

    • 0

    Hello

     

    First to sync device use command ok google sync my device - then you dont need wait few days

    We look on device type

    for com.fibaro.binarySwitch we will show nomal switch

    for com.fibaro.multilevelSwitch we will show dimmer (on, off + slider)

     

    Not all type are supported by google and in this integration. We are waiting when google will finish integration, Last time the changed some API and temperature sensor and few others stopping works

    You will see flood, temaparure sensor sensor bo no action, no icon, no push no checking state will work

     

    We look on role and category too is that light or other plug, is that blind or shutter etc

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I used the Google "sync devices" command, and "binary switch" devices do show in Google Home. But the problem is that they are shown as "lamp" device and there by grouped as "lights" so when I say "hey Google, turn on the lights", al those binary switches are also turned on.

    I don't understand why these can't be recognized as a switch immediately, (like the Homey does) but eventually in a undefined couple of days do change in to switches.

    Link to comment
    Share on other sites

    • 0
    On 4/19/2022 at 1:28 PM, A.Socha said:

    Hello

     

    First to sync device use command ok google sync my device - then you dont need wait few days

    We look on device type

    for com.fibaro.binarySwitch we will show nomal switch

    for com.fibaro.multilevelSwitch we will show dimmer (on, off + slider)

     

    Not all type are supported by google and in this integration. We are waiting when google will finish integration, Last time the changed some API and temperature sensor and few others stopping works

    You will see flood, temaparure sensor sensor bo no action, no icon, no push no checking state will work

     

    We look on role and category too is that light or other plug, is that blind or shutter etc

     

    Hello

    Unfortunatelly that is not true. sync device doesnt make the job. It should, but it doesnt. Syncing devices doesnt make the difference. Only after a few days are some changes applied. An also, all the roles and device types must be changed.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...